slow cursor issue

You have a problem with Salix? Post here and we'll do what we can to help.

slow cursor issue

Postby hugok » 27. Oct 2012, 23:09

Using the browser, whatever using firefox or midori, the cursor is slow to move across the screen during the loading of the web page... any help??
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal

Re: slow cursor issue

Postby hugok » 30. Oct 2012, 12:50

This issue only happens with the facebook web page... :?

Probably this problem is caused by my slow internet speed.... :roll:
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal

Re: slow cursor issue

Postby GJones » 31. Oct 2012, 02:46

This is probably graphics driver stuff. Are you using an Intel 965 GMA graphics chipset?

That chipset gets cursor lag whenever there's a CPU spike (like when rendering JS-intensive web pages such as Facebook). I believe it's been that way since KMS was implemented, and as far as I know there is no solution. You could try this workaround:

viewtopic.php?f=24&t=2856

which in my experience works for *some* Intel chipsets on *some* kernels.

OTOH, if it's an old Radeon chipset, you might be able to just turn off KMS. I have a Pentium 4 laptop whose Radeon chipset lags like mad with KMS, and is faster on Linux than on Windows without... No idea why.

(But sadly you cannot turn off KMS on Intel chipsets. I know it's the Light, the Way, and the Future, but it still has some pretty big performance issues IMO - even on the latest version of Ubuntu, let alone Salix 13.37.)
GJones
 
Posts: 274
Joined: 22. Jul 2011, 23:27

Re: slow cursor issue

Postby hugok » 1. Nov 2012, 00:40

My laptop use a VIA-Chrome9-HC-IGP-Family-WDDM graphic driver. Its a very weak Graphic chipset (for ex: don't support gnome 3).

How can i resolve that with this Graphic chipset?
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal

Re: slow cursor issue

Postby GJones » 2. Nov 2012, 04:42

No idea. I still suspect it's a bug (anything remotely modern should be able to render a website without lagging like that).

OTOH... is it possible that the system is eating into swap space while you're browsing? Because that is guaranteed to create lag.
GJones
 
Posts: 274
Joined: 22. Jul 2011, 23:27

Re: slow cursor issue

Postby hugok » 4. Nov 2012, 17:34

This is real annoying having this lag movement of the mouse cursor. it's difficult to browsing this way!!!
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal

Re: slow cursor issue

Postby hugok » 7. Nov 2012, 14:42

I really have to go back to the version 13.37. Its very difficult to browse this way, having a really lag mouse pointer!! I'm doing a very slow translation in transifex because of that anoying issue!! :roll:
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal

Re: slow cursor issue

Postby hugok » 20. Jun 2013, 17:05

I installed google-chrome to resolve the lag while surfing the internet.
# Hugo Carvalho - From Porto, Portugal.
# Linux user since 2008.
User avatar
hugok
 
Posts: 102
Joined: 7. Dec 2011, 22:44
Location: Porto, Portugal


Return to Problems