Xfce Workplace Switcher Pager

You have a problem with Salix? Post here and we'll do what we can to help.

Xfce Workplace Switcher Pager

Postby sqlpython » 3. Mar 2011, 17:08

Maybe someone will help me to locate the config for the Workplace Switcher (PAGER)..
I have an XFCE 4.4 install and I added the Workplace Switcher with 4 Desktops to my Panel.
I have checked the Property to Show Names then through the Xfce Setting Manger I edit the names to display
Desk 1..Desk 2..Desk 3..Desk 4
This works until I reboot where the labels promptly change back to the Default Names of
Workspace 1..Workspace 2.. Workspace 3..Workspace 4..

How can I make my changes permanent? I have searched the Configs for an entry to make My changes permanent.
Debian ( #! . Jessie 8,, Sid ) Salix Xfce 14, Gentoo, Bridge
User avatar
sqlpython
 
Posts: 283
Joined: 13. Aug 2010, 04:53
Location: Ct. USA

Re: Xfce Workplace Switcher Pager

Postby Shador » 3. Mar 2011, 18:58

I think you need to tick an option named "Save settings" or similar in the logout dialogue.
Image
Shador
 
Posts: 1295
Joined: 11. Jun 2009, 14:04
Location: Bavaria

Re: Xfce Workplace Switcher Pager

Postby sqlpython » 3. Mar 2011, 22:22

Thanks for the replay but I don't see such a setting choice
Debian ( #! . Jessie 8,, Sid ) Salix Xfce 14, Gentoo, Bridge
User avatar
sqlpython
 
Posts: 283
Joined: 13. Aug 2010, 04:53
Location: Ct. USA

Re: Xfce Workplace Switcher Pager

Postby laprjns » 4. Mar 2011, 00:28

sqlpython wrote:Thanks for the replay but I don't see such a setting choice

When you log out, it's at the bottom of the dialog box that comes up with choices of Shutdown, Restart Logout etc. It called 'Save session for future logins"
User avatar
laprjns
Salix Warrior
 
Posts: 626
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Xfce Workplace Switcher Pager

Postby sqlpython » 4. Mar 2011, 03:41

When you log out, it's at the bottom of the dialog box that comes up with choices of Shutdown, Restart Logout etc. It called 'Save session for future logins"


Thank You
Never noticed the Tic Box... I check it and it did work but not exactly as I expected..
It did cure the WorkSpace Naming issue
When I next logged in I was presented after the Password with a [Session Choice Box}..
..At the top/heading of the box was
Default Session
..At the bottom 2 buttons to choose from
LogOut and New Session

I misunderstood the box
I thought that I could only LogOut or Create a New Session
...But I could have actually Clicked on the Heading [Default Session] which I thought was only Descriptive Text.
So I clicked to Create/Add a Session and I ended up with 2 Sessions
Default and Default2
So while I have the WorkSpaces on the Pager Named as I would like.
I also have an additional step to loging to the Desktop. As I must now also choose a Session... arrggghhh

So How do I rid my self of the additional Session?
Xfce is one Desktop that I have spent little time using over the years.
Debian ( #! . Jessie 8,, Sid ) Salix Xfce 14, Gentoo, Bridge
User avatar
sqlpython
 
Posts: 283
Joined: 13. Aug 2010, 04:53
Location: Ct. USA

Re: Xfce Workplace Switcher Pager

Postby sqlpython » 4. Mar 2011, 05:10

In the end I logged back into the 2nd created Session to eliminate it..
I had named that Session Default1
To do this I edited /.cache/sessions/xfce4-session-bobssl410:0
File with gedit and removed all references to [Default1]
Then as logout of the Default1 session I unchecked the save session Tic Box in the logout GUI..
So back to One Default Session choice but still an extra logon step..
Ideally, I would have wanted to just been able to save the names in the Workspace Pager without saving the session..
I may yet go back to No Names in the pager to eliminate the Extra Logon Step.

However I really appreciate the Workaround. :) At least I know there is one way to keep the names in the Pager Constant.
Debian ( #! . Jessie 8,, Sid ) Salix Xfce 14, Gentoo, Bridge
User avatar
sqlpython
 
Posts: 283
Joined: 13. Aug 2010, 04:53
Location: Ct. USA


Return to Problems