Search found 6232 matches

by gapan
25. Feb 2024, 18:24
Forum: Problems
Topic: Newest llvm update fails
Replies: 12
Views: 216

Re: Newest llvm update fails

Well, I seem to have found another bug in slapt-get. Even though the llvm-17.0 package included llvm13-compat in its dependencies, slapt-get reads the dependencies for the llvm-13.0 package instead, even for the llvm-17.0 package. I had to add llvm13-compat to both 13 and 17 versions, since everyone...
by gapan
25. Feb 2024, 17:18
Forum: Problems
Topic: Newest llvm update fails
Replies: 12
Views: 216

Re: Newest llvm update fails

Yes, laprjns, you're right. I had noticed that too. The llvm-17.0 package depends on llvm13-compat since a couple of days ago. But everyone who had upgraded before I added the dependency didn't get it. I wanted to post about it, but kept forgetting to. EDIT: I just checked that I had actually applie...
by gapan
23. Feb 2024, 07:36
Forum: Package requests
Topic: Thunderbird pre-Stupernova
Replies: 7
Views: 141

Re: Thunderbird pre-Stupernova

That's another option. That's not a package. That's just a binary tarball. You can just extract it somewhere, anywhere, and run it from there. Right click, Extract here, go into the folder it creates and run the binary.
by gapan
22. Feb 2024, 22:14
Forum: Package requests
Topic: Thunderbird pre-Stupernova
Replies: 7
Views: 141

Re: Thunderbird pre-Stupernova

You can get 102.13.0 from here: https://backup.salixos.org/monthly.5/repo/x86_64/slackware-15.0/patches/packages/ Get it while it's still there and keep a copy locally. If you want any other version, you'll have to build it yourself as djemos suggested. It's not that hard. edit: more versions availa...
by gapan
20. Feb 2024, 12:06
Forum: Problems
Topic: Newest llvm update fails
Replies: 12
Views: 216

Re: Newest llvm update fails

I agree it's wrong the way it is, but it's been like that for ever. I doubt slackware will change it anytime soon.
by gapan
20. Feb 2024, 10:44
Forum: Problems
Topic: Newest llvm update fails
Replies: 12
Views: 216

Re: Newest llvm update fails

OK, I just worked around the md5 issue in our repos too. So, it should just work when your mirror syncs. But it's still something that should be fixed in slapt-get, only just because right now slapt-get won't work with the original slackware repositories, although it will work with the slackware rep...
by gapan
20. Feb 2024, 10:34
Forum: Problems
Topic: Newest llvm update fails
Replies: 12
Views: 216

Re: Newest llvm update fails

OK, I can confirm this too. I actually saw it yesterday but I thought it was probably a temporary glitch with syncing mirrors so I didn't think much about it. But it turns out it's a combination of issues. 1. it's the first (?) time slackware puts a package straight in the /extra/ directory, instead...
by gapan
19. Feb 2024, 07:59
Forum: Announcements
Topic: New registrations/Users with zero posts
Replies: 11
Views: 14211

Re: New registrations/Users with zero posts

I just enabled user registration in the forums again. Let's see how that goes.
by gapan
16. Feb 2024, 08:36
Forum: Problems
Topic: LightDM config options
Replies: 1
Views: 114

Re: LightDM config options

I don't think so. Closest are probably these: $ grep script /etc/lightdm/lightdm.conf # guest-account-script = Script to be run to setup guest account #guest-account-script=guest-account # session-wrapper = Wrapper script to run session with # greeter-wrapper = Wrapper script to run greeter with # g...
by gapan
13. Feb 2024, 18:46
Forum: Problems
Topic: Panel update notifier icon
Replies: 10
Views: 290

Re: Panel update notifier icon

If the problem only shows with some themes, I'm going to go with: it's a problem with the theme. You need to check exactly what other themes the one you're using needs: look for an "Inherits" line in each theme's /usr/share/icons/themename/index.theme file. Most themes probably need the ad...