I'm not a robot.

Introduce yourself, create test postings or talk nonsense
User avatar
miredia
Posts: 25
Joined: 6. Oct 2022, 10:20

Re: I'm not a robot.

Post by miredia » 4. Nov 2022, 17:15

Papasot wrote:
4. Nov 2022, 12:20
Salix and XFCE should work well on that machine, but it might be your hardware's driver that causes this "brightness reset" to maximum everytime X starts. I had the same problem in the past with a "Sandy Bridge" GPU. There are many ways to fix this (such as xbrightness, backlight-brightness and others,) but the one that will always work is as follows.
First you need to identify your screen output. Run, in a terminal:

Code: Select all

xrandr --prop | grep "connected"
You should see something like

Code: Select all

LVDS-1 connected primary 1024x600+0+0 ...
What you need is the name before "connected" - in my case that's "LVDS-1", replace as appropriate. Now, you can set the brightness to, say, half the maximum with

Code: Select all

xrandr --output LVDS-1 --brightness 0.5
Find a brightness level you feel comfortable with. Now you need to tell your WM to execute this command every time it starts. This depends on the WM, but a way that should work no matter what is to put the command above in your ~/.xinitrc. Set it and forget it.
All that without a DM running - I never use DMs so I am not sure if that changes anything.
Thank you very much for this tip. It's better than nothing, but otherwise cannot have a setting which works together with the special function keys, and without "systemd". The "xbacklight" program reports it doesn't work on my laptop, that might have been better.

User avatar
gapan
Salix Wizard
Posts: 6071
Joined: 6. Jun 2009, 17:40

Re: I'm not a robot.

Post by gapan » 6. Nov 2022, 16:03

miredia, you might take a look at this: https://askubuntu.com/questions/1150339 ... ing-xrandr

You can then assign that script to your brightness keys.
Image
Image

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: I'm not a robot.

Post by djemos » 6. Nov 2022, 20:59

@miredia, what is your gpu, intel or amdgpu?
If you have an amdgpu then xbacklight works only for intel gpu.
Install acpilight

after install the package type

Code: Select all

sudo cp /etc/udev/rules.d/90-backlight.rules.new /etc/udev/rules.d/90-backlight.rules

User avatar
miredia
Posts: 25
Joined: 6. Oct 2022, 10:20

Re: I'm not a robot.

Post by miredia » 7. Nov 2022, 01:35

Thank you for the replies!

I have run "xbacklight" program, is that what "acplight" installs? It reports: "No outputs have backlight property".

I have a 10-year-old Hewlett-Packard laptop which originally had Windows8 installed. Now it has Windows10 2H21 or whatever (almost not going into it any longer), Salix 42GB partition, Slackware (not "-current") 32-bit 42GB partition, Manjaro MATE 32GB partition and 4GB "swap".

Code: Select all

                   :::::::                    
             :::::::::::::::::::               xx@darkstar.example.net
          :::::::::::::::::::::::::            OS: Slackware 
        ::::::::cllcccccllllllll::::::         Kernel: x86_64 Linux 5.15.63
     :::::::::lc               dc:::::::       Uptime: 11m
    ::::::::cl   clllccllll    oc:::::::::     Packages: 898
   :::::::::o   lc::::::::co   oc::::::::::    Shell: bash 5.1.16
  ::::::::::o    cccclc:::::clcc::::::::::::   Resolution: 1366x768
  :::::::::::lc        cclccclc:::::::::::::   DE: Xfce4
 ::::::::::::::lcclcc          lc::::::::::::  WM: Xfwm4
 ::::::::::cclcc:::::lccclc     oc:::::::::::  WM Theme: Salix
 ::::::::::o    l::::::::::l    lc:::::::::::  GTK Theme: Salix [GTK2]
  :::::cll:o     clcllcccll     o:::::::::::   Icon Theme: Qogir-dark-panel
  :::::occ:o                  clc:::::::::::   Font: Sans 10
   ::::ocl:ccslclccclclccclclc:::::::::::::    Disk: 47G / 397G (12%)
    :::oclcccccccccccccllllllllllllll:::::     CPU: Intel Pentium B980 @ 2x 2.4GHz [46.0°C]
     ::lcc1lcccccccccccccccccccccccco::::      GPU: Mesa DRI Intel(R) HD Graphics 2000 (SNB GT1)
       ::::::::::::::::::::::::::::::::        RAM: 638MiB / 3809MiB
         ::::::::::::::::::::::::::::         
            ::::::::::::::::::::::            
                 ::::::::::::                 
I'm sorry for taking this off topic...

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: I'm not a robot.

Post by djemos » 7. Nov 2022, 09:28

OK. I also have a HP g62 old laptop where after your post i typed xbacklight and it reports: "No outputs have backlight property".

Code: Select all

djemos@slackel-hp.example.net 
       #######          ----------------------------- 
       ##O#O##          OS: Slackel Linux 5.16.9 x86_64 
       #######          Host: Hewlett-Packard 1439 
     ###########        Kernel: 5.16.9 
    #############       Uptime: 27 mins 
   ###############      Packages: 1223 (pkgtool) 
   ################     Shell: bash 5.1.16 
  #################     Resolution: 1366x768 
#####################   WM: Openbox 
#####################   WM Theme: Clearlooks-Olive 
  #################     Theme: Adwaita [GTK2/3] 
                        Icons: matefaenza [GTK2/3] 
                        Terminal: lxterminal 
                        Terminal Font: Terminus 12 
                        CPU: Intel Pentium P6100 (2) @ 1.999GHz 
                        GPU: Intel Core Processor 
                        Memory: 755MiB / 1835MiB
So i created the file /etc/X11/xorg.conf.d/20-intel.conf
and i paste the contents

Code: Select all

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "Backlight" "intel_backlight"
EndSection

If you have installed acpilight then remove it. Then reinstall xbacklight.

Then restart X (log out and log in)
I typed
xbacklight -30
xbacklight +30
It is working.

User avatar
miredia
Posts: 25
Joined: 6. Oct 2022, 10:20

Re: I'm not a robot.

Post by miredia » 8. Nov 2022, 02:55

Papasot wrote:
4. Nov 2022, 12:20
Find a brightness level you feel comfortable with. Now you need to tell your WM to execute this command every time it starts. This depends on the WM, but a way that should work no matter what is to put the command above in your ~/.xinitrc. Set it and forget it.
All that without a DM running - I never use DMs so I am not sure if that changes anything.
Hi Papasot. I have done what you suggested but my system still starts with maximum brightness of the screen because I do have a desktop environment with Salix, the standard one it comes with which is XFCE.

I have put a line similar to the following into "~/.xinitrc":

Code: Select all

xrandr --output LVDS-1 --brightness 0.5
gapan wrote:
6. Nov 2022, 16:03
miredia, you might take a look at this: https://askubuntu.com/questions/1150339 ... ing-xrandr

You can then assign that script to your brightness keys.
Hi gapan. Thank you for this, it will be very helpful.
djemos wrote:
7. Nov 2022, 09:28
If you have installed acpilight then remove it. Then reinstall xbacklight.

Then restart X (log out and log in)
I typed
xbacklight -30
xbacklight +30
It is working.
Hi djemos. I have followed these instructions but "xbacklight" program comes back with the same error message as before.

Post Reply