"p" and semicolon key specifically on my laptop won't work

You think you have found a bug? Let us know about it.

"p" and semicolon key specifically on my laptop won't work

Postby easy » 17. Jan 2017, 03:24

prior to this--and after this, having reinstalled debian--the keyboard on my Asus laptop has functioned perfectly. The funny thing is, if I plug in a usb keyboard, it'll work just fine in Salix. My laptop keyboard specifically, I hate to say, and which I might add looks identical to most other laptop keyboards in the US market, is perfectly compatible with Salix in all respects notwithstanding my "p" and semicolon key.

It's really strange, because it works perfectly on the live cd, and, when I configure my keyboard layout in the installer, it works fine, but those two keys won't do what I want them to; instead, my "p" key places an asterisk regardless of whether or not I hold the shift key, and my semicolon key does the same except with a dash. I've reconfigured my keyboard layout, ofcourse--both when installing the system (I used uk qwerty and us dvorak) and through the de configuration. I've installed multiple versions of Salix paired with the same de, and I've installed several different implementations of salix with different de's.

I'm not mad or anything: I just think it's really strange how the only thing that's soiled my install of Salix is a simple "p" key. I don't even really care about semicolons that much. I pressed all the keys in notepad to see what output they had, and none of them result in the letter "p". It's unfortunate to say that I might have to give up Salix just because of a single character--but I really like the letter "p". I can't live without it, so this post is also sort of a fairwell to Salix. I think it's a really cool project, though, and I appreciate what all you all are doing, and I hope you keep up the good work! But this is the end for me. Thanks for reading my post.
easy
 
Posts: 1
Joined: 17. Jan 2017, 03:07

Re: "p" and semicolon key specifically on my laptop won't wo

Postby gapan » 17. Jan 2017, 09:29

One word: Numlock.
Image
Image
User avatar
gapan
Salix Wizard
 
Posts: 5132
Joined: 6. Jun 2009, 17:40

Re: "p" and semicolon key specifically on my laptop won't wo

Postby ChuangTzu » 17. Jan 2017, 19:45

wow, 1 post, one question/complaint and your ready to say "that's it". With an attitude like that I don't think GNU/Linux (and definitely not BSD) is right for you. Inquiring minds are welcome; rage quit rant posts really should wait until you are a little more wet behind the ears. ;)
User avatar
ChuangTzu
Donor
 
Posts: 195
Joined: 19. May 2015, 23:34

Re: "p" and semicolon key specifically on my laptop won't wo

Postby maximus » 18. Jan 2017, 09:05

gapan wrote:One word: Numlock.


Image
User avatar
maximus
 
Posts: 134
Joined: 2. Sep 2009, 01:41

Re: "p" and semicolon key specifically on my laptop won't wo

Postby mimosa » 18. Jan 2017, 17:57

That has actually happened to me. And of course, the afflicted keyboard is unlikely to have a numlock key or light.
User avatar
mimosa
Salix Warrior
 
Posts: 2763
Joined: 25. May 2010, 17:02

Re: "p" and semicolon key specifically on my laptop won't wo

Postby laprjns » 19. Jan 2017, 01:37

easy wrote:....when I configure my keyboard layout in the installer, it works fine, but those two keys won't do what I want them to...

Let's assume that mimosa is correct and your keyboard has no numlock key. Did you know this before you installed Salix? if so you obviously missed this during the installation:
Image
Changing to "Disable" would have avoided your problem altogether. But let assume again, that you clicked right through that without realizing it. It happens even momosia appearently has done this in the past ;) Once you discovered your problem you could have asked here and waited to get some help. But no, you just dropped you post and declared that it th end for you.
Had you stayed around there are at lest two ways that we could have helped. First, you could have reinstalled making the correct choice (Disable) at the numlock dialog box. Or you could have edited a configuration file. As an example, in XFCE your could have edited the keyboards.xml file in ~/.config/xfce4/xfconf/xfce-perchannel-xml/ changing the "true' to "false" in the line:
Code: Select all
<property name="Numlock" type="bool" value="true"/>

I'm not mad or anything, I just think it's strange that you visited the forum once, took a whole 19 seconds to post you problem and accused Salix for "soiling" your install when its obvious that it was your own inattention to the installation process that causes the issue.
User avatar
laprjns
Salix Warrior
 
Posts: 958
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA


Return to Bugs