Geany terminal configuration (with solution)

You think you have found a bug? Let us know about it.
Post Reply
DrCR
Posts: 41
Joined: 30. May 2014, 05:14

Geany terminal configuration (with solution)

Post by DrCR » 30. Jun 2019, 06:39

When using Geany for the first time to create a bash script, I encountered an error when attempting to execute in Geany (i.e. via F5 shortcut) the saved bash script.
"Cannot execute build command "x-terminal-emulator -e "/bin/sh /tmp/geany_run_script_abc123.sh" ": No such file or directory. Check the Terminal setting in Preferences"

Solution: Executing successfully once I changed the Terminal field in Settings > Tools to: /usr/bin/xfce4-terminal -e "/bin/sh %c"
(If I recall correctly, it was originally set to: x-terminal-emulator -e "/bin/sh %c" )

User avatar
gapan
Salix Wizard
Posts: 5532
Joined: 6. Jun 2009, 17:40

Re: Geany terminal configuration (with solution)

Post by gapan » 30. Jun 2019, 21:40

That looks like a setting that you carried over from a debian based distribution. It isn't an issue with a fresh install of Salix.
Image
Image

DrCR
Posts: 41
Joined: 30. May 2014, 05:14

Re: Geany terminal configuration (with solution)

Post by DrCR » 2. Jul 2019, 23:51

Cool. Not sure what transpired as my install of Salix was a fresh one, back however long ago (years?) I installed it.

User avatar
Artim
Donor
Posts: 29
Joined: 9. Feb 2019, 13:21
Contact:

Re: Geany terminal configuration (with solution)

Post by Artim » 3. Jul 2019, 08:22

If you preserved your /home or /data partition while installing Salix, some settings and stuff may have carried over.

Post Reply