[SOLVED]depfinder bug with gtk+3

You think you have found a bug? Let us know about it.
Post Reply
01micko
Posts: 2
Joined: 8. Oct 2012, 20:22

[SOLVED]depfinder bug with gtk+3

Post by 01micko » 8. Oct 2012, 20:44

Hello

I think there is a bug with depfinder and gtk+3 in some instances.

For example, in ${repo}/i486/slackware-14.0/PACKAGES.TXT under audacious and audacious-plugins, gtk+2 is listed as a dependency however it requires gtk+3. Further down though, network-manager-applet lists that gtk+3 is required (doing a quick ldd on nm-applet and libnm-gtk.so.0.0.0 appears it needs gtk+2).

I realise that it is early days with slackware-14. Thanks for your work.

Regards
Last edited by 01micko on 11. Oct 2012, 21:23, edited 1 time in total.

User avatar
gapan
Salix Wizard
Posts: 5359
Joined: 6. Jun 2009, 17:40

Re: depfinder bug with gtk+3

Post by gapan » 11. Oct 2012, 12:49

Thanks for the report. This is not a bug with depfinder though. It's just that at the time that I ran depfinder on those packages, audacious was built against gtk+2 and network-manager-applet was built against gtk+3. That changed with succeeding package updates and the dependencies were not updated. I have fixed these ones now, if you find any more like these, please report them too.
Image
Image

01micko
Posts: 2
Joined: 8. Oct 2012, 20:22

Re: depfinder bug with gtk+3

Post by 01micko » 11. Oct 2012, 21:22

Hello gapan

Thanks for your response and solution. If I find any more abnormalities I will report them.

Regards

Post Reply