Mozilla-Firefox 45.1.1 crashes using web browser launcher

You think you have found a bug? Let us know about it.
Post Reply
User avatar
lucky9
Posts: 21
Joined: 31. Jul 2014, 16:16

Mozilla-Firefox 45.1.1 crashes using web browser launcher

Post by lucky9 » 15. May 2016, 14:35

Mozilla-Firefox 45.1.1 crashes using Salix64-xfce-14.1 web browser launcher
When using the web browser launcher - the world icon with pointer - firefox either crashes or restore session page opens. This happens with my old .mozilla folder or a new clean folder. If I use the firefox launcher everything works fine.
This happens on both my machines, laptop and desktop.
HP DC7800 SFF | 2.33GHz Intel Core 2 Duo | Salix64-Xfce-14.1

User avatar
gapan
Salix Wizard
Posts: 5359
Joined: 6. Jun 2009, 17:40

Re: Mozilla-Firefox 45.1.1 crashes using web browser launche

Post by gapan » 15. May 2016, 22:12

I can confirm this... sort of. In a Salix-Xfce-14.1 installation which didn't have firefox installed previously, I installed it and selected it as the default web browser from the app in the Settings menu. The launcher in the taskbar would not start it. Same with the Web Browser option in the main menu and also by running

Code: Select all

exo-open --launch WebBrowser
from the terminal.

I upgraded exo to version 0.10.7 (in place of 0.10.2) and it now worked. The weird thing is that reverting back to the 0.10.2 package, it still works! I'm not sure what to make of this.

In any case, I uploaded the exo-0.10.7 packages to the 14.1 repos. You should get them as soon as your mirror syncs. Please report if it fixes it for you too.
Image
Image

User avatar
lucky9
Posts: 21
Joined: 31. Jul 2014, 16:16

Re: Mozilla-Firefox 45.1.1 crashes using web browser launche

Post by lucky9 » 16. May 2016, 16:36

Thanks gapan.
Updated exo now it's working fine.
HP DC7800 SFF | 2.33GHz Intel Core 2 Duo | Salix64-Xfce-14.1

Post Reply