Missing dependencies for package deluge in 14.2 rc2.

You think you have found a bug? Let us know about it.
Post Reply
User avatar
Papasot
Donor
Posts: 105
Joined: 3. May 2015, 18:37
Location: Patras, Greece

Missing dependencies for package deluge in 14.2 rc2.

Post by Papasot » 15. Aug 2016, 12:54

The BitTorent client deluge has two missing dependencies in Salix 14.2 rc2. Specifically, the packages zope.interface and python-cffi are required. Note that deluge was installed without any missing dependencies in 14.1.
A pleasant detail in this forum: several people pick a picture of their pet as their avatar. Who am I to do otherwise? ;-)

User avatar
laprjns
Salix Warrior
Posts: 1028
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Missing dependencies for package deluge in 14.2 rc2.

Post by laprjns » 15. Aug 2016, 23:28

Yes confirmed here. The zope,interface package was part of the iso in 14.1. Not sure about python-cffi. its not part of my 14.1 and dulge still works. Anyway the depend list for deluge will be updated.

djemos
Salix Warrior
Posts: 1036
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Missing dependencies for package deluge in 14.2 rc2.

Post by djemos » 16. Aug 2016, 19:53

There is a new version of deluge 1.3.13 which is better. I will upload it on package submissions as soon as i have time.

User avatar
gapan
Salix Wizard
Posts: 5411
Joined: 6. Jun 2009, 17:40

Re: Missing dependencies for package deluge in 14.2 rc2.

Post by gapan » 19. Aug 2016, 14:22

I just updated the dep list on the repos. Thanks Papasot!

djemos, if you will submit a new package, please see if these are still needed.
Image
Image

Post Reply