firewall does not stay enabled

You think you have found a bug? Let us know about it.
Post Reply
glacy924
Posts: 2
Joined: 17. Jan 2017, 11:18

firewall does not stay enabled

Post by glacy924 » 17. Jan 2017, 11:33

Numerous times I enabled the firewall on the command line (sudo ufw enable) and Gufw.

They both become inactive after a reboot, despite the command line (for one) displays "Firewall is active and enabled on system startup" after enabling it.

What could be the problem?

Thanks.

User avatar
mimosa
Salix Warrior
Posts: 3028
Joined: 25. May 2010, 17:02
Contact:

Re: firewall does not stay enabled

Post by mimosa » 17. Jan 2017, 11:49

Try

Code: Select all

sudo service start ufw

glacy924
Posts: 2
Joined: 17. Jan 2017, 11:18

Re: firewall does not stay enabled

Post by glacy924 » 17. Jan 2017, 14:44

response:
chmod: cannot access '/etc/rc.d/rc.ufw': No such file or directory

User avatar
mimosa
Salix Warrior
Posts: 3028
Joined: 25. May 2010, 17:02
Contact:

Re: firewall does not stay enabled

Post by mimosa » 17. Jan 2017, 15:11

Ah, maybe ufw isn't one of the standard services - in which case, you can probably find a suitable rc.ufw script by searching online. Just put it in /etc/rc.d, make it executable, and you should be good to go.

EDIT

The ufw in Salix repositories includes a basic rc.ufw script. Perhaps you installed ufw from elsewhere? I suggest you reinstall it anyway, and that should leave you with an up to date Salix package.

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: firewall does not stay enabled

Post by DidierSpaier » 17. Jan 2017, 16:46

Try the instructions here.Or, as said mimosa, name the script /etc/rc.d/uc.ufw and manage it with servicesetup or gtkservicesetup.

EDIT. Didn't see mimosa's EDIT before posting. Do what he suggests.

User avatar
ChuangTzu
Donor
Posts: 290
Joined: 19. May 2015, 23:34

Re: firewall does not stay enabled

Post by ChuangTzu » 17. Jan 2017, 19:41

A short visit to the wiki would solve this:

https://docs.salixos.org/wiki/Setup_basic_firewall

Post Reply