Reset Xfce to its default Salix state.

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
marilynlid
Posts: 1
Joined: 7. Jun 2018, 07:12

Reset Xfce to its default Salix state.

Post by marilynlid » 7. Jun 2018, 07:16

Hi fellow Salix users.

Yesterday a neighbor brought his computer to me "to fix it". He runs Salix 14.2 (I installed it some time ago). The problem was that Xfce won't start. Switching to console reveals X couldn't start because of a segmentation fault.
This is not a Salix bug or whatever. The user is not experienced on GNU/Linux, and I doubt he even knows what "sudo" is, but nevertheless he managed to somehow break Xfce. I don't know what he did, but anyway I had to fix it.
I switched to init 3, created a new user, and tried to startx from there; everything works. So I guessed something is wrong in user's ~/.config/xfce4. I renamed that directory, forcing Xfce to start with its default configuration, and indeed it works. This verifies that the user managed to mess up his ~/.config/xfce4.

What I want now is to reset Xfce to its default Salix state. Removing or renaming ~/.config/xfce4 resets Xfce to its default state, which is what you would see if you installed Xfce using Slackware or another third-party package; Salix logo, Salix menus, and several application icons are missing.
I'm sure the original Salix Xfce configuration is stored somewhere. My first guess was /usr/xdg. I tried to copy /usr/xdg/xfce4 to ~/.config/xfce4, but this is equivalent to removing ~/.config/xfce4: it resets Xfce to its default state. So my question is, where Salix stores its default configuration for Xfce? I tried to look up for files found in the default ~/.config/xfce4 created for a new user, but I couldn't find those elsewhere (my guess is they are compressed somewhere and Salix decompress them to ~/.config/xfce4 each time a new user is created).

User avatar
mimosa
Salix Warrior
Posts: 2999
Joined: 25. May 2010, 17:02
Contact:

Re: Reset Xfce to its default Salix state.

Post by mimosa » 7. Jun 2018, 07:29

The template for a freshly minted user is in /etc/skel, so copying the contents over to /home/$USER should do it. The best way to do that is probably with rsync.

Post Reply