Purple-facebook plugin Invalid HTTP response code (400)

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 10. Mar 2020, 11:42

The purple I installed generates the error code as in subject. I found this fix https://github.com/dequis/purple-facebo ... b74a765767 - should I rebuild this with sorcery or myself or using sbo scripts?

User avatar
mimosa
Salix Warrior
Posts: 3123
Joined: 25. May 2010, 17:02
Contact:

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by mimosa » 10. Mar 2020, 21:08

The version currently available at Sbo is 9.5. The version you installed is an older build from Salix's extra repository. It may be that when gapan sees this he will update it. But are you sure it will fix the problem you're seeing?

The latest version from the github repo you linked to is actually 9.6, but it is a lot more recent than 9.5 (that is there was a big gap between those versions, and the slackbuild might need some work to build the latest one), so that might be a safer option if you want to build it yourself. To do so, download the buildscript and files from sbo (edit the slackbuild if you want a different version, and make sure you have the corresponding source too). Upgrade to the package you built using spkg. Then exclude the package in gslapt, or it'll be downgraded again.

igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 10. Mar 2020, 21:19

Thanks for reply. I will do as you suggested. I don't know the problem will be fixed. Just at moment pidgin does not work with my facebook account - I have a couple of people who are using facebook messenger. To use web interface in situation Firefox is running on about 700MB RAM - well is not in my style. Essentially I need instant messaging app which is capable to work with facebook. I have a look at some options - at this moment pidigin seems to be simplest solution.

User avatar
mimosa
Salix Warrior
Posts: 3123
Joined: 25. May 2010, 17:02
Contact:

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by mimosa » 10. Mar 2020, 22:27

I don't have Facebook myself, and I don't know if this will work, but it might be worth a try too:
https://www.npmjs.com/package/fb-messenger-cli
It looks like to install it, you just need the nodejs package from the repositories.

PelleB
Posts: 54
Joined: 21. Sep 2010, 05:44

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by PelleB » 11. Mar 2020, 06:50

I think you have to use the latest version of Pidgin (2.13) probably combined with the latest purple-facebook, to make it work.

Per B.

igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 11. Mar 2020, 09:50

mimosa wrote:
10. Mar 2020, 22:27
I don't have Facebook myself, and I don't know if this will work, but it might be worth a try too:
https://www.npmjs.com/package/fb-messenger-cli
It does not work on 32 bit system. As dependency it installs chrome application which is 64 bit (sic!). What is really laughable npm describe itself as intelligently resolving dependencies.

igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 11. Mar 2020, 10:23

Can I use sourcery to build sbo scripts?

igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 11. Mar 2020, 11:18

Ok brutal force worked. Installed version of Pidgin from -current. To work you need -current version of libidn. Then just built purple-facebook from sbo with dependencies - it works. Ugly but works.

User avatar
mimosa
Salix Warrior
Posts: 3123
Joined: 25. May 2010, 17:02
Contact:

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by mimosa » 11. Mar 2020, 12:03

Glad you found a workable solution!

In answer to your question - that is what Sourcery does (builds from Sbo). The problem is if you want a different version; commonly, it's enough just to edit the SlackBuild with the new version number, but to do this, you will need to run the build manually. The added complication here is that Salix's /extra repo trumps Sbo:
https://blog.salixos.org/post/our-new-extra-repository/

igadoter
Posts: 10
Joined: 8. Jan 2015, 23:42

Re: Purple-facebook plugin Invalid HTTP response code (400)

Post by igadoter » 12. Mar 2020, 10:50

To be clear I have now new and old libidn libraries. I didn't remove old version - I was afraid to broke dependency. I read blog. For missing sources there is slackware.uk mirror which archives not only scripts but sources as well.

Post Reply