Several question about 14.2 x64

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
User avatar
hatmaker
Posts: 1
Joined: 1. Dec 2021, 10:40

Several question about 14.2 x64

Post by hatmaker » 1. Dec 2021, 11:05

Hi, guys!
I've returned to using Salix 14.2 after a couple of years of absence. Tried several distros but they didn't work for me: some had font rendering issues (like, AntiX), some weird audio problems, etc. So I decided to return. I've grabbed x64 image from Sourceforge, installed the core system, add LXDE, got sbopkg, and installed a bunch of additional fresh software. Everything runs so smooth, I've even managed to compile and correctly start redshift, which wasn't possible on ubuntu 18.04/14.04 and the above-mentioned antiX. And then I noticed something:

- My PcManFM doesn't automount USB - flash drives. My system can clearly see them (through sudo fdisk -l) but they are invisible for FM. I've installed "gvfs" package, alongside udisks2 and still, nothing happens.

- During my booting process I get a weird message that goes something along the lines: "I cannot mount my root partition because it's not ext3" and I use ext4 fs. What's up with that?

- Screen blanking or blackening - i don't know how to call it properly (English isn't my mother tongue). I loved this trick in antiX where you can simply set, like 4 minutes of waiting before the screen turning off (getting black). Is it possible in Slackware without installing xscreensaver?

gksu: cannot start gslapt, gparted, and dotnew properly. What should i do/install to fix it? In deb - distros I had to install something like policykit-1-gnome, but here (in Slackware's world) I'm lost. I forgot everything or almost everything.

galmei
Posts: 126
Joined: 1. Jun 2018, 21:54

Re: Several question about 14.2 x64

Post by galmei » 1. Dec 2021, 16:23

Hello,
hatmaker wrote:
1. Dec 2021, 11:05
I've returned to using Salix 14.2 after a couple of years of absence. Tried several distros but they didn't work for me: [...]
Ah! The lost son!
hatmaker wrote:
1. Dec 2021, 11:05
I've grabbed x64 image from Sourceforge, installed the core system, [...]
and
hatmaker wrote:
1. Dec 2021, 11:05
My PcManFM doesn't automount USB - flash drives. My system can clearly see them (through sudo fdisk -l) but they are invisible for FM. I've installed "gvfs" package, alongside udisks2 and still, nothing happens.
Then you are one of the really tough ones and it is just a retorical question? Not so? Then I recommend a full-mode installation to solve the problem, so everything goes much easier.
hatmaker wrote:
1. Dec 2021, 11:05
During my booting process I get a weird message that goes something along the lines: "I cannot mount my root partition because it's not ext3" and I use ext4 fs. What's up with that?
If you are using LILO, then add

Code: Select all

rootfstype=ext4
to the append= line in /etc/lilo.conf and run sudo lilo; then boot. For other boot managers accordingly.
Before that you can test this by setting rootfstype=ext4 to the kernel boot line, e.g. at least:

Code: Select all

Salix rootfstype=ext4
hatmaker wrote:
1. Dec 2021, 11:05
Screen blanking or blackening - i don't know how to call it properly (English isn't my mother tongue). I loved this trick in antiX where you can simply set, like 4 minutes of waiting before the screen turning off (getting black). Is it possible in Slackware without installing xscreensaver?
Yes. The X server can do this.
To do this, create a file in the /etc/X11/xorg.conf.d directory with, for example, the name 50-serverflags.conf and the contents:

Code: Select all

Section "ServerFlags"
	Option		"BlankTime"      "0"
	Option		"StandbyTime"    "0"
	Option		"SuspendTime"    "0"
	Option		"OffTime"        "0"
EndSection
and replace the zeros with the desired times (in minutes). You must use superuser privileges to do this.

You should also read at least the man page (5) xorg.conf. But if you make up for a full-mode installation, xscreensaver will also be installed.

User avatar
gapan
Salix Wizard
Posts: 5768
Joined: 6. Jun 2009, 17:40

Re: Several question about 14.2 x64

Post by gapan » 1. Dec 2021, 18:57

Welcome!

You chose the hard way by installing core!
hatmaker wrote:
1. Dec 2021, 11:05
- My PcManFM doesn't automount USB - flash drives. My system can clearly see them (through sudo fdisk -l) but they are invisible for FM. I've installed "gvfs" package, alongside udisks2 and still, nothing happens.
Perhaps you might need to launch lxde with dbus-launch at the end of your ~/.xsession. You can test it by launching pcmanfm with dbus-launch:

Code: Select all

dbus-launch pcmanfm
hatmaker wrote:
1. Dec 2021, 11:05
- Screen blanking or blackening - i don't know how to call it properly (English isn't my mother tongue). I loved this trick in antiX where you can simply set, like 4 minutes of waiting before the screen turning off (getting black). Is it possible in Slackware without installing xscreensaver?
Xfce has an option for that in xfce4-power-manager. Not sure if LXDE has such an option somewhere else, but what galmei suggested should work anyway.
hatmaker wrote:
1. Dec 2021, 11:05
gksu: cannot start gslapt, gparted, and dotnew properly. What should i do/install to fix it? In deb - distros I had to install something like policykit-1-gnome, but here (in Slackware's world) I'm lost. I forgot everything or almost everything.
Install the gnsu package. Or ktsuss if you'd like to use the root password instead of your own.
Image
Image

User avatar
ivanovnegro
Donor
Posts: 20
Joined: 5. Jul 2021, 22:07

Re: Several question about 14.2 x64

Post by ivanovnegro » 1. Dec 2021, 20:07

hatmaker wrote:
1. Dec 2021, 11:05
- Screen blanking or blackening - i don't know how to call it properly (English isn't my mother tongue). I loved this trick in antiX where you can simply set, like 4 minutes of waiting before the screen turning off (getting black). Is it possible in Slackware without installing xscreensaver?.
LXDE can also use the Xfce power manager, just install it and set it to your desired settings, there is no need for xscreensaver or do as Galmei suggested. The package is called

Code: Select all

xfce4-power-manager

galmei
Posts: 126
Joined: 1. Jun 2018, 21:54

Re: Several question about 14.2 x64

Post by galmei » 3. Dec 2021, 14:15

ivanovnegro wrote:
1. Dec 2021, 20:07
LXDE can also use the Xfce power manager, just install it and set it to your desired settings, there is no need for xscreensaver or do as Galmei suggested. The package is called

Code: Select all

xfce4-power-manager
Thanks for bringing back to my mind the Xfce-power-manager. I had to hatmaker the opposite problem. I didn't want blanking, but steady display. After I had stalled xscreensaver as far as possible without success, I had set "xfce4-power-manager" to zero - also without success. But then I had remembered that the X server can take this influence on the blanking. With Option "BlankTime" "0" I have now success for a long time. In the meantime I renewed the hardware several times (for other reasons) and also the xscreensaver has been updated several times, nevertheless I still have to influence my Xfce desktop this way, because the annoying problem persists.

User avatar
ivanovnegro
Donor
Posts: 20
Joined: 5. Jul 2021, 22:07

Re: Several question about 14.2 x64

Post by ivanovnegro » 3. Dec 2021, 16:10

galmei wrote:
3. Dec 2021, 14:15
Thanks for bringing back to my mind the Xfce-power-manager. I had to hatmaker the opposite problem. I didn't want blanking, but steady display. After I had stalled xscreensaver as far as possible without success, I had set "xfce4-power-manager" to zero - also without success. But then I had remembered that the X server can take this influence on the blanking. With Option "BlankTime" "0" I have now success for a long time. In the meantime I renewed the hardware several times (for other reasons) and also the xscreensaver has been updated several times, nevertheless I still have to influence my Xfce desktop this way, because the annoying problem persists.
The problem is usually using xfce4-power-manager and the screen blanking settings of xscreensaver at the same time. One should disable the power manager settings from xscreensaver and use Xfce's power manager exclusively. But I had all the same problems where I wanted no screen blanking at all but I was still getting it in the past with LXDE and Xfce.

You can always confirm your settings by typing:

Code: Select all

xset q

Post Reply