Installations and their Dependencies

You have a problem with Salix? Post here and we'll do what we can to help.
User avatar
gapan
Salix Wizard
Posts: 5892
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 19. May 2022, 18:19

SalixManiac wrote:
19. May 2022, 17:45
abiword-3.0.5 needs the following packages:
libical,boost,librevenge,libwps,raptor2,rasqal,redland,libwpd,libwpg,libexif,gvfs,goffice.

with this build;
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--libdir=/usr/lib64 \
--disable-static \
--enable-shared \
--enable-clipart \
--enable-templates \
--with-redland \
--with-boost=yes \
--with-goffice
I don't understand your comment. If you compile abiword yourself, then it will need whatever you compile it with. The package that is in the repositories definitely does not need all of those. For example, I remove boost, and it still works fine. I don't have redland or rasqal installed and it works fine.
Image
Image

User avatar
SalixManiac
Posts: 33
Joined: 15. Apr 2022, 02:26

Re: Installations and their Dependencies

Post by SalixManiac » 20. May 2022, 17:02

I thought it was a generic array of dependencies :o but this is certainly one of the most difficult things to do, for example for French we have to take hunspell for the spell checker because aspelll does not support this language.

User avatar
laprjns
Salix Warrior
Posts: 1076
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installations and their Dependencies

Post by laprjns » 27. May 2022, 22:08

System-config-printer still has a problem. I tried installing it on another system and here's what I get.

Code: Select all

root[rich]# slapt-get -i system-config-printer
Reading Package Lists...Done
Excluding system-config-printer, use --ignore-dep to override
The following packages have unmet dependencies:
  system-config-printer: Depends: python-request
The following packages have been EXCLUDED:
  system-config-printer 
0 upgraded, 0 reinstalled, 0 newly installed, 0 to remove, 1 not upgraded.
But I installed it?

Code: Select all

root[rich]# slapt-get -i python-requests
Reading Package Lists...Done
python-requests is up to date.
0 upgraded, 0 reinstalled, 0 newly installed, 0 to remove, 0 not upgraded.
So I tried this

Code: Select all

rroot[rich]# slapt-get -i system-config-printer --ignore-dep
Reading Package Lists...Done
The following packages have unmet dependencies:
  system-config-printer: Depends: python-request
The following NEW packages will be installed:
  system-config-printer 
0 upgraded, 0 reinstalled, 1 newly installed, 0 to remove, 0 not upgraded.
Need to get 972.0kB of archives.
After unpacking 7.0MB of additional disk space will be used.
1/1 Get http://slackware.uk/salix/x86_64/slackware-15.0/ system-config-printer 1.5.15-x86_64-5 [972.0kB]...Done

Preparing to install system-config-printer-1.5.15-x86_64-5
Installing package system-config-printer-1.5.15-x86_64-5...
| system-config-printer (CUPS printer administration tool)
| 
| The purpose of the tool is to configure a CUPS server (often the local
| machine) using the CUPS API. The tool is written in Python, using
| pygtk for the graphical parts and Python bindings (pycups) for the
| CUPS API. It is largely the same as using the CUPS web interface for
| configuring printers, but has the advantage of being a native
| application rather than a web page.
| 
| Homepage: https://github.com/OpenPrinting/system-config-printer
| 
| 
| 
Done
It was installed, so I tried starting it.

Code: Select all

rich[~]$ system-config-printer
rich[~]$ system-config-printer

(system-config-printer.py:3114): dbind-WARNING **: 18:01:32.129: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 76, in <module>
    import cupshelpers
  File "/usr/lib64/python3.9/site-packages/cupshelpers/__init__.py", line 60, in <module>
    from . import openprinting
  File "/usr/lib64/python3.9/site-packages/cupshelpers/openprinting.py", line 22, in <module>
    import requests, urllib.request, urllib.parse, urllib.error, platform, threading, tempfile, traceback
  File "/usr/lib64/python3.9/site-packages/requests/__init__.py", line 43, in <module>
    import urllib3
ModuleNotFoundError: No module named 'urllib3'

(system-config-printer.py:3114): dbind-WARNING **: 18:01:32.129: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 76, in <module>
    import cupshelpers
  File "/usr/lib64/python3.9/site-packages/cupshelpers/__init__.py", line 60, in <module>
    from . import openprinting
  File "/usr/lib64/python3.9/site-packages/cupshelpers/openprinting.py", line 22, in <module>
    import requests, urllib.request, urllib.parse, urllib.error, platform, threading, tempfile, traceback
  File "/usr/lib64/python3.9/site-packages/requests/__init__.py", line 43, in <module>
    import urllib3
ModuleNotFoundError: No module named 'urllib3'
That's a far as I went. Something must be wrong with the dependency list
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
gapan
Salix Wizard
Posts: 5892
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 27. May 2022, 22:31

Ah, that should be "python-requests", not "python-request". If you have that installed along with all other dependencies, it should work:

Code: Select all

python-requests
python-urllib3
python-chardet|python-charset-normalizer
python-certifi
python-idna
pygobject3
gtk+3
Image
Image

User avatar
Bird
Posts: 49
Joined: 24. Jul 2015, 12:15
Location: German Goose

Re: Installations and their Dependencies

Post by Bird » 29. May 2022, 18:07

Something else:
Maybe add a little note to the package description of the Sourcery package "floating-IPS", stating "Use flips command to execute program". It's not terribly obvious unless you know the short name "flips".

User avatar
gapan
Salix Wizard
Posts: 5892
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 29. May 2022, 18:37

Bird wrote:
29. May 2022, 18:07
Something else:
Maybe add a little note to the package description of the Sourcery package "floating-IPS", stating "Use flips command to execute program". It's not terribly obvious unless you know the short name "flips".
I can't do that. I can only edit dependencies. Everything you find in sourcery is actually administered by SBo, not salix.
Image
Image

User avatar
laprjns
Salix Warrior
Posts: 1076
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installations and their Dependencies

Post by laprjns » 30. May 2022, 20:23

twapake requires perl-Curses-UI, but slapt-src can't find it.
rich[slapt-get]$ slapt-src --install twapake
Missing slackbuild: twapake requires perl-Curses-UI
Unable to find all specified slackbuilds.
rich[slapt-get]$
It look like the SLACKBUILDS.TXT file is missing the perl-Curses-UI stanza
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
gapan
Salix Wizard
Posts: 5892
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 30. May 2022, 20:49

That's because you can get perl-Curses-UI with slapt-get.
Image
Image

User avatar
laprjns
Salix Warrior
Posts: 1076
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installations and their Dependencies

Post by laprjns » 30. May 2022, 21:42

gapan wrote:
30. May 2022, 20:49
That's because you can get perl-Curses-UI with slapt-get.
I miss spi...
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
gapan
Salix Wizard
Posts: 5892
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 30. May 2022, 21:59

laprjns wrote:
30. May 2022, 21:42
I miss spi...
I know. But my hope is that you won't need it in the end. Not if everything is in the repos.
Image
Image

Post Reply