Installations and their Dependencies

You have a problem with Salix? Post here and we'll do what we can to help.
User avatar
laprjns
Salix Warrior
Posts: 1085
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installations and their Dependencies

Post by laprjns » 3. Jul 2022, 17:08

FreeCAD is missing the following dependencies;
Coin
qt5-webkit
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
gapan
Salix Wizard
Posts: 6039
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 3. Jul 2022, 20:48

laprjns wrote:
3. Jul 2022, 17:08
FreeCAD is missing the following dependencies;
Coin
qt5-webkit
Thank you!
Image
Image

User avatar
Bird
Posts: 64
Joined: 24. Jul 2015, 12:15
Location: Germany

Re: Installations and their Dependencies

Post by Bird » 28. Jul 2022, 12:02

I'm trying to install the Palemoon browser on Salix 14.2 64-bit via Sourcery. Same for palemoon-bin.
Does it work for you? I get an error that the MD5 checksums are wrong.

User avatar
Bird
Posts: 64
Joined: 24. Jul 2015, 12:15
Location: Germany

Re: Installations and their Dependencies

Post by Bird » 6. Sep 2022, 19:37

On Salix 14.1, I tried to install the package "gsm" via Sourcery. However the download link to http://www.imagemagick.org/download/del ... 13.tar.bz2 is broken. I found out that for Salix 14.2, the same version and be found in the normal packages, for example here: http://salix.mirror.garr.it/salix//i486 ... aries/gsm/

I'd need the "gsm" package to install Kdenlive on Salix 14.1. Could you somewhat merge the 14.2 package back to the 14.1 package list?

User avatar
gapan
Salix Wizard
Posts: 6039
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 6. Sep 2022, 19:50

Bird wrote:
6. Sep 2022, 19:37
On Salix 14.1, I tried to install the package "gsm" via Sourcery. However the download link to http://www.imagemagick.org/download/del ... 13.tar.bz2 is broken. I found out that for Salix 14.2, the same version and be found in the normal packages, for example here: http://salix.mirror.garr.it/salix//i486 ... aries/gsm/

I'd need the "gsm" package to install Kdenlive on Salix 14.1. Could you somewhat merge the 14.2 package back to the 14.1 package list?
No, but nobody is stopping you from getting the sources from that 14.2 repository and building the package manually. ;)
Image
Image

User avatar
Bird
Posts: 64
Joined: 24. Jul 2015, 12:15
Location: Germany

Re: Installations and their Dependencies

Post by Bird » 7. Sep 2022, 05:07

@gapan: Surely I'll do that... but that doesn't fix the problem for the next one. Could you appoint me as Salix Sourcery Legacy Manager? I would like to be able to fix these things on the bigger scale.

User avatar
Bird
Posts: 64
Joined: 24. Jul 2015, 12:15
Location: Germany

Re: Installations and their Dependencies

Post by Bird » 8. Sep 2022, 10:56

Even if it won't be maintained, I'll continue to write down package dependency problems for the older Salix versions.

On Salix 14.2, the Sourcery package "subtitlecomposer" requires "automoc4".
Edit: Subtitle Composer also needs "oxygen-icons" to display icons, as it is a KDE program.

DidierSpaier
Posts: 416
Joined: 20. Jun 2016, 20:15

Re: Installations and their Dependencies

Post by DidierSpaier » 18. Sep 2022, 17:59

At SBo jack2 has been renamed jack.

@gapan; would you mind propagate this change to the repository extra-15.0, including the dependencies to jack?

I ask because jack (formerly jack2) is included in Slint so trying to install packages depending on it with slapt-get fails by lack of jack2.

Cheers,
Didier

User avatar
gapan
Salix Wizard
Posts: 6039
Joined: 6. Jun 2009, 17:40

Re: Installations and their Dependencies

Post by gapan » 18. Sep 2022, 21:29

DidierSpaier wrote:
18. Sep 2022, 17:59
At SBo jack2 has been renamed jack.

@gapan; would you mind propagate this change to the repository extra-15.0, including the dependencies to jack?

I ask because jack (formerly jack2) is included in Slint so trying to install packages depending on it with slapt-get fails by lack of jack2.

Cheers,
Didier
Didier, for this reason, there is a "jack" dummy package in the main salix repo, which just depends on jack2.
Image
Image

User avatar
laprjns
Salix Warrior
Posts: 1085
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installations and their Dependencies

Post by laprjns » 24. Sep 2022, 14:08

The evdi package has unmet dependence evdi-kernel.
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

Post Reply