Can't install xmonad

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
Mars
Posts: 5
Joined: 3. Oct 2022, 17:43

Can't install xmonad

Post by Mars » 3. Oct 2022, 17:53

Hi all!

I am unable to install xmonad for some reason. It tells me that haskell-X11 depends on haskell. Makes sense, but there is no haskell package? I thought I'd install ghc, maybe that would fulfill the haskell dependency, but no :(

Code: Select all

slapt-get]$ doas slapt-get -i ghc xmonad
Reading Package Lists...Done 
Excluding xmonad, use --ignore-dep to override
The following packages have unmet dependencies:
  haskell-X11: Depends: haskell
The following packages have been EXCLUDED:
  xmonad
The following NEW packages will be installed:
  ghc
0 upgraded, 0 reinstalled, 1 newly installed, 0 to remove, 1 not upgraded.
Tried to install the list of packages from the Slackware docs but not everything exists. Probably because it is outdated.

Any tips on how to install Xmonad?
(and as a bonus question: any tips on using xmonad as an xfwm4 replacement in XFCE ? (currently i3 is used as replacement, but I like xmonad better).

Thanx!
Mars

SsamirR
Posts: 5
Joined: 30. Sep 2022, 07:17

Re: Can't install xmonad

Post by SsamirR » 3. Oct 2022, 18:27

try to install required dependencies first :

Code: Select all

sudo slapt-get --show xmonad | grep "Package Required:" | tr ',' '\n' | while read -r package ; do sudo slapt-get -i "$package" -y ; done

Mars
Posts: 5
Joined: 3. Oct 2022, 17:43

Re: Can't install xmonad

Post by Mars » 3. Oct 2022, 18:39

Thank you. Unfortunately one of the packages it wants to install from the "Package Required" list, is 'haskell'. That is not an existing package.
SsamirR wrote:
3. Oct 2022, 18:27
try to install required dependencies first :

Code: Select all

sudo slapt-get --show xmonad | grep "Package Required:" | tr ',' '\n' | while read -r package ; do sudo slapt-get -i "$package" -y ; done

DidierSpaier
Posts: 440
Joined: 20. Jun 2016, 20:15

Re: Can't install xmonad

Post by DidierSpaier » 3. Oct 2022, 19:08

It looks like an issue with the dependency list. As a workaround I tried this, which worked:

Code: Select all

slapt-get -i ghc
slapt-get -i haskell-X11
slapt-src -i xmonad

Mars
Posts: 5
Joined: 3. Oct 2022, 17:43

Re: Can't install xmonad

Post by Mars » 3. Oct 2022, 21:32

Hmm. It doesn't work for me unfortunately. Installing ghc is not a problem. But when slapt-getting haskell-X11 it tells me it depends on the non-existent haskell package.
If I try to build with slapt-src, (either haskell-X11 or xmonad), I get the message that it was unable to find all specified slackbuilds (I did update the slackbuilds list), which would be the haskell package, I assume.
DidierSpaier wrote:
3. Oct 2022, 19:08
It looks like an issue with the dependency list. As a workaround I tried this, which worked:

Code: Select all

slapt-get -i ghc
slapt-get -i haskell-X11
slapt-src -i xmonad

Mars
Posts: 5
Joined: 3. Oct 2022, 17:43

Re: Can't install xmonad

Post by Mars » 3. Oct 2022, 21:55

Thanx everybody! I got it installed.

I installed all dependencies that were able to install, and then I just installed haskell-X11 and xmonad with the --no-dep option.
As I thought, ghc was enough to be able to run xmonad.

User avatar
mimosa
Salix Warrior
Posts: 3286
Joined: 25. May 2010, 17:02
Contact:

Re: Can't install xmonad

Post by mimosa » 13. Oct 2022, 11:53

I'm glad you got it to work!

In the end I came to the conclusion that it's better to just use Haskell-platform (the kitchen sink). But nowadays they do it like this:

https://www.haskell.org/downloads/

I used Xmonad as my main WM for many years; now I use ratpoison (there even used to be a Salix Ratpoison edition!)

User avatar
gapan
Salix Wizard
Posts: 6070
Joined: 6. Jun 2009, 17:40

Re: Can't install xmonad

Post by gapan » 17. Oct 2022, 06:50

Hmmm... I have no idea where that "haskell" dependency came from. And I can see it's there in most haskell related packages. I have now removed it, so it should be no issue anymore. Thanks!
Image
Image

Post Reply