Problem with protonvpn-cli

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
wally
Posts: 10
Joined: 22. Nov 2016, 09:47

Problem with protonvpn-cli

Post by wally » 27. Nov 2022, 00:51

Hello all, I'm trying to setup protonvpn. I get this in bash, so i guess it's not installed correctly. Anyone know how to fix this:

slacker[~]$ protonvpn --help
Traceback (most recent call last):
File "/usr/bin/protonvpn", line 33, in <module>
sys.exit(load_entry_point('protonvpn-cli==2.2.11', 'console_scripts', 'protonvpn')())
File "/usr/bin/protonvpn", line 25, in importlib_load_entry_point
return next(matches).load()
File "/usr/lib64/python3.9/importlib/metadata.py", line 86, in load
module = import_module(match.group('module'))
File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 850, in exec_module
File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
File "/usr/lib64/python3.9/site-packages/protonvpn_cli/cli.py", line 59, in <module>
from . import connection
File "/usr/lib64/python3.9/site-packages/protonvpn_cli/connection.py", line 16, in <module>
from .utils import (
File "/usr/lib64/python3.9/site-packages/protonvpn_cli/utils.py", line 13, in <module>
import requests
ModuleNotFoundError: No module named 'requests'
slacker[~]$

User avatar
gapan
Salix Wizard
Posts: 6100
Joined: 6. Jun 2009, 17:40

Re: Problem with protonvpn-cli

Post by gapan » 27. Nov 2022, 10:36

You also need to install python-requests. I'll add it to the dep file.
Image
Image

wally
Posts: 10
Joined: 22. Nov 2016, 09:47

Re: Problem with protonvpn-cli

Post by wally » 30. Nov 2022, 01:43

I used just openvpn in Lubuntu to setup protonvpn and that worked. Every instruction I see on the web requires both openvpn and protonvpn-cli to be setup. I can't remember how I did it with just openvpn now. Any ideas?

User avatar
gapan
Salix Wizard
Posts: 6100
Joined: 6. Jun 2009, 17:40

Re: Problem with protonvpn-cli

Post by gapan » 30. Nov 2022, 19:54

What's wrong with the openvpn in salix?
Image
Image

Post Reply