booting from usb

You have a problem with Salix? Post here and we'll do what we can to help.
anamesa
Posts: 12
Joined: 14. Oct 2013, 16:02

Re: booting from usb

Post by anamesa » 25. Nov 2013, 01:17

It seems that it has finally worked. I followed the procedure described at the end of my previous post.
Step A
-------
1. I booted with the installation media (it was not live cd, only for installation) and have chosen to quit installation when the relevant screen showed.
2. I then made a directory "/mnt/salix" to mount my usb disk installation. It was on /dev/sdd10, and I mounted it on /mnt/salix (as root)
3. Then I mounted /dev, /proc & /sys to the corresponding /mnt/salix/dev, /mnt/salix/proc & /mnt/salix/sys
4. I then chrooted as described in the post I've been referred to, and build the initrd (I deleted the former initrd.gz & the directory inside /mnt/salix/boot it had built.
I also installed LILO, but that was not needed, because I use grub2 (from another installation) to find the various linux systems I've installed here and there. I checked of course, that it had found and written down the salix installation correctly.

Previous was step A, in order to be able to boot once. Now follows step B.

Step B
-------
So, I booted into my salix installation on /dev/sdd10, and as root (without need to chroot, or mount /dev, /proc and /sys) I've changed to /boot (cd /boot) and built the initrd with the running kernel (which in my case, as a matter of fact is the "vmlinuz-huge-3.2.45" (salix 64bit xfce4))

I've not encountered any problem for the time being, and hope I wont.

PS. This procedure is possible because it is possible (for my hardware at least) to boot into the salix installation, for a couple of times, even if the kernel used to make the initrd is not the installed kernel, but another (in my case it was rather the 3.2.29, I don't quite remember the outcome of the "uname -a" command when booted with installation media.

EDIT
Since last posting, I run again into not being able to boot. I edited the grub menu (e -> edit -> F10 to boot) by adding the line "rootdelay=20" somewhere in the top, before the reference to the specific root device. Then I booted OK. I'll check it a couple of times and then I'll add it into the /boot/grub/grub.cfg file (of the distro which handles grub in my systtem).

EDIT 2
It seems that the actual problem was exactly this: that the initrd could not find the root device. This can happen if one has, as in my case, many linux installations in different usb disks, so it may happen that the first time disk A is /dev/sdb and disk B /dev/sdc, the second time one boots, disk A is /dev/sdc and disc B /dev/sdb. This can pose problems to the initrd. It is best to boot with only the usb disc connected, which contains the distro for booting. There is no influence of the kernel of the distro whatsoever, since even in his note about initrd Volkerding uses the existing (previous) kernel to build an initrd from the kernel he has just installed (new kernel). Otherwise, how could he boot to the new kernel, to use it on itself?. The initrd refers to the installed kernel and uses its image and modules (as far as I can tell). In my case I had to experiment a couple of times by editing the grub.cfg in boot time, to find the correct root device, but then it booted ok.

Post Reply