[SOLVED] fluxbox menu does not accept png icons

You have a problem with Salix? Post here and we'll do what we can to help.
User avatar
jsfarinet
Posts: 305
Joined: 23. Nov 2014, 07:32

[SOLVED] fluxbox menu does not accept png icons

Post by jsfarinet » 27. Nov 2014, 20:51

Strangely, fluxbox in Salix does not accept png files as icons in the menu file - those within the <> brackets. Pretty much the same identical version of fluxbox on another machine does. This is according to what the fluxbox page says

"The <'icon'> field is always optional when shown below. If specified, the icon will be scaled down and displayed in the menu alongside the text label of the item. It must be in .xpm or .png format."

So, may be there is something in the general Salix settings that i should tweak?
Last edited by jsfarinet on 3. Dec 2014, 11:58, edited 3 times in total.

User avatar
gapan
Salix Wizard
Posts: 5537
Joined: 6. Jun 2009, 17:40

Re: fluxbox menu does not accept png icons

Post by gapan » 27. Nov 2014, 22:49

No, the slackware fluxbox package is compiled without imlib2 support, which is needed for rendering png icons, as imlib2 is not part of slackware. Either stick with it, or install imlib2 and rebuild the fluxbox package the way you like.
Image
Image

User avatar
jsfarinet
Posts: 305
Joined: 23. Nov 2014, 07:32

Re: fluxbox menu does not accept png icons

Post by jsfarinet » 27. Nov 2014, 23:11

gapan wrote:No, the slackware fluxbox package is compiled without imlib2 support, which is needed for rendering png icons, as imlib2 is not part of slackware. Either stick with it, or install imlib2 and rebuild the fluxbox package the way you like.
Ah i see, ok so far :) (no configuration error on my side).

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: fluxbox menu does not accept png icons

Post by Atip » 28. Nov 2014, 01:16

Yes, the menu accepts only .xpm format icons.
I just change the ones needed from .png to .xpm

User avatar
jsfarinet
Posts: 305
Joined: 23. Nov 2014, 07:32

Re: fluxbox menu does not accept png icons

Post by jsfarinet » 1. Dec 2014, 18:54

gapan wrote:No, the slackware fluxbox package is compiled without imlib2 support, which is needed for rendering png icons, as imlib2 is not part of slackware. Either stick with it, or install imlib2 and rebuild the fluxbox package the way you like.
Imlib2 is installed here. Now, i tried to rebuild fluxbox from source. But, doing make, i'm getting this error:

Code: Select all

g++: Fehler: @my_libs@: Datei oder Verzeichnis nicht gefunden
make[4]: *** [fluxbox] Fehler 1
make[4]: Leaving directory `/home/uli/Downloads/fluxbox-1.3.5/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Leaving directory `/home/uli/Downloads/fluxbox-1.3.5/src'
make[2]: *** [all] Fehler 2
make[2]: Leaving directory `/home/uli/Downloads/fluxbox-1.3.5/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/uli/Downloads/fluxbox-1.3.5'
make: *** [all] Fehler 2
Any ideas here?

TIA!

User avatar
gapan
Salix Wizard
Posts: 5537
Joined: 6. Jun 2009, 17:40

Re: fluxbox menu does not accept png icons

Post by gapan » 1. Dec 2014, 21:07

Are you trying to compile it manually? You should use the slackbuild to create a package.
Image
Image

User avatar
jsfarinet
Posts: 305
Joined: 23. Nov 2014, 07:32

Re: fluxbox menu does not accept png icons

Post by jsfarinet » 1. Dec 2014, 21:32

gapan wrote:Are you trying to compile it manually? You should use the slackbuild to create a package.
Yes, it's a tarball i downloaded from the fluxbox site. Where do i get the slackbuild package? In gslapt i'll get the binary without imlib2 support, i guess ...

PS. The one i get from http://packages.slackware.com/?r=slackw ... i486-1.txz seems to have no options (no options at all) regard Imlib2 support.

User avatar
gapan
Salix Wizard
Posts: 5537
Joined: 6. Jun 2009, 17:40

Re: fluxbox menu does not accept png icons

Post by gapan » 1. Dec 2014, 22:02

Download all files from here: http://download.salixos.org/i486/slackw ... p/fluxbox/
put them in the same directory. And...

Code: Select all

chmod +x fluxbox.SlackBuild
fakeroot ./fluxbox.SlackBuild
and after it finishes look for the new package in your /tmp.
Image
Image

User avatar
jsfarinet
Posts: 305
Joined: 23. Nov 2014, 07:32

Re: fluxbox menu does not accept png icons

Post by jsfarinet » 1. Dec 2014, 23:55

gapan wrote:Download all files from here: http://download.salixos.org/i486/slackw ... p/fluxbox/
put them in the same directory. And...

Code: Select all

chmod +x fluxbox.SlackBuild
fakeroot ./fluxbox.SlackBuild
and after it finishes look for the new package in your /tmp.
Thanks a lot for all that info. I followed your advice precisely, but unfortunately it ended up with the same error:

Code: Select all

g++: Fehler: @my_libs@: Datei oder Verzeichnis nicht gefunden
make[4]: *** [fluxbox] Fehler 1
make[4]: Leaving directory `/tmp/fluxbox-1.3.5/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Leaving directory `/tmp/fluxbox-1.3.5/src'
make[2]: *** [all] Fehler 2
make[2]: Leaving directory `/tmp/fluxbox-1.3.5/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/tmp/fluxbox-1.3.5'
make: *** [all] Fehler 2
What's that directory or file @my_libs@ whch is missing?

User avatar
laprjns
Salix Warrior
Posts: 1039
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: fluxbox menu does not accept png icons

Post by laprjns » 2. Dec 2014, 02:48

jsfarinet wrote:mlib2 is installed here. Now, i tried to rebuild fluxbox from source. But, doing make, i'm getting this error:
...
There is a bug in imlib2-config. See here. http://git.enlightenment.org/legacy/iml ... 5dde234b2d
The easiest way to fix it is to edit the file directly. Do the following:

Code: Select all

$ sudo geany /usr/bin/imlib2-config
This will open the file in geany for editing. Scroll down to line 49; it should look like this:

Code: Select all

echo $libdirs -lImlib2 @my_libs@
Delete the @my_libs@ text so that it looks like this:

Code: Select all

echo $libdirs -lImlib2
and then save the file and exit geany. Once this is done run the fluxbox.Slackbuild scrip again.

It worked here. I was able to reproduce your build error and then after making the change to the imlib2-config the fluxbox package built without problems. Don't know if the package works, but it does build.
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

Post Reply