Megasync error on new, vanilla Salix64 14.2 install.

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
User avatar
globetrotterdk
Posts: 427
Joined: 26. Oct 2010, 13:57
Location: Copenhagen, Denmark

Megasync error on new, vanilla Salix64 14.2 install.

Post by globetrotterdk » 14. Mar 2018, 09:08

I have now installed megasync twice, each time after a re-install, but I can't figure out what is going on. The scenario is that I install megasync on a new, vanilla Salix64 XFCE 14.2 system. I run megasync and sync all of my items. Everything is fine. However, when I reboot, megasync refuses to run. When run in a terminal, I get the following error:

Code: Select all

$ megasync
megasync: /lib64/libcrypto.so.1.0.0: no version information available (required by megasync)
In /lib64:

Code: Select all

$ ls -l
lrwxrwxrwx 1 root root      18 Mar 12 21:29 libcrypto.so.1 -> libcrypto.so.1.0.0
-r-xr-xr-x 1 root root 2419016 Dec  9 00:51 libcrypto.so.1.0.0
I don't understand what is going on.
Military justice is to justice what military music is to music. - Groucho Marx

User avatar
mimosa
Salix Warrior
Posts: 3094
Joined: 25. May 2010, 17:02
Contact:

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by mimosa » 14. Mar 2018, 11:07

You may be missing some of these dependencies:
https://slackbuilds.org/repository/14.2 ... h=megasync

User avatar
globetrotterdk
Posts: 427
Joined: 26. Oct 2010, 13:57
Location: Copenhagen, Denmark

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by globetrotterdk » 14. Mar 2018, 11:39

Sorry, I should have been more specific. I installed the version that is in the Salix repository - 2.3.1-x86_64-1salix.
----
I added the required dependencies, but no change.
Military justice is to justice what military music is to music. - Groucho Marx

User avatar
gapan
Salix Wizard
Posts: 5516
Joined: 6. Jun 2009, 17:40

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by gapan » 14. Mar 2018, 11:43

Yes, but do try installing those dependencies. They were indeed missing from the package in the repos. I have just added them, but it will take some time until mirrors sync.
Image
Image

User avatar
globetrotterdk
Posts: 427
Joined: 26. Oct 2010, 13:57
Location: Copenhagen, Denmark

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by globetrotterdk » 14. Mar 2018, 11:54

Hi gapan. Nice to hear from you. I added the dependencies, however there is no change. I still get the same message in a terminal.
Military justice is to justice what military music is to music. - Groucho Marx

User avatar
gapan
Salix Wizard
Posts: 5516
Joined: 6. Jun 2009, 17:40

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by gapan » 14. Mar 2018, 11:57

Is your system fully updated?
Image
Image

User avatar
globetrotterdk
Posts: 427
Joined: 26. Oct 2010, 13:57
Location: Copenhagen, Denmark

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by globetrotterdk » 14. Mar 2018, 12:11

It is now, but I unfortunately have just discovered that there was something that required me to run eliloconfig. Is there any way to recover from this?
Military justice is to justice what military music is to music. - Groucho Marx

User avatar
gapan
Salix Wizard
Posts: 5516
Joined: 6. Jun 2009, 17:40

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by gapan » 14. Mar 2018, 12:20

Can you remove that package and install the MEGAsync slackbuild with spi?

Code: Select all

sudo spi -i MEGAsync
Image
Image

User avatar
globetrotterdk
Posts: 427
Joined: 26. Oct 2010, 13:57
Location: Copenhagen, Denmark

Re: Megasync error on new, vanilla Salix64 14.2 install.

Post by globetrotterdk » 14. Mar 2018, 12:35

I ran

Code: Select all

sudo spi -i MEGAsync
and the SlackBuilds version installed. Everything seems to be working fine after a reboot.
Military justice is to justice what military music is to music. - Groucho Marx

Post Reply