System freeze problem

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
wally
Posts: 8
Joined: 22. Nov 2016, 09:47

System freeze problem

Post by wally » 21. Aug 2018, 18:00

Hello all, I've been away from salix a couple of years. I just installed 14.2 last night. Problem is, my system keeps freezing up. The wired connection takes several minutes to settle down and work, but one annoyance at a time. I've googled this and the only thing I've come close to my problem was a video driver problem. What do ya'll think? It runs fine for a while then starts this sh*t! It's not over heating. I really don't know were to begin. This is what's under the hood.wally[~]$ sudo lshw -short
Password:
H/W path Device Class Description
=============================================
system System Product Name (To Be Filled By O.E.M.)
/0 bus M5A78L-M LX3
/0/0 memory 64KiB BIOS
/0/4 processor Athlon II (To Be Filled By O.E.M.)
/0/4/5 memory 384KiB L1 cache
/0/4/6 memory 1536KiB L2 cache
/0/26 memory 4GiB System Memory
/0/26/0 memory 2GiB DIMM Synchronous 1333 MHz (0.8 ns)
/0/26/1 memory 2GiB DIMM Synchronous 1333 MHz (0.8 ns)
/0/100 bridge RS780 Host Bridge
/0/100/2 bridge RS780 PCI to PCI bridge (ext gfx port 0)
/0/100/2/0 display NVIDIA Corporation
/0/100/2/0.1 multimedia NVIDIA Corporation
/0/100/4 bridge RS780/RS880 PCI to PCI bridge (PCIE port 0)
/0/100/4/0 eth0 network QCA8171 Gigabit Ethernet
/0/100/11 storage SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
/0/100/12 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/12.1 bus SB7x0 USB OHCI1 Controller
/0/100/12.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/13 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/13.1 bus SB7x0 USB OHCI1 Controller
/0/100/13.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 storage SB7x0/SB8x0/SB9x0 IDE Controller
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB7x0/SB8x0/SB9x0 LPC host controller
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.5 bus SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
/0/101 bridge Family 10h Processor HyperTransport Configurat
/0/102 bridge Family 10h Processor Address Map
/0/103 bridge Family 10h Processor DRAM Controller
/0/104 bridge Family 10h Processor Miscellaneous Control
/0/105 bridge Family 10h Processor Link Control
wally[~]$
I've been using Lubuntu. So it goes without saying I don't know anything about Linux. That's why I'm back with Salix. Got to start learning sometime.

Thanks for any help rendered.

User avatar
gapan
Salix Wizard
Posts: 5531
Joined: 6. Jun 2009, 17:40

Re: System freeze problem

Post by gapan » 23. Aug 2018, 07:23

Did you have the same problems with Lubuntu or is it only Salix? Were you actually using that PC before?

It sounds more like a hardware problem.
Image
Image

wally
Posts: 8
Joined: 22. Nov 2016, 09:47

Re: System freeze problem

Post by wally » 23. Aug 2018, 08:53

Gapan, I think it's a driver problem. This didn't happen in Lubuntu and dosen't happen in Slackware 14.2 which I tried for a short while. I still had the network manager problem though. That's why I installed Salix. Salix works great guns on my old Lenovo laptop. Please just suggest some cli commands and strategy I can use to locate the problem.
Thanks for the help.

User avatar
gapan
Salix Wizard
Posts: 5531
Joined: 6. Jun 2009, 17:40

Re: System freeze problem

Post by gapan » 23. Aug 2018, 08:55

Slackware 14.2 and Salix14.2 use the exact same drivers.
Image
Image

wally
Posts: 8
Joined: 22. Nov 2016, 09:47

Re: System freeze problem

Post by wally » 23. Aug 2018, 09:21

Well something must be different. I'm going to research a fix for networkmanager and reload Slackware and see if over time my system locks up. I'll get back to you on this. Thanks.

User avatar
gapan
Salix Wizard
Posts: 5531
Joined: 6. Jun 2009, 17:40

Re: System freeze problem

Post by gapan » 23. Aug 2018, 09:24

For network manager search the forums. There are a few reports that it doesn't work that well with some cards. I think it's usually solved by using a static IP. Or switch to wicd.
Image
Image

wally
Posts: 8
Joined: 22. Nov 2016, 09:47

Re: System freeze problem

Post by wally » 23. Aug 2018, 09:33

Thanks I'll try those first.

User avatar
ChuangTzu
Donor
Posts: 343
Joined: 19. May 2015, 23:34

Re: System freeze problem

Post by ChuangTzu » 24. Aug 2018, 00:16

or netconfig and select DHCPD for wired connection.

Code: Select all

sudo netconfig
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3101
Joined: 25. May 2010, 17:02
Contact:

Re: System freeze problem

Post by mimosa » 24. Aug 2018, 10:35

On a fresh install, you should really do a kernel upgrade to the latest kernel from the repositories. Instructions on the wiki. I doubt it'll help with this trouble though.

Post Reply