Issue with fonts, opera-developer and xml [Solved]

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
User avatar
Van_Vinkle
Donor
Posts: 113
Joined: 25. Oct 2012, 17:39

Issue with fonts, opera-developer and xml [Solved]

Post by Van_Vinkle » 21. Oct 2018, 12:28

I don't like very much firefox for my battlehorse browser. Because that I have installed opera-developer (better than opera IMO) through sourcery. But it does not work.

If I launch it from console I get:

Code: Select all

 $ opera-developer
Fontconfig warning: "/etc/fonts/fonts.conf", line 162: blank doesn't take any effect anymore. please remove it from your fonts.conf
My fonts.conf looks like this:

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
        DO NOT EDIT THIS FILE.
        IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
        LOCAL CHANGES BELONG IN 'local.conf'.


...
...
<!--
  These are the default Unicode chars that are expected to be blank
  in fonts.  All other blank chars are assumed to be broken and
  won't appear in the resulting charsets
 -->
                <blank>
                        <int>0x0020</int>       <!-- SPACE -->
                        <int>0x00A0</int>       <!-- NO-BREAK SPACE -->
                        <int>0x00AD</int>       <!-- SOFT HYPHEN -->
                        <int>0x034F</int>       <!-- COMBINING GRAPHEME JOINER -->
                        <int>0x0600</int>       <!-- ARABIC NUMBER SIGN -->
                        <int>0x0601</int>       <!-- ARABIC SIGN SANAH -->
...
...
 			<int>0x2800</int>       <!-- BRAILLE PATTERN BLANK -->
                        <int>0x3000</int>       <!-- IDEOGRAPHIC SPACE -->
                        <int>0x3164</int>       <!-- HANGUL FILLER -->
                        <int>0xFEFF</int>       <!-- ZERO WIDTH NO-BREAK SPACE -->
                        <int>0xFFA0</int>       <!-- HALFWIDTH HANGUL FILLER -->
                        <int>0xFFF9</int>       <!-- INTERLINEAR ANNOTATION ANCHOR -->
                        <int>0xFFFA</int>       <!-- INTERLINEAR ANNOTATION SEPARATOR -->
                        <int>0xFFFB</int>       <!-- INTERLINEAR ANNOTATION TERMINATOR -->
                </blank>
...
Line 162 is the last line of this excerpt.

I've been touching up the file /etc/fonts/fonts.conf, despite the warning in the head of the file, without success. I've also searched how edit this file (other than usual editor) but I've not find any solution.

Any idea will be very appreciated.

Van Vinkle
Last edited by Van_Vinkle on 21. Oct 2018, 20:20, edited 1 time in total.

User avatar
Van_Vinkle
Donor
Posts: 113
Joined: 25. Oct 2012, 17:39

Re: Issue with fonts, opera-developer and xml

Post by Van_Vinkle » 21. Oct 2018, 15:40

I answer to myself.

Unexpectedly, after cutting off the computer and starting it again, opera-developer is running now. Why? I don't know: mysteries of the informatics :shock:

User avatar
gapan
Salix Wizard
Posts: 5532
Joined: 6. Jun 2009, 17:40

Re: Issue with fonts, opera-developer and xml

Post by gapan » 21. Oct 2018, 17:24

fc-config probably ran during boot.
Image
Image

User avatar
Van_Vinkle
Donor
Posts: 113
Joined: 25. Oct 2012, 17:39

Re: Issue with fonts, opera-developer and xml [Solved]

Post by Van_Vinkle » 21. Oct 2018, 20:23

Thanks, Gapan, for your answer, but fc-config is not in my system:

Code: Select all

# which fc-config
which: no fc-config in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)
# locate fc-config
#
Another mystery.

User avatar
gapan
Salix Wizard
Posts: 5532
Joined: 6. Jun 2009, 17:40

Re: Issue with fonts, opera-developer and xml [Solved]

Post by gapan » 21. Oct 2018, 20:43

Oops, sorry, meant to write fc-cache!
Image
Image

Post Reply