x2goserver hangs

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

x2goserver hangs

Post by Nanook » 22. Jan 2019, 05:54

I installed x2go server. When I tried to connect from a remote host it complained about some missing perl modules, so I installed them. Now when I try to connect it hangs indefinitely, never times out, never connects. Can't find any server side log files that might provide a clue.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: x2goserver hangs

Post by mimosa » 22. Jan 2019, 09:16

Some more details about exactly what you have tried and what you are seeing would be helpful.

Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

Re: x2goserver hangs

Post by Nanook » 21. Mar 2019, 02:53

Since it initially complained about two missing perl modules, I installed them all.
I made sure x-forwarding was enabled in ssh and tested it by invoking xclock and making sure it indeed did display on my originating machine when ssh into the salix machine.
I've looked at logs for errors but can not find anything relevant.
I've done a ps while attempting to log and grep'd for my username. This is the results:

root 2060 0.0 0.1 28700 4824 ? Ss 19:51 0:00 sshd: nanook [priv]
nanook 2062 1.3 0.0 28700 3788 ? S 19:51 0:00 sshd: nanook@notty
nanook 2087 0.0 0.0 11192 2996 ? Ss 19:51 0:00 bash -l -c echo "X2GODATABEGIN:de8bffe2-09f7-4ad4-b437-fc362632b676"; export PATH="/usr/local/bin:/usr/bin:/bin";export TERM="dumb"; X2GODPI=96 X2GO_XINERAMA=no x2gostartagent 800x600 adsl 16m-jpeg-9 unix-kde-depth_24 us auto 1 D XFCE both; echo "X2GODATAEND:de8bffe2-09f7-4ad4-b437-fc362632b676";
nanook 2098 5.9 0.0 11300 3040 ? S 19:51 0:01 /bin/bash /usr/bin/x2gostartagent 800x600 adsl 16m-jpeg-9 unix-kde-depth_24 us auto 1 D XFCE both

So it is at least trying to start, but that's as far as it gets.
I've posted to the x2go mail list, so far nobody has responded.

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: x2goserver hangs

Post by djemos » 23. Mar 2019, 15:10

I tried to install x2goserver. It is buggy. Find a better program like remmina or TeamViewer.

Post Reply