The system wants to downgrade mozilla-firefox

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
User avatar
ibka
Posts: 107
Joined: 12. Sep 2010, 13:14
Location: Sweden
Contact:

The system wants to downgrade mozilla-firefox

Post by ibka » 24. Mar 2019, 15:45

Version of Salix: Salix 14.1 x86_64
Repository mirror: http://slackware.uk

Today there was an update notification, and i installed the updates (witch i shouldn't have done)
I did not see it was an downgrade. The bad is that all my bookmarks and tabs disappeared :cry:
if i run slapt-get -u i get the following error:
Retrieving package data [http://slackware.uk/salix/x86_64/14.1/]...error attempting to read pkg description
I manage to restore bookmarks and history so it is solved now, but the system wants to downgrade Mozilla-firefox.
The only positive is that i don't have 100+ tabs now.
Image

User avatar
gapan
Salix Wizard
Posts: 5528
Joined: 6. Jun 2009, 17:40

Re: The system wants to downgrade mozilla-firefox

Post by gapan » 24. Mar 2019, 19:07

Oops! That's my bad! I'm terribly sorry, I've fixed it, but it may take a bit for mirrors to sync. :oops:

The package is actually there, so you can get it manually for now, it's only the metadata that is bad.
http://download.salixos.org/x86_64/14.1 ... 64-1gv.txz

Bad metadata meant that slapt-get reverted to the package in the slackware repos, which is an older version.

I also noticed that I hadn't upgraded locale packages for firefox in 14.1. Double oops! :oops: :oops:
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5528
Joined: 6. Jun 2009, 17:40

Re: The system wants to downgrade mozilla-firefox

Post by gapan » 24. Mar 2019, 22:22

The slackware.uk mirror has synced, so you can get it from there with slapt-get too.
Image
Image

Post Reply