perl-AnyEvent Slackbuild Fails

You have a problem with Salix? Post here and we'll do what we can to help.
Post Reply
mastermiller
Posts: 1
Joined: 2. May 2019, 18:03

perl-AnyEvent Slackbuild Fails

Post by mastermiller » 2. May 2019, 18:13

Hey everyone,

Been using Salix for a couple months now and I'm loving it so far. I ran into a problem installing i3 via slapt-src; when I try to install perl-AnyEvent as a dependency the build fails with the following message:
Test Summary Report
-------------------
t/81_hosts.t (Wstat: 512 Tests: 2 Failed: 2)
Failed tests: 1-2
Non-zero exit status: 2
Files=82, Tests=250, 3 wallclock secs ( 0.19 usr 0.05 sys + 1.34 cusr 0.16 csys = 1.74 CPU)
Result: FAIL
Failed 1/82 test programs. 2/250 subtests failed.
Makefile:1039: recipe for target 'test_dynamic' failed
make: *** [test_dynamic] Error 255
fakeroot -- sh perl-AnyEvent.SlackBuild Failed
What can I do about this? I know Slackbuilds fail on Salix sometimes because they're sometimes missing packages usually included already in full Slackware installs. If that's the case, what packages should I get to make this work? Or is the problem something else? Really looking forward to getting my favorite WM up and running on my favorite distro. Thanks for your time!

User avatar
ibka
Posts: 107
Joined: 12. Sep 2010, 13:14
Location: Sweden
Contact:

Re: perl-AnyEvent Slackbuild Fails

Post by ibka » 3. May 2019, 08:02

Hi mastermiller.
You don't write which version of Salix you have installed, but i tried to install i3 on Salix XFCE 14.2 and it installed the perl-AnyEvent and other packages as well.

Code: Select all

sudo spi -i i3
Bee sure that you have run the

Code: Select all

sudo spi -u
so it reads and update the repositories.

When i started i3 there was a error because there is a missing dependency of i3status.
After installing i3status i got no error, now i haw never used i3 so i can't say if every thing is working as it should.
Image

User avatar
gapan
Salix Wizard
Posts: 5528
Joined: 6. Jun 2009, 17:40

Re: perl-AnyEvent Slackbuild Fails

Post by gapan » 3. May 2019, 12:52

Hi mastermiller and welcome to the forums,

can you provide more of the output? That last part is not so informative.
Image
Image

Post Reply