Salix Xfce 15.0beta1

babam
Posts: 21
Joined: 28. Oct 2015, 14:11

Re: Salix Xfce 15.0beta1

Post by babam » 31. Jul 2022, 11:58

I found some packages are missing dependencies
mirage ---> gexiv2
mypaint ---> libmypaint

Code: Select all

PACKAGE NAME:  mirage-0.11.1-x86_64-2salix15.0.txz
PACKAGE LOCATION:  ./salix/graphics
PACKAGE SIZE (compressed):  144 K
PACKAGE SIZE (uncompressed):  576 K
PACKAGE REQUIRED:  libX11,libXau,libXdmcp,libxcb
--
PACKAGE NAME:  mypaint-2.0.1-x86_64-1salix15.0.txz
PACKAGE LOCATION:  ./salix/graphics
PACKAGE SIZE (compressed):  4569 K
PACKAGE SIZE (uncompressed):  18276 K
PACKAGE REQUIRED:  numpy3,mypaint-brushes2
Thanks.
Sorry, my English is bad.

babam
Posts: 21
Joined: 28. Oct 2015, 14:11

Re: Salix Xfce 15.0beta1

Post by babam » 31. Jul 2022, 15:07

Where does the value of "PACKAGE REQUIRED" come from?
Because there are those that contain the full list and some that are only partial.

Full:

Code: Select all

PACKAGE NAME:  gimp-2.10.30-x86_64-2.txz
PACKAGE REQUIRED:  aaa_libraries|alsa-lib,aaa_libraries|bzip2,aaa_libraries|c-ares,aaa_libraries|cups,aaa_libraries|curl,aaa_libraries|eudev,aaa_libraries|expat,aaa_libraries|gcc,aaa_libraries|gcc-g++,aaa_libraries|glib2,aaa_libraries|gmp,aaa_libraries|gpm,aaa_libraries|keyutils,aaa_libraries|krb5,aaa_libraries|libffi,aaa_libraries|libidn,aaa_libraries|libidn2,aaa_libraries|libjpeg-turbo,aaa_libraries|libnsl,aaa_libraries|libpng,aaa_libraries|libpsl,aaa_libraries|libssh2,aaa_libraries|libtiff,aaa_libraries|libtirpc,aaa_libraries|libunwind,aaa_libraries|ncurses,aaa_libraries|openldap,aaa_libraries|pcre,aaa_libraries|slang,aaa_libraries|xz,aaa_libraries|zlib,aaa_libraries|zstd,aalib,atk,babl,brotli,cairo,cyrus-sasl,e2fsprogs,exiv2,fontconfig,freetype,fribidi,gdk-pixbuf2,gegl,gexiv2,ghostscript,glib2,gnutls,graphite2,gtk+2,harfbuzz,json-c,json-glib,lcms2,libICE,libSM,libX11,libXau,libXcomposite,libXcursor,libXdamage,libXdmcp,libXext,libXfixes,libXi,libXinerama,libXmu,libXpm,libXrandr,libXrender,libXt,libglvnd,libgudev,libmng,libmypaint,librsvg,libunistring,libwebp,libwmf,libxcb,libxml2,mozilla-nss,nettle,nghttp2,openexr,openjpeg,openssl-solibs|openssl,p11-kit,pango,pixman,poppler,util-linux
Partial:

Code: Select all

PACKAGE NAME:  mypaint-2.0.1-x86_64-1salix15.0.txz
PACKAGE REQUIRED:  numpy3,mypaint-brushes2
Sorry, my English is bad.

User avatar
gapan
Salix Wizard
Posts: 5913
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0beta1

Post by gapan » 31. Jul 2022, 21:41

missTell wrote:
31. Jul 2022, 11:08
I tried installing Slim (see my VM) and it installed fine, but it didn't offer to replace GDM,
as it is doing in some other distros.

1. How one can swap GDM for Slim?

2. How one can get rid of DDM forever, should one decide to keep Slim?

Only (as simple as possible and) Idiot-proof answer please!
We don't have GDM installed by default in 15.0, we have lightdm. But in any case, if you want to replace lightdm with slim, just remove lightdm. The startup scripts just check if one of lightdm, lxdm, slim, gdm, kdm, sddm or xdm is present (in that order) and use whatever it finds first. Simple. If you want lightdm back, reinstall it.
Image
Image

User avatar
missTell
Posts: 92
Joined: 19. Apr 2018, 06:45

Re: Salix Xfce 15.0beta1

Post by missTell » 1. Aug 2022, 15:45

Thank's for the response -- it worked without issues!

I noticed that Murrine engine is not preinstalled -- maybe one should add it to default install, as many themes are using it.

As of Salix nIceWM ...

It is basically a default Xfce install, with added Slim, IceWM, SpaceFM, Murrine and some custom IceWM and Slim themes.

It is interesting because it is not only nice looking, but also runs only on some 180 ~ 230 MB RAM.

Yes, the icon themes, GTK themes and such can affect RAM usage.

I also fixed the Start Menu icons.

https://ibb.co/3TMDnpN
https://ibb.co/xsJqW8M
https://ibb.co/b5MtTvT

Slim login screen:

https://ibb.co/pfxMzdR
https://ibb.co/k5kJn85
https://ibb.co/GHCkmB8

Extra login screen and theme for girls -- Sexy Salix. ;)

https://ibb.co/rt7kRzk
https://ibb.co/Wk38M5W
https://ibb.co/G5bSw0k
https://ibb.co/0tz22HL
https://ibb.co/Q96s417

It should be uploaded in an hour or so ...


Addendum:
Done with uploading.
Download: https://people.salixos.org/misstell/VMs ... 5_nIce.ova
Login: https://people.salixos.org/misstell/VMs ... ali%2A.txt
Your user name is your password.
F1 to change between IceWM and Xfce sessions. Make sure to read ReadMe.txt in home.
“Never argue with stupid people, they will drag you down to their level and then beat you with experience.” (Mark Twain)

User avatar
gapan
Salix Wizard
Posts: 5913
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0beta1

Post by gapan » 4. Aug 2022, 21:47

babam wrote:
31. Jul 2022, 11:58
I found some packages are missing dependencies
mirage ---> gexiv2
mypaint ---> libmypaint
Thanks for the notification, I have fixed those. If you find any more, please post about them in the forum.

As to how the dependency lists are created, it's mostly through a tool that is called depfinder: https://github.com/gapan/depfinder
This works perfectly for binaries, but might miss things for script executables, like python or perl (mirage is a python script), or things that have been packaged in a weird manner (this is the case for mypaint, the 64bit package uses /usr/lib instead of /usr/lib64).
Image
Image

User avatar
ibka
Posts: 137
Joined: 12. Sep 2010, 13:14
Location: Sweden
Contact:

Re: Salix Xfce 15.0beta1

Post by ibka » 6. Aug 2022, 07:20

shellpic missing dependencies python2-pillow
Image

User avatar
gapan
Salix Wizard
Posts: 5913
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0beta1

Post by gapan » 6. Aug 2022, 07:51

ibka wrote:
6. Aug 2022, 07:20
shellpic missing dependencies python2-pillow
Thank you!
Image
Image

babam
Posts: 21
Joined: 28. Oct 2015, 14:11

Re: Salix Xfce 15.0beta1

Post by babam » 7. Aug 2022, 21:00

Why are there 2 hplip packages?

Code: Select all

PACKAGE NAME:  hplip-3.20.5-x86_64-1gv.txz
PACKAGE LOCATION:  ./salix/ap
PACKAGE SIZE (compressed):  18648 K
PACKAGE SIZE (uncompressed):  74592 K
--
PACKAGE NAME:  hplip-3.20.5-x86_64-6.txz
PACKAGE LOCATION:  ./slackware64/ap
PACKAGE SIZE (compressed):  18652 K
PACKAGE SIZE (uncompressed):  31650 K
hplip is requires PyQt5

Thanks.
Sorry, my English is bad.

User avatar
gapan
Salix Wizard
Posts: 5913
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0beta1

Post by gapan » 7. Aug 2022, 21:23

babam wrote:
7. Aug 2022, 21:00
Why are there 2 hplip packages?
I've forgotten about that. I removed one of them now, thanks.
babam wrote:
7. Aug 2022, 21:00
hplip is requires PyQt5
It really doesn't. You can install a printer, print or do anything without having Qt or PyQt5 installed through the CUPS interface. The hplip GUI requires PyQt5, but you don't have to use the gui.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5913
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0beta1

Post by gapan » 8. Aug 2022, 00:17

15.0RC1 announcement here: viewtopic.php?f=17&t=8394
Image
Image

Post Reply