Salix Xfce 15.0RC2

User avatar
mimosa
Salix Warrior
Posts: 3273
Joined: 25. May 2010, 17:02
Contact:

Re: Salix Xfce 15.0RC2

Post by mimosa » 14. Aug 2022, 10:27

Yes, it's up to date (I followed the instructions at the top of the RC1 topic, there were a lot of package upgrades). Rebooting seems to have fixed whatever interfered with mate-screenshot (though I still see the same message) but pulse is just the same.

I have also lost refind but I think I know the answer to that one!

User avatar
gapan
Salix Wizard
Posts: 6036
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0RC2

Post by gapan » 14. Aug 2022, 11:46

mimosa wrote:
14. Aug 2022, 09:48
I upgraded according to the instructions rather than re-install. So it's possible I broke something when playing around with it before. Because of a strange BIOS / hardware problem, I have to perform a tweak to get audio to work; but this is not normally needed for my USB headphones. Pulse crashed, sending me a message asking me to do the following, which produced an error:

Code: Select all

mimosa[~]$ start-pulseaudio-x11 
/usr/bin/pulseaudio: symbol lookup error: /usr/lib64/libgtk3-nocsd.so.0: undefined symbol: gtk_get_major_version
mimosa[~]$ 
Oh, I now realized I get that too! I'll investigate... It's definitely something I did...
Image
Image

User avatar
gapan
Salix Wizard
Posts: 6036
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0RC2

Post by gapan » 14. Aug 2022, 12:18

Still not sure why that happens, but you can temporarily fix it by reverting to the previous gtk3-nocsd package. You can find it here for example:

64bit: https://backup.salixos.org/monthly.0/re ... 64-1gv.txz
32bit: https://backup.salixos.org/monthly.0/re ... 86-1gv.txz
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3273
Joined: 25. May 2010, 17:02
Contact:

Re: Salix Xfce 15.0RC2

Post by mimosa » 14. Aug 2022, 12:32

I can confirm that fixes it.

By the way I presume I lost rEFInd because the default package was updated in the Slackware repositories. I don't suppose there;s any chance we could have laprjns's package instead? It has nice Salix branding, icons for different distros, etc, whereas the default package is terribly barebones.

But the problem is fixed by adding refind to EXCLUDES.

hugok
Posts: 309
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Xfce 15.0RC2

Post by hugok » 14. Aug 2022, 12:43

I also confirm the Volume control pulseaudio message.

Fixed with the temporarily gtk3-nocsd package.

At least this problem was good for correcting a typo in the Portuguese translation in the Volume control message that prompts :D
https://translate.fedoraproject.org/tra ... n&offset=2
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

User avatar
gapan
Salix Wizard
Posts: 6036
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0RC2

Post by gapan » 14. Aug 2022, 12:58

The pulseaudio problem should be fixed by the updated gtk3-nocsd-20220623-x86_64/i586-2gv.txz packages I just uploaded to the repos.
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3273
Joined: 25. May 2010, 17:02
Contact:

Re: Salix Xfce 15.0RC2

Post by mimosa » 14. Aug 2022, 16:48

I can confirm Pulse is now working normally for me.

User avatar
SalixManiac
Posts: 66
Joined: 15. Apr 2022, 02:26

Re: Salix Xfce 15.0RC2

Post by SalixManiac » 14. Aug 2022, 17:14

+1

For many XFCE users, Greybird is an old friend that we expect to find in the Theme collection.
Colin Chapman “light is right” those last words "the middle pedal is for cowards"

hugok
Posts: 309
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Xfce 15.0RC2

Post by hugok » 14. Aug 2022, 21:59

gapan wrote:
14. Aug 2022, 12:58
The pulseaudio problem should be fixed by the updated gtk3-nocsd-20220623-x86_64/i586-2gv.txz packages I just uploaded to the repos.
Yes, also working here now.
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

User avatar
gapan
Salix Wizard
Posts: 6036
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 15.0RC2

Post by gapan » 15. Aug 2022, 09:43

Dizover wrote:
12. Aug 2022, 18:05
Helo, I have a big issue, сan you please help me?
Since slackware 15 32 bit this issue is pop out even with salix os, maybe you can help me, i tried Salix Xfce 15.0RC2 32 bit and it's have this issue after loading img, my hard drive is not corrupt, and i can install salix 14.2.1 32bit, so this problem came up from slacware 15. That PC on what i try to install OS have Motherboard 661M03C-6L and hard drive is connected with IDE port, maybe that's a problem but I can't do anything about it, because the computer is old and does not have sata ports, is it possible to return IDE support? I can install salix 14.2.1 32bit, but I can't install the new version.
Hi Dizover and welcome. Try to remove any usb devices you have connected one by one. Are these screenshots during installation or after installation?
Image
Image

Post Reply