Salix Live Xfce 15.0 RC1

Post Reply
djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Salix Live Xfce 15.0 RC1

Post by djemos » 1. Oct 2022, 09:30

All flash storage media are supported now (e.g. SD cards).
Added support for sdcards in initrd of liveiso while there was support for sdcrds after installation.
I tested with one sandisk sdcard M2 1GB i have with an usb adapter and with a sandisk sdcard 2GB with a sandisk adapter.
The sdcard sdcard M2 1GB is regognised as /dev/sdb1 and opened in thunar and in SLI and i could create partitons.
Same with the other sandisk 2GB sdcard.
sdcads are like usb sticks so do not expect to see any change in time for real installation.
The installation takes almost two hours to copy 7-8 GB of files. The user has to do this once and he has a real system in a usb like in internal or external ssd disk to carry it in pocket. I do this the last years and it is working fine.
Using the install-upgrade-kernel-ext-usb-gtk gui tool (it is not included in iso) can also upgrade the kernel (it is working with grub). If he has choose (e)lilo then he has to do it by hand.

I did the installation to my old 5 years SANDISK CRUZER SNAP 32GB USB 2.0 FLASH DRIVE and everything went fine. I have done so many real installations in it for slackel and salix to test. And it is still working. Another type i ordered which is metalic is this SANDISK SDCZ71-032G CRUZER FORCE 32GB USB2.0 FLASH DRIVE.
After booting with the sandisk usb there was no various things such as proc, sys, efi are shown as "devices" (with a USB icon).
I could not figure out why this happened. I had used for the installation a kingston usb3.0 i bought which after 3 days it reports input/output error and i returned it.
It did not happened on making the live usb (it is another brand name) or when installing to vmware. So it has to do with the usb i think. I do not know.
I suggest to users to buy a sandisk 2.0 usb not more than 32GB. Since after copying 7-8GB of files at installtion time there is no difference in installation time.

I have spent dozens of hours last days to make installation tests on usb.
I even recreated all from start. Installing salix 32 and 64 from the standard iso's and recreated the live iso's again.
I have to mention that running the salix_startup_guide from the installer the links cannot open in firefox.
Because we run sli with sudo as root the firefox cannot run as root and open the links. Because of ~/.Xauthority belongs to one:users and not root. So this is not a bug. (you can see the message if you run the sli from terminal)
If you run salix_starup_guide.pdf as user (e.g. from terminal "atril /usr/doc/sli-1.2.5/salix_starup_guide.pdf) the links are working.

I will name this release rc1 and there is nothing more to be done.
Thank you all for testing.

You can download the iso images using the following links.

Salix Live Xfce 15.0 rc1 (32-bit, i686)
(size: 1699 MB, md5: 764bcb7b2a7ccb4e4eefb84314765067)
Sourceforge: https://sourceforge.net/projects/salix/ ... o/download

Salix64 Live Xfce 15.0 rc1 (64-bit, x86_64)
(size: 1693 MB, md5: c23dadd881b69db0e8901cf5f37c8c04)
Sourceforge: https://sourceforge.net/projects/salix/ ... o/download

hugok
Posts: 337
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Live Xfce 15.0 RC1

Post by hugok » 2. Oct 2022, 15:08

Nice djemos :D
I'll try it later for a spin and see how it goes.
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

hugok
Posts: 337
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Live Xfce 15.0 RC1

Post by hugok » 2. Oct 2022, 20:46

In the test I did everything worked fine for me however I noticed that the corrections I made in the Portuguese translation about two weeks ago are still not present in sli. Djemos, can you please sync the translations from Transifex and update sli?
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 15.0 RC1

Post by djemos » 2. Oct 2022, 22:01

hugok wrote:
2. Oct 2022, 20:46
In the test I did everything worked fine for me however I noticed that the corrections I made in the Portuguese translation about two weeks ago are still not present in sli. Djemos, can you please sync the translations from Transifex and update sli?
While on live environment download and reinstall this sli package and then run sli.
And tell me if translations for pt and br are ok
to test both run in a terminal
LANG=pt_PT.utf8 sudo sli
and
LANG=pt_BR.utf8 sudo sli

Please send me an email to dijemos@gmail.com
Your email i have it is not correct.

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 15.0 RC1

Post by djemos » 3. Oct 2022, 12:07

Ι had ordered a new usb stick. SANDISK SDCZ71-032G CRUZER FORCE 32GB USB2.0. It is super fast.
I did two installations one for salixlive-xfce and one for salixlive64-xfce. Installation started at 14:36 and ended at 14:56 (20 minutes) It costs only 5.90€

hugok
Posts: 337
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Live Xfce 15.0 RC1

Post by hugok » 5. Oct 2022, 21:44

Hi djemos

I did what you said.
The Portuguese (pt) translations are good and up to date. No problems here :D

As far as the Brazilian Portuguese (pt_BR) translations are concerned, running "LANG=pt_BR.utf8 sudo sli
" command, sli displays the Portuguese translation instead of Brazilian Portuguese. I even changed the system to pt_BR ...

one[~]$ locale
LANG=pt_BR.utf8
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE=C
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
LC_ALL=
one[~]$

I double-checked the translations in Transifex and they are different... so I don't know why sli doesn't display the brazilian portuguese translation instead of the Portuguese one :roll: :?:
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

hugok
Posts: 337
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Live Xfce 15.0 RC1

Post by hugok » 5. Oct 2022, 23:01

Shouldn't the Brazilian Portuguese translation file be named pt_BR.po instead of br.po in https://github.com/djemos/sli
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 15.0 RC1

Post by djemos » 6. Oct 2022, 09:47

Ok. I downloaded the pt and br po files from transifex and i rename them to pt_BR and pt_PT.
While on live environment download and reinstall this sli package and then run sli.
Check again as before with LANG=
It is working now.
And i will upload new rc2 isos

hugok
Posts: 337
Joined: 7. Dec 2011, 22:44
Location: Portugal
Contact:

Re: Salix Live Xfce 15.0 RC1

Post by hugok » 7. Oct 2022, 10:03

Hi djemos,

Everything is working fine now. Both sli pt and pt_BR translation

PS: I made a small correction in the Portuguese (pt) translation. Could you please update once again...

Thank you
Hugo Carvalho
Portuguese translator

https://github.com/hugok79

Post Reply