Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

User avatar
laprjns
Salix Warrior
Posts: 1032
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Salix Xfce 14.2RC1

Post by laprjns » 12. Aug 2016, 13:31

On a Basic install, guefi throws a missing gi message. Installing pygobject, (which in turn install gobject-introspection) fixes it

User avatar
gapan
Salix Wizard
Posts: 5516
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2RC1

Post by gapan » 12. Aug 2016, 19:34

OK, so we found a problem with the 64bit iso and UEFI systems. It will boot with some systems, but not all apparently. We investigated with laprjns and think we have found the problem. I'm currently uploading an RC2 iso that hopefully fixes this. Will post back when the iso is up.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5516
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2RC1

Post by gapan » 12. Aug 2016, 21:59

OK, RC2 is now up. I've updated the links in the first post, but I'm putting them here too:

Salix64 Xfce 14.2RC2 (64-bit, x86_64)
(size: 1012MB, md5: 7285287aece50b2ff60a574717c3ecab)
Sourceforge: https://sourceforge.net/projects/salix/ ... o/download
torrent: http://people.salixos.org/gapan/iso/sal ... C2.torrent

The 32-bit iso stays in RC1, as there was no such problem with it.
Image
Image

moicla77
Posts: 9
Joined: 10. Feb 2015, 16:42

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by moicla77 » 13. Aug 2016, 08:07

En français!
Bonjour,
Usage PC de bureau
Salix Xfce 14.2 RC2
Les applications que j'utilise :
Firefox OK
Thunderbird OK
Transmission OK
Skype : Slackbuild, s'installe mais ne démarre pas (probléme multilib)
LibreOffice : monétaire probléme interprétation du . du pavé numérique
Gramps (généalogie) je ne l'ai pas trouvé
Asunder OK
Mplayer OK
Gnome mplayer je ne l'ai pas trouvé
VLC je ne l'ai pas trouvé
Totem je ne l'ai pas trouvé
Brasero je ne l'ai pas trouvé
Xfburn OK
xsane OK
evince OK
hp-toolbox je ne l'ai pas trouvé

A suivre ...

tylerpc
Posts: 1
Joined: 13. Aug 2016, 15:22

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by tylerpc » 13. Aug 2016, 16:14

Hello, new user here but I've been on Slackware for a few years now. I just wanted to say thank you for all the hardwork and this RC1 (64-bit) is running smoothly on my Acer C720. This is one of those chromebooks with an i3 Haswell cpu. I always have to make a few tweaks to get it working nicely. For example, the touchpad settings used in Xfce aren't very good for my use case. I had to add a custom synaptics.conf to make it useable enough. There are a few more tweaks I have to make to get everything functioning (like suspend) but this is just a problem with my laptop and not Salix.

I think all of your default applications are very sane (thank you for adding libreoffice by default!). I decided to install Midori to see how it's been developing (haven't used it for a quite a while). I was pleasantly surprised to see all of the new features you can enable with extensions in the preference menu. I believe I actually prefer it over Firefox now. Firefox has been my favorite for most browsing but lately it's become bloated. I use Alienbob's Chromium package (along w/ widevine and pepperflash) to watch Netflix. But Midori I think has developed well enough to be my new main browser. The only tweak I needed was adding a custom user agent string because certain websites won't function with any of the strings it provided by default.

Finally, I want to say kudos on the spi package manager. It's a fantastic addition to everything that makes this distro awesome. Keep up the great work! :D

-Tyler

User avatar
ChuangTzu
Donor
Posts: 338
Joined: 19. May 2015, 23:34

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by ChuangTzu » 13. Aug 2016, 21:39

Bare metal install of 14.2 RC2 (64bit) is working well. No problems so far.

Is slapt-src synced with new repo?
Image
Image

User avatar
laprjns
Salix Warrior
Posts: 1032
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by laprjns » 13. Aug 2016, 22:37

ChuangTzu wrote:Is slapt-src synced with new repo?
If you mean Slackbuild.org 14.2 repo then yes it is.

User avatar
ChuangTzu
Donor
Posts: 338
Joined: 19. May 2015, 23:34

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by ChuangTzu » 13. Aug 2016, 23:54

laprjns wrote:
ChuangTzu wrote:Is slapt-src synced with new repo?
If you mean Slackbuild.org 14.2 repo then yes it is.
great! Then we are definitely close to a final release. 8-)
Image
Image

User avatar
Bart
Posts: 41
Joined: 31. May 2011, 17:41

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by Bart » 14. Aug 2016, 08:44

laprjns wrote:
ChuangTzu wrote:Is slapt-src synced with new repo?
If you mean Slackbuild.org 14.2 repo then yes it is.
What? It seeks also the packages of slackbuilds.org? How it works? In this mirror http://salix.mirror.garr.it/mirrors/sal ... uild/14.2/ I have two files both of size 0. Now I'm using sbopkg for Slackbuild packages.

First problem with vlc 2.2.4 (Alien package):

Code: Select all

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[000000000262c2e8] core libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
[0000000002762358] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0000000002762358] skins2 interface error: cannot instantiate qt4 dialogs provider
[0000000002762358] [cli] lua interface: Listening on host "*console".
VLC media player 2.2.4 Weatherwax
Command Line Interface initialized. Type `help' for help.
> ^C[0000000002762358] [cli] lua interface error: Error loading script /usr/lib64/vlc/lua/intf/cli.luac: lua/intf/modules/host.lua:279: Interrupted.

User avatar
laprjns
Salix Warrior
Posts: 1032
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Salix Xfce 14.2RC1 (32-bit) and 14.2RC2 (64-bit)

Post by laprjns » 14. Aug 2016, 13:34

ChuangTzu wrote:
laprjns wrote:
ChuangTzu wrote:Is slapt-src synced with new repo?
If you mean Slackbuild.org 14.2 repo then yes it is.
great! Then we are definitely close to a final release. 8-)
Well it is sync'ed but there are still some bugs that need to be worked out. Take for instance vlc. vlc is not available in Salix binary repository yet, but there is a slackbuild available in the Slackbuild.org 24.2 repository, So you should be able to install using Sourcery, slapt-src or spi, but it does not yet show up as a available package to build and install.
So there will still be some problems (availability and dependency issues) going forward with building and installing packages using Sourcery, slapt-src and spi.

Locked