Salix Live Xfce 14.2 beta1

babam
Posts: 18
Joined: 28. Oct 2015, 14:11

Re: Salix Live Xfce 14.2 beta1

Post by babam » 22. Sep 2016, 12:48

westms wrote:
Atip wrote:The * stands for the different locale I have tried, symbolic so to speak.
When the booting stalls on Setting up locale the keyboard is still accessible, therefore I can get out with. Ctrl-Alt-Delete.

Thunar does not open *.iso files, it just shows a blank page even with libisoburn installed.

I have no problem with simple scan in my HD Salix-14.2 installation.
On my system p7zip is not installed, Engrampa, version 1.8.0, shows ISO files anyway (not Salix Live Xfce 14.2 beta1).

@ Atip: Are relevant error messages in .xsession-errors or in /var/log available?

A Test: Launch engrampa first directly from the application menu or better from a terminal. Then select and open a ISO file from menu "Archives/Open" (probably other wording). Is the content displayed? When started from a terminal, then error messages are displayed in the terminal?
Whether in your system Engrampa using Libarchive to open ISO files.
Last edited by babam on 22. Sep 2016, 12:54, edited 3 times in total.
Sorry, my English is bad.

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 14.2 beta1

Post by djemos » 22. Sep 2016, 12:49

p7zip is needed by engrampa to open iso files in version 1.8.0.
I confirm that in salix-xfce installation or live iso engrampa-1.14.1 cannot open iso files. This is not live iso bug. I cannot find why cannot open iso files.
About simple scan since your printer works in real installation then it is another driver or package installed after installation. I cannot know what is this since i do not have such a printer.

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Re: Salix Live Xfce 14.2 beta1

Post by westms » 22. Sep 2016, 16:26

djemos wrote:p7zip is needed by engrampa to open iso files in version 1.8.0.
I'm sorry, but engrampa version 1.8.0, on Salix64 Xfce 14.1, does not need p7zip. I've reviewed before my first answer. The libarchive package is installed. Engrampa can open ISO image files here.

Currently, I do not use Salix64 Xfce 14.2, but I still have Salix64 Xfce 14.2RC1 on the test computer. On this installation libarchive is installed. P7zip is not installed by default. Engrampa here can not open ISO image files. I then installed p7zip. Then engrampa can open ISO image files. Probably a missing dependency.

So babam was right in his description of the circumstances.
djemos wrote:I confirm that in salix-xfce installation or live iso engrampa-1.14.1 cannot open iso files. This is not live iso bug. I cannot find why cannot open iso files.
In my opinion it is also a live ISO problem. The Live-ISO is surely to be a relatively independent Salix distribution. Am I right?

@ Atip:
Is sane installed? I don't mean xsane.

Which output generates a call to sane-find-scanner? (perhaps as su)

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 14.2 beta1

Post by djemos » 22. Sep 2016, 16:37

Before i write my message i tested engrampa in salix-xfce-14.2 installed, with p7zip installed and libarchive installed too.
I also tested in salix-xfce-14.2 live iso
engrampa cannot open iso images in both. If i could find what is missing then engrampa it will work on both, installation and live iso.
The Live-ISO is not an relatively independent Salix distribution. It includes the same packages with installation iso.

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 14.2 beta1

Post by djemos » 22. Sep 2016, 18:42

I remember that i had the same problem in slackel also. There i use p7zip-9.20.1 which does not have this problem with iso files.
p7zip versions from 15.09 and high have a problem with iso files because new 7-Zip checks that the size of payload of archive is equal to size of file.
This problem happens with isos created with mkisofs.
In google i found this " as developer of xorriso i have to nitpick that it is not the size of the ISO but the existence of empty files which makes mkisofs output indigestible for 7z.
mkisofs uses block address 4294967280 (aka 0xfffffff0 aka -16) for files which are no directories and contain no data bytes.
7z checks sanity of block addresses versus ISO size."

So there are 2 solutions which solve the problem.
1. Use the p7zip 9.20.1 version from here
or
2. install this engrampa 1.14.1 patched package from here which ignores the p7zip listing error "Unexpected end of archive"

Both were tested and engrampa open iso files in installation and live iso.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Salix Live Xfce 14.2 beta1

Post by Atip » 23. Sep 2016, 02:47

djemos wrote: So there are 2 solutions which solve the problem.
1. Use the p7zip 9.20.1 version from here
or
2. install this engrampa 1.14.1 patched package from here which ignores the p7zip listing error "Unexpected end of archive"

Both were tested and engrampa open iso files in installation and live iso.
No. 2 solution did not open iso file. :(

No. 1 solution did :)

Further:
My Canon printer does print in this Salix Live. Only simple scan does not detect it.

Stall on boot on Setting up locale: I checked Slackel-Live64-KDE there with locale=en_US.utf8 in menu_en.cfg present, no boot problem.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Salix Live Xfce 14.2 beta1

Post by Atip » 23. Sep 2016, 03:47

Code: Select all

one[~]$ sudo salix-codecs-installer-gtk
Password: 
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/sbin/salix-codecs-installer-gtk", line 466, in on_button_infowindow_yes_clicked
    repos = self.download_repo_info()
  File "/usr/sbin/salix-codecs-installer-gtk", line 276, in download_repo_info
    self.download_repofile(working_dir, url)
UnboundLocalError: local variable 'url' referenced before assignment
then
It seems you don't have the permissions to write the repository files.
Greek to me ;)

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Salix Live Xfce 14.2 beta1

Post by djemos » 23. Sep 2016, 05:48

No. 2 solution did not open iso file.
You always need p7zip installed. Did you install the p7zip salix 15.09 version from repos and then install the patched engrampa package?
It seems you don't have the permissions to write the repository files.
This has to do with the default http://salix.hostingxtreme.com repository mirror which has a problem. Change repository with reposetup and will have no problem installing files with gslapt.

About your problem booting with the 32 bit live iso i cannot reproduced it here. 32 bit live iso boots fine.
I do not have a canon printer either to test simple scan.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Salix Live Xfce 14.2 beta1

Post by mimosa » 23. Sep 2016, 20:06

I know this is old news, but it is perhaps relevant that it still continues: Salix Live boots fast and performs well on one stick, but then another stick performs badly. On this same stick I had AlienBob's Slackware Live and it booted quickly and opened applications and windows without delay, till I replaced it with Salix Live. Salix Live performs just as well on another stick, but not this one. I was booting it on the same hardware.

I understand that not all sticks are created equal, but it seems that Salix Live may be a bit more sensitive to any weaknesses.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Salix Live Xfce 14.2 beta1

Post by Atip » 24. Sep 2016, 02:06

djemos wrote:
No. 2 solution did not open iso file.
You always need p7zip installed. Did you install the p7zip salix 15.09 version from repos and then install the patched engrampa package?
Engrampa now opening iso files. :)
It seems you don't have the permissions to write the repository files.
This has to do with the default http://salix.hostingxtreme.com repository mirror which has a problem. Change repository with reposetup and will have no problem installing files with gslapt.
[/quote]

Check! Changed repository mirror, installed multi media codecs and parola does now play sound and videos. :)
About your problem booting with the 32 bit live iso i cannot reproduced it here. 32 bit live iso boots fine.
I do not have a canon printer either to test simple scan.

Locked