Libreoffice 6.4.5 x86_64

Here you can post links to your contributed packages.
djemos
Salix Warrior
Posts: 1096
Joined: 29. Dec 2009, 13:45
Location: Greece

Libreoffice 6.4.5 x86_64

Post by djemos » 31. Jul 2020, 08:40

Libreoffice 6.4.5 x86_64 package
Locale and Help packages for x86_64
Greek spell packages for ancient and modern Greek language.

User avatar
gapan
Salix Wizard
Posts: 5607
Joined: 6. Jun 2009, 17:40

Re: Libreoffice 6.4.5 x86_64

Post by gapan » 31. Jul 2020, 15:37

Thanks djemos!

Sad thing that they have abandoned 32bit packages. :?
Image
Image

djemos
Salix Warrior
Posts: 1096
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Libreoffice 6.4.5 x86_64

Post by djemos » 31. Jul 2020, 19:11

gapan wrote:
31. Jul 2020, 15:37
Thanks djemos!

Sad thing that they have abandoned 32bit packages. :?
What is annoying is that they did not abandoned 32 bit packages for windows.
Because i could not build 32 bit packages in my laptop it will take many hours, i included in latest 32bit openbox and mate versions of slackel the 6.2.8 LibreOffice version.

User avatar
Van_Vinkle
Donor
Posts: 119
Joined: 25. Oct 2012, 17:39

Re: Libreoffice 6.4.5 x86_64

Post by Van_Vinkle » 2. Aug 2020, 15:33

Thanks again Djemos!

galmei
Posts: 89
Joined: 1. Jun 2018, 21:54

Re: Libreoffice 6.4.5 x86_64

Post by galmei » 4. Aug 2020, 16:04

Unfortunately I have to cloud the joy about a new version.
I have installed Libreoffice 6.4.5 x86_64 on an installation Salix64 Xfce 14.2 but libreoffice does not work. The Salix installation is up to date. After starting the writer I get a window with "LibreOffice 6.4" in the title bar. The window background is first black and empty and then changes to grey. Then there are one or two muddled characters. ODT documents specified when opening are damaged, but can be repaired with 5.1.4 version. The window decoration in the title bar is without any function. Cancel is only possible with the Kill command. In the process table three related processes can be found.

What can I do to find the problem?

Maybe I have misunderstood something. Is this Libreoffice 6.4.5 x86_64 even suitable for Salix64 Xfce 14.2?

Is it possible that this Libreoffice compilation excludes my old CPU (CPU flags)?

Code: Select all

[~]$ inxi -f
CPU: Single core AMD Sempron 3200+ (-UP-) cache: 128 KB speed/max: 1000/1800 MHz
     CPU Flags: 3dnow 3dnowext 3dnowprefetch apic clflush cmov cr8_legacy cx16 cx8
     de extapic extd_apicid fpu fxsr fxsr_opt lahf_lm lm mca mce mmx mmxext msr
     mtrr nopl nx pae pat pge pni pse pse36 rdtscp rep_good sep sse sse2 syscall
     tsc vme vmmcall
[~]$
The Salix repositories contains version 5.1.4, which I am currently using again. If nothing helps, where can I possibly find the lastest 5 version?

djemos
Salix Warrior
Posts: 1096
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Libreoffice 6.4.5 x86_64

Post by djemos » 4. Aug 2020, 16:19

This is the official version from Libreoffice site which is repackaged to create a txz package for Slackware, Salix, Slackel.
I did not run it on a Salix system, so i cannot tell. But you can find here other versions (6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.7, 6.2.8) to test them.
Someone else can also run 6.4.5 on Salix and report.

Edit: I downloaded salixlive64-xfce-14.2.1.iso and booted in vmware. I upgraded libreoffice 5.1.4 to 6.4.5. It is running fine. No problem. I created documents and saved them. I then opened them in libreoffice without problem.
Is it possible that this Libreoffice compilation excludes my old CPU (CPU flags)?
I do not know. Since 5.1.4 is running maybe it is your system.

User avatar
gapan
Salix Wizard
Posts: 5607
Joined: 6. Jun 2009, 17:40

Re: Libreoffice 6.4.5 x86_64

Post by gapan » 4. Aug 2020, 18:24

I'm running it on 14.2 since djemos uploaded the packages a few days ago. I can see no problems. In fact, all the bugs I've been experiencing with previous 6.x versions (that were not there in 5.x) seem to be fixed.

@galmei, are there any errors if you try to launch it from a terminal? For example:

Code: Select all

lowriter
Image
Image

galmei
Posts: 89
Joined: 1. Jun 2018, 21:54

Re: Libreoffice 6.4.5 x86_64

Post by galmei » 5. Aug 2020, 11:23

djemos wrote:
4. Aug 2020, 16:19
This is the official version from Libreoffice site which is repackaged to create a txz package for Slackware, Salix, Slackel.
I did not run it on a Salix system, so i cannot tell. But you can find here other versions (6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.7, 6.2.8) to test them.
Thanks for the clarification, djemos.

galmei
Posts: 89
Joined: 1. Jun 2018, 21:54

Re: Libreoffice 6.4.5 x86_64

Post by galmei » 5. Aug 2020, 11:48

Thanks for your answer, gapan.
gapan wrote:
4. Aug 2020, 18:24
@galmei, are there any errors if you try to launch it from a terminal? For example:

Code: Select all

lowriter
There are no error messages after the call and after exiting. If I start from a terminal, I can simply abort with Ctrl-C.

Then I tried localc. Small message windows are displayed. The content:

My translation:

Code: Select all

The component cannot be loaded. Possibly the installation was interrupted or not completely executed.
Complete error message:

 loading component library <file:///usr/lib64/libreoffice6.4/program/../program/libsdlo.so> failed.
Original:

Code: Select all

Die Komponente kann nicht geladen werden. Möglicherweise wurde die Installation unterbrochen oder nicht vollständig durchgeführt.
Vollständige Fehlermeldung:

 loading component library <file:///usr/lib64/libreoffice6.4/program/../program/libsdlo.so> failed.
However, the component is available:

Code: Select all

[~]$ ls -l /usr/lib64/libreoffice6.4/program/libsdlo.so 
-rwxr-xr-x 1 root root 7879480 Jul 31 09:05 /usr/lib64/libreoffice6.4/program/libsdlo.so*
[~]$
localc allows operation in safe mode. In this mode a Calc spreadsheet is displayed.
I have tried all libreoffice programs like this, also soffice. Each time with similar behaviour.

But the soffice window showed a working menu bar and the window decoration was functional, but had no other content. While testing with soffice I also minimized the window and brought it back to the foreground. The result was that the typical soffice window with navigation/function selection and recently used files was displayed. The decoration of the lowriter window became functional during testing. If I minimize the empty lowriter window and then bring it back to the foreground, after a short waiting time a correct and familiar appearance is displayed. This is the same with all other Libreoffice applications.

When I searched the web I found opinions that the libavahi package must be installed (http://forum.slitaz.org/topic/libreoffi ... -libsdloso). It is not installed on my Salix installation. The libavahi package create a mountain of other packages in chain reaction. I will not install it. But I tried the suggestion to create two fake libraries (libavahi-client.so.3 and libavahi-common.so.3) -- but it has no effect on the problem. Maybe more is needed after all.

In Discusion https://www.linuxquestions.org/question ... 175647308/ from the end of January 2019 Alien Bob writes that his LibreOffice package has been compiled on Slackware and does not require any additional packages. However, packages younger than LibreOffice 6.2.x are compiled for Slackware-current.

I will try 6.4.x for Slackware-current from Alien Bob for a test. I think the risk to ruin the system is smaller than installing the one compiled by LibreOffice Foundation, which is provided by djemos as a package. I would like to read your opinions first.

For me the whole thing looks like an (additional) problem with Gtk2/Gtk3.

User avatar
gapan
Salix Wizard
Posts: 5607
Joined: 6. Jun 2009, 17:40

Re: Libreoffice 6.4.5 x86_64

Post by gapan » 5. Aug 2020, 16:01

I do have avahi installed here, but in order to test it, I removed it and libreoffice runs just fine without it. So, it's not avahi that is the problem. By now, I have installed the package in half a dozen different computes and it works everywhere.

Can you try creating a new user account and launching it from there?

And there's no way the package that AlienBob built for current will work in 14.2.
Image
Image

Post Reply