LibreOffice 6 and 7 for Salix 14.2

Here you can post links to your contributed packages.
Post Reply
User avatar
gapan
Salix Wizard
Posts: 5631
Joined: 6. Jun 2009, 17:40

LibreOffice 6 and 7 for Salix 14.2

Post by gapan » 9. Sep 2020, 12:56

So I've built packages for newer LibreOffice releases that work in 14.2. I have uploaded packages for both 6.4.6.2 and 7.0.1.2 releases. You should note that they do have some issues, so make sure you read to the end of this post before using them.

First, packages for LibreOffice 6.4.6.2:

64bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

32bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

You'll find additional locale packages here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i686-1gv/

and help packages here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i686-1gv/

And packages for LibreOffice 7.0.1.2:

64bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

32bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

Locale packages are here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i686-1gv/

and help packages here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i686-1gv/

ISSUES
Although I built these on a 14.2 system, with only a newer gcc than what comes as standard, I can see they have problems with the GTK+3 libraries. LO 6.4.6.2 mostly works OK with the GTK+3 interface. As far as I can see, the only thing that doesn't work is Base, the bundled database, which crashes on launch. With LO 7.0.1.2, everything launches, but consumes 100% of one CPU core while focused, for no reason at all (it throws several warnings on the terminal). However, they both work fine using the old default "generic" interface instead of GTK+3. It probably looks ugly for most, but if you're using something like Raleigh as your GTK theme, it blends right in. For that reason, I've added libreoffice scripts in /etc/profile.d/ that set the respective environment variable:

Code: Select all

export SAL_USE_VCLPLUGIN=gen
Right after installation, the profile scripts have not been read yet, so the GTK+3 interface will be used instead. Logout and back in, or source the /etc/profile.d/libreoffice.sh script from your terminal and launch libreoffice from the same terminal. Setting this back to "gtk3" (and logging out/in), or simply commenting it out will use the GTK+3 interface.

Due to these issues, it's unlikely that we're going to upgrade LibreOffice with any of these in the official repositories. It may be the case that if we use a newer GTK+3 in 14.2, these problems will disappear, but I haven't tried it yet*. Upgrading GTK+3 might potentially also break other stuff (like themes) because GTK developers apparently hate backwards compatibility.

I also tried to build LO with the Qt interface, but it fails miserably. The one that we have in 14.2 is apparently too old for LO too.

Also, I can see no reason why these won't work in current (djemos, you're welcome to try them).

* Didier, you have a newer GTK+3 in slint, so you may try these if you like.
Image
Image

djemos
Salix Warrior
Posts: 1103
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: LibreOffice 6 and 7 for Salix 14.2

Post by djemos » 9. Sep 2020, 19:20

I have installed the 6.4.6 and 7.0.1 64 bit packages in slackel and work fine. No problem with fonts.
I see that helpacks 7.0.0 and l10n packages are repackaged from the LibreOffice official repos.

I also have build 7.0.1 for slackel using alien scripts (including l10n (includes help) and dict packages, without qt5 and java support.
They took 8 hours to build for 64 bit and other 8 hours for 32 bit. They also work fine in slackel.

User avatar
gapan
Salix Wizard
Posts: 5631
Joined: 6. Jun 2009, 17:40

Re: LibreOffice 6 and 7 for Salix 14.2

Post by gapan » 10. Sep 2020, 21:26

djemos wrote:
9. Sep 2020, 19:20
I have installed the 6.4.6 and 7.0.1 64 bit packages in slackel and work fine. No problem with fonts.
So, no weird CPU issues with 7.0.1.2? And lobase works with 6.4.6.2?
djemos wrote:
9. Sep 2020, 19:20
I see that helpacks 7.0.0 and l10n packages are repackaged from the LibreOffice official repos.
Yeah, it's easier to do that way...
djemos wrote:
9. Sep 2020, 19:20
I also have build 7.0.1 for slackel using alien scripts (including l10n (includes help) and dict packages, without qt5 and java support.
They took 8 hours to build for 64 bit and other 8 hours for 32 bit. They also work fine in slackel.
It takes about 2.5 hours for each on my build server. :D I've seen alienbob's scripts and they are too much. I've created SLKBUILDs that are a lot simpler.

So, if these work fine for you for Slackel, I'd be happy to build newer versions whenever you want them. In fact, I built these:
http://people.salixos.org/gapan/libreof ... e-slackel/
They are exactly the same as the 7.0.1.2 packages in the first post, but they don't include the /etc/profile.d scripts, so they don't default to the "generic" UI, but use the gtk3 one instead.
Image
Image

djemos
Salix Warrior
Posts: 1103
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: LibreOffice 6 and 7 for Salix 14.2

Post by djemos » 12. Sep 2020, 08:44

gapan wrote:So, no weird CPU issues with 7.0.1.2? And lobase works with 6.4.6.2?
Yes locale works.
gapan wrote:It takes about 2.5 hours for each on my build server. :D I've seen alienbob's scripts and they are too much. I've created SLKBUILDs that are a lot simpler.
It takes 8 hours in my lenovo i3-4030U (4) @ 1.800GHz with 4GB RAM. Your server is turbo. :)
Well alienbob's scripts download a lot of other packages except locales and build libreoffice. While yours just download the source code. But it is good to also build and locale and help packages so to not wait for libreoffice to build them and download and repackage them for salix, slackel.
Also i have seen that your build of libreoffice load much quicker big docx file (186 pages) than libreoffice i build with alienbob's scripts. I see also that my libreoffice build load memory in steps as load the file. I did not checked how much memory your build use and how much my build use. I will test it and report here again using your builds 7.0.1.2 for slackel.

Edit: packages 7.0.1.2 build for slackel are loading the docx (186 pages document) much slower, quite the same like mine slackel builds. While the other 7.0.1.2 build for salix are much quicker. I do not know why this happens.
About memory: These screenshots might help.
your build for slackel.
Image

mine build for slackel.
Image

So, builds for slackel both load the file much slower than builds for salix. Maybe this has to do with stable and current tree of slackware and a lot of libraries and programs upgrades included in current tree i think.
Both builds are stable which is what we need.

User avatar
gapan
Salix Wizard
Posts: 5631
Joined: 6. Jun 2009, 17:40

Re: LibreOffice 6 and 7 for Salix 14.2

Post by gapan » 12. Sep 2020, 17:56

Actually, my script builds all locales, but later removes them, because that would create a huge package. We have them as separate packages, as usual, anyway.

It doesn't make much sense that you get different load times and memory consumptions for the "_salix14.2" and "_slackel" packages. They are essentially identical, the only thing different is that the slackel ones don't include the /etc/profile.d/ scripts. Were you using the gtk3 UI in both cases? The generic UI feels faster I think.

And I've also built packages for Libreoffice 6.3.6.2. As far as I can tell, it's the last version that works with no problems with the gtk3 UI in Salix 14.2. I'll keep on testing it though. Here are the packages:

64bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

32bit
http://people.salixos.org/gapan/libreof ... ix14.2.txz
http://people.salixos.org/gapan/libreof ... ix14.2.md5

respective locale packages here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i586-1gv/

and help packages here:
64bit: http://people.salixos.org/gapan/libreof ... 86_64-1gv/
32bit: http://people.salixos.org/gapan/libreof ... -i586-1gv/
Image
Image

djemos
Salix Warrior
Posts: 1103
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: LibreOffice 6 and 7 for Salix 14.2

Post by djemos » 13. Sep 2020, 06:02

gapan wrote:Actually, my script builds all locales, but later removes them, because that would create a huge package. We have them as separate packages, as usual, anyway.
Since script builds all locales why to not create the txz locale packages and then remove them so the libreoffice package will not be huge.

User avatar
gapan
Salix Wizard
Posts: 5631
Joined: 6. Jun 2009, 17:40

Re: LibreOffice 6 and 7 for Salix 14.2

Post by gapan » 13. Sep 2020, 22:15

it would be more work to do it that way.
Image
Image

DidierSpaier
Posts: 332
Joined: 20. Jun 2016, 20:15

Re: LibreOffice 6 and 7 for Salix 14.2

Post by DidierSpaier » 14. Sep 2020, 21:39

gapan wrote:
9. Sep 2020, 12:56
* Didier, you have a n-x86_64-1slintewer GTK+3 in slint, so you may try these if you like.
I just did that, having received your email.

Using gtk+3-3.24.12-x86_64-1slint I have no weird CPU issues with 7.0.1.2., and base doesn't crash at startup in 6.4.6.2 (using your packages). It complaints when trying to create a new database using the wizard that "A connection for the following URL was requested "sdbc:embedded:hsqldb" and not found, but I assume that's completely unrelated. Maybe you could try the package GTK+3 here to test on Salix? The source is there. For your information the package was built with meson, using gtk+3.SlackBuild.new.

Post Reply