Claws-mail 3.16

If there's software you need and you can't find, make a request for it.
Post Reply
User avatar
simone
Posts: 15
Joined: 24. Sep 2016, 14:36

Claws-mail 3.16

Post by simone » 1. Feb 2018, 09:08

In December the new version of Claws-e-mail came out, will it be available in the repositories, or where to get it?
Thanks

http://www.claws-mail.org/news.php

User avatar
witek
Posts: 233
Joined: 16. Nov 2009, 13:41
Location: Poland.Łódź

Re: Claws-mail 3.16

Post by witek » 1. Feb 2018, 10:39

I have experience with some newer version of Claws-mail (in Debian) and I`m a bit dissappointed. Since 3.14 or so the fancy plugin stopped working and Claws cannot render HTML messages. Thus I`m staying with 3.11 if possible. The problem with fancy plugin seems to be general however. Dilo is recommended as a replacemt but IMHO it falls short.

DidierSpaier
Posts: 264
Joined: 20. Jun 2016, 20:15

Re: Claws-mail 3.16

Post by DidierSpaier » 1. Feb 2018, 14:54

Hello,
simone wrote:In December the new version of Claws-e-mail came out, will it be available in the repositories, or where to get it?http://www.claws-mail.org/news.php
You can get one from this Slint repository:
http://slackware.uk/slint/x86_64/slint-14.2.1/slint/
If you need a 32-bit version the source directory is here:
http://slackware.uk/slint/x86_64/slint- ... laws-mail/

I still use Thunderbird, thus I'd be grateful for a feedback.

Credit gapan for the SlackBuild.

Didier

User avatar
simone
Posts: 15
Joined: 24. Sep 2016, 14:36

Re: Claws-mail 3.16

Post by simone » 1. Feb 2018, 15:38

DidierSpaier wrote:Hello,
simone wrote:In December the new version of Claws-e-mail came out, will it be available in the repositories, or where to get it?http://www.claws-mail.org/news.php
You can get one from this Slint repository:
http://slackware.uk/slint/x86_64/slint-14.2.1/slint/
If you need a 32-bit version the source directory is here:
http://slackware.uk/slint/x86_64/slint- ... laws-mail/

I still use Thunderbird, thus I'd be grateful for a feedback.

Credit gapan for the SlackBuild.

Didier
Downloaded and installed but does not start ....
claws-mail
claws-mail: error while loading shared libraries: libpisock.so.9: cannot open shared object file: No such file or directory

DidierSpaier
Posts: 264
Joined: 20. Jun 2016, 20:15

Re: Claws-mail 3.16

Post by DidierSpaier » 1. Feb 2018, 17:05

This package depends on pilot-link from Slackware64-14.2. Alternatively install it, or try to rebuild the package locally (maybe it's picked up as dependency if pilot-link is installed, I didn't check).

User avatar
simone
Posts: 15
Joined: 24. Sep 2016, 14:36

Re: Claws-mail 3.16

Post by simone » 5. Feb 2018, 11:26

Installed with SlackBuildManager but it gives me problems with the pgp signature. Remaining the previous one .... ;)

DidierSpaier
Posts: 264
Joined: 20. Jun 2016, 20:15

Re: Claws-mail 3.16

Post by DidierSpaier » 5. Feb 2018, 12:53

I don't know what is SlackBuildManager but be aware that I don't sign packages individually, only CHECKSUMS.md5.gz, as does gapan with Salix (and using a script he wrote just slightly modified).

If you add this Slint repository: http://slackware.uk/slint/x86_64/slint-14.2.1/ to /etc/slapt-get/slapt-getrc and run slapt-get --add-keys this should close the issue.

But if you don't trust this repository (you choice) you can still rebuild the package from source.

User avatar
simone
Posts: 15
Joined: 24. Sep 2016, 14:36

Re: Claws-mail 3.16

Post by simone » 5. Feb 2018, 13:10

I rebuilt it with Sourcery by default on Salix, but I think it's a bug in the new version .... it no longer decrypts the pgp keys :)
Thanks

DidierSpaier
Posts: 264
Joined: 20. Jun 2016, 20:15

Re: Claws-mail 3.16

Post by DidierSpaier » 5. Feb 2018, 13:21

Ah OK i misunderstood your previous post.

But then I should check if I observe the same behavior with our package. Would you be kind enough to elaborate on this issue, eg. indicating your actions and their results?

User avatar
simone
Posts: 15
Joined: 24. Sep 2016, 14:36

Re: Claws-mail 3.16

Post by simone » 5. Feb 2018, 14:22

Added repo slint and installed for trial version 3.16 of Claws-mail. If I open an encrypted email with pgp, it says it can not be decrypted. With the previous version no problem. So I reinstalled the previous version.
Thanks

Post Reply