[Solved] Wishing Kdenlive 15.04.1

If there's software you need and you can't find, make a request for it.
Post Reply
User avatar
Sybelius
Posts: 82
Joined: 9. Jan 2010, 01:51
Location: Gaborone - Botswana

[Solved] Wishing Kdenlive 15.04.1

Post by Sybelius » 18. May 2015, 19:34

Hi Salix Team,

Please, if possible I should like to get Kdenlive 15.04.1 (it's the last born) package for Salix 14.1 KDE 32 bit .

https://kdenlive.org/
https://kdenlive.org/discover/15.04.1
http://download.kde.org/stable/applicat ... .04.0/src/
https://kdenlive.org/download-source

Thank you for your kind attention :)
Best Regards
Last edited by Sybelius on 19. May 2015, 20:55, edited 1 time in total.

User avatar
gapan
Salix Wizard
Posts: 5532
Joined: 6. Jun 2009, 17:40

Re: Wishing Kdenlive 15.04.1

Post by gapan » 18. May 2015, 21:17

Since we don't actually provide kdenlive in salix, it's provided by slackbuilds.org, you'll probably have better luck if you directly message the respective maintainer in sbo:
http://slackbuilds.org/repository/14.1/ ... /kdenlive/
Image
Image

djemos
Salix Warrior
Posts: 1073
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Wishing Kdenlive 15.04.1

Post by djemos » 19. May 2015, 10:25

There is no way to have kdenlive-15.04.1 on salix or even on slackware current since need kde-5.x
You can use kdenlive-0.9.8 which is based on kde-4.x versions.
For 0.9.8 version download these packages i486, x86_64 and see if they are working for you.

You can build your 0.9.10 package with this SLKBUILD
Copy this file in a kdenlive folder, cd to folder and run

Code: Select all

fakeroot slkbuild -X

User avatar
Sybelius
Posts: 82
Joined: 9. Jan 2010, 01:51
Location: Gaborone - Botswana

Re: Wishing Kdenlive 15.04.1

Post by Sybelius » 19. May 2015, 20:53

@ Gapan and Djemos: Thank you :)

Edit

Hi Djemos :) thanking that slackbuild of yours I got kdenlive-0.9.10-i486-1dj.txz.
Needing the following procedure on Slackware 14.1 KDE 32 bit:
install "mlt" (from Repository Slackel) which requires:
- libcdio-paranoia # Repository Slackel
- libjpegturbo # from source
- libva # Repository Alien Bob
- libxshmfence # from source http://lists.x.org/pipermail/xorg/2013- ... 56216.html
- sox # Repository Slackware.com
(other dipendences already installed)

After installation Kdenlive complains for the absence of:
- dvgrab # installed package from download - OK
- dvauthor # installed by Gslapt - OK
>>> avformat module (ffmpeg) # still unable to solve that issue; is it part of "mlt" or "ffmpeg"?
Installed packages:
- mlt-0.9.0-i486-2dj.txz
- ffmpeg-2.1.5-i486-1gv
Last edited by Sybelius on 21. May 2015, 13:57, edited 1 time in total.

djemos
Salix Warrior
Posts: 1073
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: [Solved] Wishing Kdenlive 15.04.1

Post by djemos » 20. May 2015, 19:54

avformat is included on ffmpeg
you need cdparanoia and libcddb, libcdio and ffmpeg from salix and slackware 14.1 repos. You can install all them with gslapt.
Do not use libcdio-paranoia and mlt from slackel which is based on slackware current and they depend on libpng16 and other deps.
Build mlt from source (slapt-src -i mlt)
and then build kdenlive.

User avatar
Sybelius
Posts: 82
Joined: 9. Jan 2010, 01:51
Location: Gaborone - Botswana

Re: [Solved] Wishing Kdenlive 15.04.1

Post by Sybelius » 20. May 2015, 20:59

@ Djemos: a couple of hours ago I have been reading your message " avformat is included on ffmpeg "; so, after dinner I removed ffmpeg-2.1.5-i486-1gv and installed ffmpeg-2.4.3-i486-1alien.txz
Kdenlive does'nt complains anymore, all modules are loaded but am reading now what you added to that message of yours and seems I did the wrong process.
I will test Kdenlive as soon as possible and report the result.

Thanks once again Djemos :)

djemos
Salix Warrior
Posts: 1073
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: [Solved] Wishing Kdenlive 15.04.1

Post by djemos » 20. May 2015, 21:15

if it is working then it is ok.
Just test it with a video file.

User avatar
Sybelius
Posts: 82
Joined: 9. Jan 2010, 01:51
Location: Gaborone - Botswana

Re: [Solved] Wishing Kdenlive 15.04.1

Post by Sybelius » 20. May 2015, 21:24

Just tested joining two clips/converting/exporting.
It works but when going to move the clips to the bin it results full (is completely empty) and needing to eliminate the files bypassing the bin :D
Don't know if because the installation I did; if the problem continues I will remove all packages and start again following the procedure you suggested to me

Edit (May 21,2015)

@ Djemos: - Due the bin's issue I have been removing mlt>libcdio-paranoia>Kdenlive and reinstalling following that hint of yours (with the command "slapt-src -i mlt" can't create it, so I have been installing "mlt" and requested dependencies by packages from Repository Slacky.eu and something by SlackBuild and source).
Final result: Kdenlive works properly ( as before :) ) but the bin is still faulty, can't use it, needing to eliminate files with direct command.
The folder /home/dominum/.local/share/Trash is empty, don't know how to fix it.
>>> jack-audio-connection-kit-0.124.1-i486-1_SBo and ladspa_sdk-1.13-i486-4_SBo have been upgraded by Gslapt.

Cheers!

Edit (May 24,2015)

Solved :)
cd /home/user/.local/share/Trash/
# rm -fr *
Start new session or reboot

Post Reply