Page 2 of 3

Re: QlandkarteGT

Posted: 1. Jun 2010, 20:58
by anttel
After upgrading following the wiki, QLandkarteGT works fantastic!!!! Many thanks. to connect my Garmin GPS there seems to be Garmin drivers necessary. link: ... &Itemid=17

Could you please help me again?
Best regards.


Re: QlandkarteGT

Posted: 1. Jun 2010, 21:04
by gapan
Did you try to follow the instructions there? The only difference would be at the end, where you should run

Code: Select all

make install
as root, instead of running with sudo.

Re: QlandkarteGT

Posted: 2. Jun 2010, 19:13
by anttel
Well I followed the instructions. After that I copied the generated files into /usr/lib/qlandkartegt/ but the version of these Garmin device files were not accepted bij Qlandkarte 0.18. Then I copied these files from my sidux installation (qlandkarte and the garmin drivers package is in the debian SID repository) and these are accepted by the Salix Qlandkarte. Now I cannot acces the Garmin mapcsx60 GPS via USB. Acces is denied. I did trie to fix the permissions: ... _GNU/Linux

I tried both the debian and opensuse udev.rules for my garmin but still the acces is denied...

Then I started QLandkarte as root. When I try to download tracks I get the next message:

Failed to download tracks. Failed to configure USB: Device or resource busy

The kernel driver 'dummy' is blocking. Please use 'rmmod dummy' as root to remove it temporarily. You might consider to add 'blacklist dummy' to your modeprobe.conf, to remove the module permanently.

When I use rmmod dummy the message I get is:

# rmmod dummy
ERROR: Module dummy does not exist in /proc/modules

This is how far I've come.

I've got the feeling it's almost done, but how can I get acces to my Garmin GPS (USB)?
best regards,

Re: QlandkarteGT

Posted: 4. Jun 2010, 00:18
by laprjns
Here's a package for the drivers: ... 86-1rl.txz
Don't know if it will work, but it built without any problems.
Also, I have rebuilt the qlandkarteGT to fix the icon problem. Here's the new package: ... 86-2rl.txz

Hope this works for you

Re: QlandkarteGT

Posted: 7. Jun 2010, 19:16
by anttel
Hello Laprjns,
Thank you very much for the two new packages. Qlandkarte and the Garmin package install fine. All the Garmin GPS are in the settings menu. Selecting my Garmin GPSmap 60CSx works fine, but connecting to through usb is not allowed: acces is denied. I described this in a previous message. I don't knowyet how to solve this. I tried to fix this like the debian and the fedora options, but too bad they both don't work.

Could someone help me out with this last hurdle, please.
Thank you in advance


Re: QlandkarteGT

Posted: 8. Jun 2010, 02:07
by laprjns
Does it work if you run qlandkartegt as root?

Re: QlandkarteGT

Posted: 8. Jun 2010, 10:25
by flux
Try to remove the kernel module


as root and then start again qlandkarteqt (as user).

It works for me with gpsbabel in this way, with the loaded kernel module there is no way to access the GPS device via USB.


Re: QlandkarteGT

Posted: 8. Jun 2010, 14:06
by anttel
Hello Laprnjs and flux,
Many thanks for the help you give. As root it does work! The GPS device beeps once as I plug it in (USB) - in sidux this means a working connection and now it also does in Salix (I did remove the garmin kernel drivers). In user modus USB acces is denied. I remember there is something with udev rules. I'll try to find out how.


Re: QlandkarteGT

Posted: 8. Jun 2010, 23:58
by laprjns
If it works running as root, then it seems to me to be a permission problem, and you need some kind of udev rule. I'm getting a little out of my expertise (which doesn't require going to far :) ) but try adding this. Create a file in /etc/udev/rules.d called 51-garmin.rules and add the follwing line to it

Code: Select all

SYSFS{idVendor}=="091e", SYSFS{idProduct}=="0003", MODE="666"
After rebooting, see if your normal user can now get access to you garmin device

Re: QlandkarteGT

Posted: 14. Jun 2010, 14:03
by anttel
After creating the 51-garmin.rules file and adding the line and a reboot still usb acces is denied to my garmin gps.
I tried also some other variants of th commands as stated on the gps babel website. Does these permissions work different in Salix?