Look for VLC 3.0.1

General talk about packaging procedures and packages.
Post Reply
raymccoy
Posts: 11
Joined: 28. May 2010, 11:05

Look for VLC 3.0.1

Post by raymccoy » 28. Feb 2018, 10:12

Hello,
how do i get VLC Player 3.0.1 installed on the SALIX 14.2?

slap-get founds only 2.4 (so vlc 2.4 is yes installed)

DidierSpaier
Posts: 282
Joined: 20. Jun 2016, 20:15

Re: Look for VLC 3.0.1

Post by DidierSpaier » 28. Feb 2018, 11:22

raymccoy wrote:Hello,
how do i get VLC Player 3.0.1 installed on the SALIX 14.2?
Short answer: there is no simple way.

Long answer: Alien Bob has a package for VLC 3.0.0 in this repository: http://slackware.uk/people/alien/sbrepo ... 86_64/vlc/ but this needs qt5, qt5-webkit and libxkbcommon on top of a full Slackware installation, which means that on Salix you probably need other dependencies that you'd have to find by yourself. Furthermore you would have to avoid mixing packages from different repos, which can fail. For instance qt5 is not at the same version in the aforementioned repo and in a Salix repo.

As an aside, for these reasons I won't upgrade VLC for Slint.

DrCR
Posts: 34
Joined: 30. May 2014, 05:14

Re: Look for VLC 3.0.1

Post by DrCR » 2. Apr 2018, 01:17

It would then seem VLC 3.x will not be present until Slackware 15? Would that be a fair conjecture?

User avatar
mimosa
Salix Warrior
Posts: 3019
Joined: 25. May 2010, 17:02
Contact:

Re: Look for VLC 3.0.1

Post by mimosa » 2. Apr 2018, 06:53

Well, or 14.3 ...

DrCR
Posts: 34
Joined: 30. May 2014, 05:14

Re: Look for VLC 3.0.1

Post by DrCR » 3. Apr 2018, 04:00

OK, thanks

Post Reply