ImageMagick

General talk about packaging procedures and packages.
Post Reply
User avatar
Tim CowChip
Posts: 301
Joined: 27. May 2011, 03:35
Location: Cascade Locks, OR

ImageMagick

Post by Tim CowChip » 23. Oct 2012, 21:39

I was surprised not find this package, upon which so many other packages depend, in any Salix sources. If no one objects I will submit this package for inclusion in the 14.0 repositoy.
ImageImage

User avatar
zAchAry
Posts: 804
Joined: 11. May 2010, 09:02
Location: Israel

Re: ImageMagick

Post by zAchAry » 23. Oct 2012, 23:14

Is not ImageMagick a Slackware official package?
Image
Help to make Slackware easier Donate to Salix

User avatar
laprjns
Salix Warrior
Posts: 1031
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: ImageMagick

Post by laprjns » 23. Oct 2012, 23:16

It already there, it a Slackware package, not Salix. I installed it several times using slapt-get this past weekend to build some packages. There looks to be a problem with the 14.0 x64 repo right now. I notice the PACKAGE.TXT file is empty (size is 0 kb) . Look here:
http://salix.enialis.net/x86_64/slackware-14.0/
If your trying to install on a x64 this may be the problem. The i486 PACKAGE.TXT looks ok.

User avatar
Tim CowChip
Posts: 301
Joined: 27. May 2011, 03:35
Location: Cascade Locks, OR

Re: ImageMagick

Post by Tim CowChip » 24. Oct 2012, 00:05

Come to think of it I remember disabling the Slackware-14.0 source recently when it failed during update.
Thanks for the info guys.
ImageImage

User avatar
gapan
Salix Wizard
Posts: 5498
Joined: 6. Jun 2009, 17:40

Re: ImageMagick

Post by gapan » 24. Oct 2012, 07:40

laprjns wrote:I notice the PACKAGE.TXT file is empty (size is 0 kb) . Look here:
http://salix.enialis.net/x86_64/slackware-14.0/
How did that happen? It's fixed now anyway.
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3089
Joined: 25. May 2010, 17:02
Contact:

Re: ImageMagick

Post by mimosa » 24. Oct 2012, 10:26

I had this with Slackel (installed for a friend). I updated slaptgetrc to point at 14.0 instead of current, and the Slackware part generated an error. Thought it was a mistake on my part, and I was going to check I had the links right.

User avatar
Spixi
Posts: 8
Joined: 1. Feb 2012, 19:27

Re: ImageMagick

Post by Spixi » 30. Nov 2012, 18:27

Hello, I have a similar problem (using Salix OS 1.33.7, but the 32 Bit version)

Code: Select all

root[~]# slapt-get --install imagemagick-6.6.6_10-i486-1
Lese Paket-Listen... /var/log/packages: Datei oder Verzeichnis nicht gefunden
Fertig
Schliesse imagemagick aus, mit --ignore-dep to override ueberschreiben
Paket udev, welches von mesa benoetigt wird, ist ausgeschlossen
Die folgenden Pakete wurden AUSGESCHLOSSEN:
  imagemagick 
0 upgraded, 0 reinstalled, 0 newly installed, 0 to remove, 1 not upgraded.

Fertig
root[~]# slapt-get --install imagemagick --ignore-dep
Lese Paket-Listen... /var/log/packages: Datei oder Verzeichnis nicht gefunden
Fertig
Die folgenden NEUEN Pakete werden installiert:
  bzip2 zlib binutils expat freetype fontconfig gamin glib2 libXau libXdmcp 
  libxcb libX11 libXrender libpng pixman cairo cxxlibs gmp libelf mpfr libmpc 
  gcc libjpeg libICE ncurses util-linux libSM libXfixes libXdamage libXext 
  libXi libXt libXmu libXxf86vm libdrm glew attr acl libusb udev mesa libtiff 
  djvulibre fftw gdk-pixbuf2 ilmbase jasper lcms atk libXcomposite libXcursor 
  libXinerama libXrandr openssl-solibs libXft pango gtk+2 python libxml2 
  librsvg libtool libwmf openexr imagemagick
I'll try it with --no-dep

User avatar
thenktor
Salix Wizard
Posts: 2426
Joined: 6. Jun 2009, 14:47
Location: Franconia
Contact:

Re: ImageMagick

Post by thenktor » 4. Dec 2012, 08:42

What happened to your "/var/log/packages" directory? Run ls -l /var/log/packages/ and ls -l /var/log/
Image
burnCDDA (burns audio CDs)
geBIERt (German beer blog)

djemos
Salix Warrior
Posts: 1064
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: ImageMagick

Post by djemos » 4. Dec 2012, 13:51

mimosa wrote:I had this with Slackel (installed for a friend). I updated slapt-getrc to point at 14.0 instead of current, and the Slackware part generated an error. Thought it was a mistake on my part, and I was going to check I had the links right.
Slackel will never have a 14.0 slackware repository but has a slackware current repository. So updating slapt-getrc to point to 14.0 will point to nothing.
Slackel follows slackware current and latest kde releases.

Post Reply