docutils 0.9.1-i486-1_SBo

General talk about packaging procedures and packages.
Post Reply
User avatar
sqlpython
Posts: 303
Joined: 13. Aug 2010, 04:53
Location: Ct. USA

docutils 0.9.1-i486-1_SBo

Post by sqlpython » 19. Feb 2013, 19:40

I had to add docutils when I installed SlackBuild for Spyder which requires Sphinx which in turn requires docutils for python.
Rather then use Gslapt I used SlackBuild to build docutil ...
Which of course is not the Salix repository version ..
Problem is this:
Seems Every day I have an Update of docutils and I am wondering if this is the same version Over and Over again.
I am considering uninstalling the SlackBuild version and replacing it with the Salix Repository version.
Should that make a Difference?
Should I even Bother?
Debian ( Stretch 9, Sid ) Salix OpenBox 14.1, Gentoo, Calculate

User avatar
laprjns
Salix Warrior
Posts: 1032
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: docutils 0.9.1-i486-1_SBo

Post by laprjns » 20. Feb 2013, 00:54

sqlpython wrote:I had to add docutils when I installed SlackBuild for Spyder which requires Sphinx which in turn requires docutils for python.
You could have installed spyder using sourcery or the command line equivalent slapt-src. They both use the slackbuild available from Slackbuild.org

Code: Select all

lapt-src --search spyder
spyder:2.1.10 - spyder (interactive Python IDE)
Sourcery and slapt-src even have limited dependancy resolution. So if you used slapt-src to build and install spyder you would have built and installed the dependancies:

Code: Select all

root[rich]# slapt-src --i spyder
The following packages will be installed:
 spyder 
The following dependent slackbuilds will be built and installed:
 pysetuptools Jinja2 Sphinx 
Do you want to continue? [y/N]
However you would still have the same update notification problem. Salix update notifier will still want to update docutils because the Gslapt (and slapt-get) only knows about it's package and will default to updating to it. Both Gslapt and slackbuild are using the same version of docutil, 0.9.1, so they are both the same package and shouldn't make a difference.
You've got two choices to get rid of the update notice, either blacklist docutils in Gslapt or upgrade it with the Gslapt version.

Code: Select all

root[rich]# slapt-get --search docutil
docutils-0.9.1-i486-1cp [inst=no]: docutils (Python Document Utilities module)
docutils-0.9.1-i486-1_SBo [inst=yes]: docutils (Python Document Utilities module)
root[rich]# 
root[rich]# 
root[rich]# slapt-get -install docutils
Reading Package Lists...Done
The following packages will be upgraded:
  docutils 
1 upgraded, 0 reinstalled, 0 newly installed, 0 to remove, 0 not upgraded.
Need to get 1.4MB of archives.
After unpacking 5.7MB of additional disk space will be used.
Do you want to continue? [y/N] 
I would go with installing the Gslapt version.

User avatar
sqlpython
Posts: 303
Joined: 13. Aug 2010, 04:53
Location: Ct. USA

Re: docutils 0.9.1-i486-1_SBo

Post by sqlpython » 20. Feb 2013, 05:10

Thanks Rich
@laprjns said
I would go with installing the Gslapt version.
@sqlpython said
I am considering uninstalling the SlackBuild version and replacing it with the Salix Repository version.
heh heh great minds think alike. Must be the Connecticut air. :lol:
Yes, Thanks for the input but I didn't really see any other way.
Anyway, I appreciate the short slapt-src tutorial as I really never go that route it is good to know that it is there.
You can see how I ended...
Bob

Code: Select all

root[sqlpython]# slapt-get --search docutil
docutils-0.9.1-i486-1cp [inst=yes]: docutils (Python Document Utilities module)
Debian ( Stretch 9, Sid ) Salix OpenBox 14.1, Gentoo, Calculate

Post Reply