NIS

General talk about packaging procedures and packages.
Post Reply
Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

NIS

Post by Nanook » 18. Jan 2019, 06:01

I am new to Salix. I am very familiar with Redhat and Debian based distributions which all share one of two package managers but Salix is a new thing. We operate Linux based shell servers as well as provide web hosting here at Eskimo North. I am trying to get a Salix shell server operational per a user request. In order to do this the server has to be an NIS client so all users on the network can login, needs to mount home directories and mail spools from other servers via NFS, and preferably should have some way of graphic remote access. For all our other machines we use x2go and I'd love to get an x2go server operational on Salix.

I've installed from 14.2.1 into a kvm/qemu virtual machine. So far it's been a horrendous battle. Virtio disk drivers didn't work, neither virtio network. Could not get a UEFI install to work. And even though the disk defaulted to GRUB which I'm using for all my other virtual machines, could not get it to work on Salix and had to go with lilo (ugh).

So now I've got a basic machine operational but making it an NIS client problematic. NIS not included with a full install so tried to find with the spi package manager using spi --search nis and spi --search ypbind, neither returned anything useful. Help!

galmei
Posts: 60
Joined: 1. Jun 2018, 21:54

Re: NIS

Post by galmei » 18. Jan 2019, 08:54

I can not help with the installation. But as far as x3go is concerned, I can tell, in the repository there are the two packages x2goclient (X2Go Remote Desktop solution - client part) and x2goserver (X2Go Remote Desktop solution).

There is also a package yptools (NIS servers and clients). Maybe it contains what you are looking for.

To troubleshoot UEFI, you should give more information so that others have something to think about.

Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

Re: NIS

Post by Nanook » 22. Jan 2019, 02:34

This is the problem I'm having with the package manager. It is running as root and networking and DNS are working properly.

Image

Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

Re: NIS

Post by Nanook » 22. Jan 2019, 02:34

Hmm, I included an image with the previous post but the BBCode did not work for some reason.
You can view it here: https://www.eskimo.com/~nanook/wp-conte ... /salix.png

Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

Re: NIS

Post by Nanook » 22. Jan 2019, 04:00

Someone gave me good repos to add and I got past this problem. Now trying to get x2goserver to work. Not cooperating.

galmei
Posts: 60
Joined: 1. Jun 2018, 21:54

Re: NIS

Post by galmei » 22. Jan 2019, 11:44

Nanook wrote:
22. Jan 2019, 02:34
This is the problem I'm having with the package manager. It is running as root and networking and DNS are working properly.
Do I understand you correctly, you run Gslapt as root? How and why?

Anyway, good that you've posted a screenshot. Sometimes pictures help more than a thousand words. From the screenshot I gather that the repository server salix.hostingxtreme.com is used. This is unsuitable for a long time. Please use

Code: Select all

sudo reposetup
and choose another server.

Code: Select all

man reposetup
gives more information, as well as reading the "Salix Startup Guide".

Post Reply