? about Qt version in SalixOS

General talk about packaging procedures and packages.
Post Reply
salix_user
Posts: 50
Joined: 23. Jan 2019, 13:15

? about Qt version in SalixOS

Post by salix_user » 15. Mar 2020, 10:10

Salix 14.2

Code: Select all

$ qmake -v
QMake version 2.01a
Using Qt version 4.8.7 in /usr/lib/qt/lib
$ 
Some programs I want to install require Qt 5.5+
Salix's repo has Qt 5.6.1
Should I uninstall 4.8.7 before installing 5.6.1 ?
How to install 5.6.1 ?

User avatar
laprjns
Salix Warrior
Posts: 1055
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: ? about Qt version in SalixOS

Post by laprjns » 15. Mar 2020, 11:47

They both can be installed at the same time. For 14.2, Qt4 should be installed as the default and uses "qmake' as the command to run it . To install qt5 do the following

Code: Select all

rich[~]$ sudo slapt-get --install qt5
To run qmake for Qt5 do

Code: Select all

rich[~]$ qmake-qt5 -v
QMake version 3.0
Using Qt version 5.6.1 in /usr/lib64
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
mimosa
Salix Warrior
Posts: 3150
Joined: 25. May 2010, 17:02
Contact:

Re: ? about Qt version in SalixOS

Post by mimosa » 15. Mar 2020, 11:53

I'm pretty sure qt5 can coexist with the stock version - I have both installed on my system. Anyway, if you run into trouble, time enough to think again. I recommend getting it from here (choose your Salix version and architecture, download the tarball, and install with spkg):
http://www.slackware.com/~alien/slackbuilds/qt5/

salix_user
Posts: 50
Joined: 23. Jan 2019, 13:15

Re: ? about Qt version in SalixOS

Post by salix_user » 15. Mar 2020, 16:01

Thank you, guys !

$ qmake-qt5 -v
QMake version 3.1
Using Qt version 5.9.6 in /usr/lib
$ qmake -v
QMake version 2.01a
Using Qt version 4.8.7 in /usr/lib/qt/lib
$

I have compiled vocoscreen. It requires qt5.

salix_user
Posts: 50
Joined: 23. Jan 2019, 13:15

Re: ? about Qt version in SalixOS

Post by salix_user » 20. Mar 2020, 20:13

Do these packages contain QtCreator ?
I see only

Image

How to install QtCreator on Salix 14.2 32-bit ?
------

One more question

I want to compile QtNote It requires qt5. This program can't choose qt5 automatically.
How do I change which version of Qt is used for qmake?

salix_user
Posts: 50
Joined: 23. Jan 2019, 13:15

Re: ? about Qt version in SalixOS

Post by salix_user » 20. Mar 2020, 21:33

salix_user wrote:
20. Mar 2020, 20:13
How to install QtCreator on Salix 14.2 32-bit ?
I see it in "Sourcery".

User avatar
mimosa
Salix Warrior
Posts: 3150
Joined: 25. May 2010, 17:02
Contact:

Re: ? about Qt version in SalixOS

Post by mimosa » 21. Mar 2020, 09:34

salix_user wrote:
20. Mar 2020, 20:13
How do I change which version of Qt is used for qmake?
laprjns wrote:
15. Mar 2020, 11:47
To run qmake for Qt5 do

Code: Select all

rich[~]$ qmake-qt5 -v
QMake version 3.0
Using Qt version 5.6.1 in /usr/lib64

salix_user
Posts: 50
Joined: 23. Jan 2019, 13:15

Re: ? about Qt version in SalixOS

Post by salix_user » 21. Mar 2020, 12:55

Thanks! It works.
But it should be

Code: Select all

qmake-qt5

Post Reply