[REPO] emesene-1.5 awesome

Old stuff that should not bother anyone anymore
Locked

User avatar
gapan
Salix Wizard
Posts: 5406
Joined: 6. Jun 2009, 17:40

Re: emesene-1.5 awesome

Post by gapan » 1. Sep 2009, 19:06

Correct flags are not used. This is a weird case, because there is nothing you can do in your build files. You need to edit a system file: /usr/lib/python2.6/config/Makefile and change the

Code: Select all

OPT=            -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes
line to

Code: Select all

OPT=            -DNDEBUG -g -fwrapv -O2 -march=i486 -mtune-i686 -Wall -Wstrict-prototypes
That way, every similarly weird app you build from then on, will be built with correct flags.

Also pygtk and pycairo should be added to the dep file too.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5406
Joined: 6. Jun 2009, 17:40

Re: emesene-1.5 awesome

Post by gapan » 1. Sep 2009, 20:04

Oh, also arch should be i486, not noarch!
Image
Image

User avatar
stillborn
Posts: 56
Joined: 30. Jul 2009, 10:06

Re: emesene-1.5 awesome

Post by stillborn » 2. Sep 2009, 06:19

gapan wrote:Correct flags are not used. This is a weird case, because there is nothing you can do in your build files. You need to edit a system file: /usr/lib/python2.6/config/Makefile and change the

Code: Select all

OPT=            -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes
line to

Code: Select all

OPT=            -DNDEBUG -g -fwrapv -O2 -march=i486 -mtune-i686 -Wall -Wstrict-prototypes
That way, every similarly weird app you build from then on, will be built with correct flags.

Also pygtk and pycairo should be added to the dep file too.
It won't build if I change the python config file.
FIN

User avatar
gapan
Salix Wizard
Posts: 5406
Joined: 6. Jun 2009, 17:40

Re: emesene-1.5 awesome

Post by gapan » 2. Sep 2009, 06:24

I see, leave it like this then.
Image
Image

User avatar
stillborn
Posts: 56
Joined: 30. Jul 2009, 10:06

Re: emesene-1.5 awesome

Post by stillborn » 2. Sep 2009, 09:27

Dep file fixed. :). Also very good information here in these threads ;)
FIN

User avatar
gapan
Salix Wizard
Posts: 5406
Joined: 6. Jun 2009, 17:40

Re: emesene-1.5 awesome

Post by gapan » 2. Sep 2009, 16:10

You forgot to include pygobject in the dep file (because I forgot to tell you about it). :D

Also, you didn't change the arch to i486.

And, it really is not a good idea to create the dep file inside the buildscript. Just remove that part altogether.
Image
Image

User avatar
stillborn
Posts: 56
Joined: 30. Jul 2009, 10:06

Re: [REPO] emesene-1.5 awesome

Post by stillborn » 5. Sep 2009, 19:31

Re-built with correct flags this time, first post edited.
FIN

User avatar
gapan
Salix Wizard
Posts: 5406
Joined: 6. Jun 2009, 17:40

Re: [REPO] emesene-1.5 awesome

Post by gapan » 5. Sep 2009, 20:36

Uploaded! :)
Image
Image


Locked