Playing with a spin-off

Other talk about Salix
User avatar
mimosa
Salix Warrior
Posts: 3101
Joined: 25. May 2010, 17:02
Contact:

Re: Playing with a spin-off

Post by mimosa » 12. Nov 2016, 11:33

Try installing wicd, or network maanger, and all their dependencies (though you might want to weed out the graphical ones I suppose). Both can be used from the CLI.

Or perhaps if you just look at the deps, you will see something that leaps out at you.

Sasquatch
Posts: 155
Joined: 26. Mar 2014, 00:50

Re: Playing with a spin-off

Post by Sasquatch » 12. Nov 2016, 11:41

The only thing missing is the drivers. Ifconfig, iwconfig, and wpa_supplicant all appear to be fully functional, they give me plenty of feedback when I issue commands. I suspect the problem is that my config file isn't fully developed. I just have the bit concerning the ssid and passkey. I can see the information on the wlan0 card I just can't get it to send and receive.

I ran this command;

Code: Select all

basename $( readlink /sys/class/net/eth0/device/driver )
and found out I have the ath9k driver on this laptop. This is the same laptop I had a fully functional Salix install on just a while ago but now wpa_supplicant is telling me this is not a supported driver. I get the same response from the firmware I installed from the iso.

I didn't know wicd could be run from the command line. I'll install it since I know it worked before. Thanks.

Post Reply