Page 1 of 1

configuring FTP server proFTPD - how2 {partially solved}

Posted: 8. Dec 2016, 20:02
by jpg153
Dear fellows,

after I installed VirtualBox I installed Win2K and then, with some hassle, eComstation 1.2R (OS/2 4.5 plus addons) in VB.
The problem with OS/2 in VirtualBox is, USB doesnot work reliable and a shared folder is not supported.
Loading into OS/2 is quite handy by creation of disk/CD images. But downloading files from OS/2 onto Salix is a pain
and sometimes impossible.
So I thought about FTP.
Connecting from Win2K or OS/2 (in VirtualBox) to FTP servers out in the Internet works.
So I setup proFTPD in Salix from the repo.

After several trials I was able to point gFTP (Salix) to the proFTPD server with anonymous/ftp login. Finally I managed to load files in both directions local<>server.

However, this doesnot work with Win2K nor with OS/2 in VirtualBox.

Is there any Salix'er out there familiar with proFTPD to tell me what I probably misconfigured and how to resolve that?

Thanks for any volunteer .

Update: I did some fiddling and now it seems to work. text-mode FTP clients still have problems but HandyFTP (OS/2) and the FTP-functionality in Mozilla (Win2K) are connecting without obvious issues. It is just the permissions on the files not being correct. Will hopefully find out...

Re: configuring FTP server proFTPD - how2 {partially solved}

Posted: 10. Dec 2016, 06:19
by westms
jpg153 wrote:Dear fellows,
jpg153 wrote:Update: I did some fiddling and now it seems to work. text-mode FTP clients still have problems but HandyFTP (OS/2) and the FTP-functionality in Mozilla (Win2K) are connecting without obvious issues. It is just the permissions on the files not being correct. Will hopefully find out...
Hello fellow,

if you want to know my opinion: the pure madness! You may be lucky to not have come up with the idea of ​​using an RS-232 crossover-cable to connect the two serial ports on the computer to communicate between two processes over it.

Joking apart.

The problem with the file permissions might be solved using the FTP command chmod mode file-name. It's not exactly what you're looking for, but it will do. Another solution to the file permissions might be to create a file that contains all the names of files to be transferred, including ownership and permissions. E.g. for Linux: ls -l >tx_linux_files.lst. Transfer this file together with the others and evaluate it on the recipient side. With the information thus obtained, fix the permission problems. This is then done on both sides of the transfer using scripts.

I had already prepared a comprehensive text with which one could begin to tackle the real problem. The first attempt would be to bypass the problem locally. The real problem has something to do with with crazy or cracked interprocess communication.

Attempts to redirect the discussion, my intended text should be:


can not say anything about proFTPD and maybe it is not necessary.

The description seems to me a further example of the well-known X-Y problem.

You have already described what the X problem is:
But downloading files from OS/2 to Salix is ​​a pain and sometimes impossible.
You could describe it in detail.

Then you still mean:
The problem with OS/2 in VirtualBox is, USB doesnot work and a shared folder is not supported.
Again, no detailed description. The problem is: You can not exchange files via the shared folder.

I assume, as a replacement, you tried to exchange files via a USB flash memory stick, but which also does not work. Your next attempt for a solution is to exchange files over the web via FTP. Am I right with my assumptions? That would be two Y-problems then.

Why not discuss here or in a more appropriate forum how files can be exchanged directly between Salix and the eComstation in a virtualbox?

First, you should check whether the virtualization, which is probably running on 64-bit Linux, is set correctly for the 32-bit software eComstation.

Then one should bear in mind that eComstation 1.2R is ten years old and it can simply be too old to integrate with modern operating systems.

Which filesystems does it support, and on which filesystem is the shared folder? Maybe 1.2R (already) can deal with EXT2, but certainly not with EXT4. Regarding the USB stick, 1.2R maybe knows VFAT, which is only an extension of the FAT by long filenames, but it does not know FAT32. Maybe you have problems with this. FAT32 is only available with eComstation 2.1.

One solution to the X problem might be to create another harddisk partition with a JFS filesystem on it and provide a shared folder. Linux supports JFS and for OS/2 it is the default filesystem. For testing, this solution could be tried first with a FAT16, EXT2 or JFS filesystem on a partition on a USB stick. The filesystem on the stick would be mounted under Linux and would then be part of the Linux filesystem. eComstation should be able to access the shared folder on it.

Btw.: Multiboot and virtualization is out of the question for me for a long time. I use at least one computer for each operating system and since I buy only used hardware, it does not cost more than a single current computer. These computers I gather at the LAN and can exchange files using GVFS, NFS, Samba and/or Mount. Most of these computers are seldom operated at the same time anyway.

Re: configuring FTP server proFTPD - how2 {partially solved}

Posted: 11. Dec 2016, 23:05
by jpg153

the solution to run different OSs on physically different PCs is nice bit sometime just not the right solution.
If I needed this in a professional working environment, I would probably go for something like that.

Anyway, regarding the functionality for OS/2-guests in VirtualBox, this is from the manual:
Guest Additions for OS/2. Shared folders are not yet supported with OS/2 guests. In ad-
dition, seamless windows and automatic guest resizing will probably never be implemented
due to inherent limitations of the OS/2 graphics system.
USB is said to be working, in principle, but is very much depending on the real chipset and functions and the
real devices. Some work, some not. As OS/2 does only support FAT16 or HPFS on USB devices, sharing is limited.
If I add FAT32 support (if available as such and for eCS1.2R) it would at least solve the issue of file sizes. Which is part of the pain...
There is a FAT32 support out there, maybe not the latest version...

The problem with OS/2 is probably not its age (Windows 95/98 is not supported in VirtualBox) but its architecture.
This is why I still like it. The workplace shell is probably the most powerful desktop out there, but so poorly designed
at some stage&corners...which makes it sometimes fragile....anyway, we discuss on this for hours. :geek:

Then, yes, shared folders are not available (s.a.) and USB is sometimes not working, so FTP was my next best solutions to come
around that problem. It is not "active". "Active" would be to setup Samba on Salix and install so called "Netdrive" on OS/2.
But for the few files I am going to share, this would be an overkill.

I prefer using Salix, no question, and in Salix I am using a 32bit chroot for Softmaker FreeOffice and dosbox for just one old pinball game :-)
Now VirtualBox with Win2K (as well probably just for one or two apps which do not run on any other platform) and now eComStation,
mainly for Clearlook (the fastest wordprocessor with a very special design/idea) and some other nice apps, and inside eComStation
I also have DOS and Windows 3.1 .
All this on one machine... so could use it simultaneously. :mrgreen:

But, its more for fun than a business need :D

Thanks so far.