[Resolu] Salix 13.1 & 13.37 é LILO

French Forum
Post Reply
micoud
Posts: 34
Joined: 13. Jan 2011, 19:19

[Resolu] Salix 13.1 & 13.37 é LILO

Post by micoud » 31. Oct 2011, 08:37

Bonjour,
Avec SalixOS 13.1, je suis confronté à un problème d'ouverture de session : je dois ressaisir mon identifiant et mon mot de passe plusieurs fois de suite, car rejeté avec un message (La connexion a duré moins de n secondes, bla bla bla (je n'ai que très rarement ce problème sur mon autre poste, lui aussi avec la 13.1.)

Bien, je décide d'installer la V13.37 sur le poste récalcitrant. Je dispose de 4 partitions système sur ce poste. J'installe donc la V13.37 sur une des partitions tout en conservant la partition où est chargée la V13.1. Tout baigne, plus besoin de ressaisir x fois mon identifiant et mon mot de passe.
Pendant l'install de la V13.37, je laisse installer LILO. Au reboot, je ne vois plus que 2 partitions (M$ et la V13.37). Je modifie le fichier lilo.cfg, et maintenant, je vois bien tous mes systèmes, mais je ne peux pas démarrer avec l'ancienne version de Salix. J'arrive bien sur l'écran de connexion, mais je ne peux rien saisir. Le clavier et aussi la souris sont totalement inopérants :(

Ci-dessous la partie du fichier lilo.cfg concernée

Code: Select all

# Windows bootable partition config begins
other = /dev/sda1
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda3
  label = Salix_OS_13.37
  read-only  
image = /boot/vmlinuz
  root = /dev/sda2
  label = Salix_Ancien
  read-only  
image = /boot/vmlinuz
  root = /dev/sda5
  label = Open_Suze
  read-only  
# Linux bootable partition config ends
Merci pour vos éclaircissements.
Last edited by micoud on 2. Nov 2011, 06:40, edited 1 time in total.

User avatar
JRD
Salix Warrior
Posts: 949
Joined: 7. Jun 2009, 22:52
Location: Lyon, France

Re: Salix 13.1 & 13.37 é LILO

Post by JRD » 31. Oct 2011, 10:57

Ah je sais ! :)
En fait lilo fait tout "en avance". Quand tu arrives sur l'écran de lilo, il ne sait rien des partitions sous-jacentes. Il fonctionne en mode block et connait les blocks du disque où aller chercher les données.
Tout ça pour dire que quand tu mets /boot/vmlinuz, c'est l'adresse réelle, au moment où tu fais "lilo -v" qui est utilisée. Autrement dit, tu boots ta Salix 13.1 avec le kernel de la 13.37, idem pour ta Suze.
Deux solutions soffrent à toi :
  • Tu utilises l'outil "lilosetup" d'Akuna qui devrait te permettre de tout détecter et de te faire ça aux petits oignons.
  • Tu montes tes partitions avant (soit à la main, soit avec l'excellent outil "gmountman" de Gapan), et tu références dans lilo.conf les adresse dans les partitions montées, puis tu refais "lilo -v". Après cela tu peux démonter tes partoches.
C'est un peu ce qui est chiant avec Lilo. Mais bon, c'est un chargeur de démarrage simple et qui fonctionne bien.
Image

micoud
Posts: 34
Joined: 13. Jan 2011, 19:19

Re: Salix 13.1 & 13.37 é LILO

Post by micoud » 31. Oct 2011, 19:40

Ah, ça c'est une réponse précise et efficace. J'allais justement annoncer que j'avais exactement le même problème avec Open Suze !
Quant au lilosetup, il me plantait mon PC. J'ai fais toutes les mises à jour dispo pour ma Salix, et maintenant le lilosetup fonctionne. Est-ce celui d'Akuna ?
J'ai donc fait les modifs et sauvegardé le tout à la place de l'ancien, puis tapé la cde "lilo" en mode console. J'ai eu droit à ce message d'erreur

Code: Select all

root[~]# lilo
Warning: LBA32 addressing assumed
Added Windows *
Fatal: open /boot/vmlinuz-huge-smp-2.6.33.4-smp: No such file or directory 
Je n'ai pas cliqué sur le bouton "Installer le gestionnaire Lilo". Devrais-je le faire ?
Au reboot, rien n'est changé : Salix 11.37 & M$ fonctionnent, mais pas Salix 11.1 ni Opensuse.
Ci-dessous mon lilo.conf après modifs

Code: Select all

# Début de configuration de la partition démarrable Windows
other = /dev/sda1
label = Windows
# Fin de configuration de la partition démarrable Windows
#
# Début de configuration de la partition démarrable Linux
image = /boot/vmlinuz-huge-smp-2.6.33.4-smp
root = /dev/disk/by-uuid/fdd41cb1-cc74-4500-afab-c83ef0e2578c
label = Salix_Ancien
read-only
# Fin de configuration de la partition démarrable Linux
#
# Début de configuration de la partition démarrable Linux
image = /tmp/lilosetup/mnt/sda3/boot/vmlinuz-huge-smp-2.6.37.6-smp
root = /dev/disk/by-uuid/a6c78622-98bc-4edd-9e01-152f6b6b051e
label = Salix_OS_1137
read-only
# Fin de configuration de la partition démarrable Linux
#
# Début de configuration de la partition démarrable Linux
image = /tmp/lilosetup/mnt/sda5/boot/vmlinuz-2.6.37.1-1.2-default
root = /dev/disk/by-uuid/8eba36e0-4631-47a2-9d57-4c3e29faa5f8
label = Open_Suze
initrd = /tmp/lilosetup/mnt/sda5/boot/initrd-2.6.37.1-1.2-default
read-only
# Fin de configuration de la partition démarrable Linux

User avatar
mimosa
Salix Warrior
Posts: 3101
Joined: 25. May 2010, 17:02
Contact:

Re: Salix 13.1 & 13.37 é LILO

Post by mimosa » 31. Oct 2011, 20:59

Oui il faut "installer le gestionnaire Lilo". Sinon, ça sera la même chose qu'auparavant - le même lilo.conf ancien.

D'ailleurs, en utilisant l'outil lilosetup, ce n'est pas normalement nécessaire de faire les modifications principales de lilo.conf manuellement. Justement l'erreur humaine pourrait facilement entrer en jeu. Seulement au cas de ne pas fonctionner "automatiquement" qu'il vaudrait la peine d'interférir. Je crois que dans mon cas, ça n'a jamais été nécessaire.

micoud
Posts: 34
Joined: 13. Jan 2011, 19:19

Re: Salix 13.1 & 13.37 é LILO

Post by micoud » 1. Nov 2011, 11:18

Dans le menu "système", il y a une option "Lilo Setup". Quelle différence avec le "gestionnaire Lilo" ?
Je suis un peu largué :(
Jusqu'ici, j'ai toujours utilié GRUB et je commençais à bien m'en sortir avec. Je me demande si je ne vais pas revenir à Grub ?

User avatar
mimosa
Salix Warrior
Posts: 3101
Joined: 25. May 2010, 17:02
Contact:

Re: Salix 13.1 & 13.37 é LILO

Post by mimosa » 1. Nov 2011, 11:45

J'avais peut-être pas bien entendu; mon système n'utilise pas le français! LiloSetup ouvre l'outil d'Akuna, qui doit détecter toutes les partitions exactement comme il faut. Puis tu choisis les noms qui vont aparaître dans le menu de lilo. Mais il faut après cliquer sur le bouton à droite au bout de la fenêtre, en anglais c'est, "Install Lilo Bootloader".

Cette dernière étape doit être équivalente à

Code: Select all

#lilo
mais je ne sais pas si le nouveau lilo.conf déjà sera sauvé par lilosetup. Mieux faire simplement avec un clic.

micoud
Posts: 34
Joined: 13. Jan 2011, 19:19

Re: Salix 13.1 & 13.37 é LILO

Post by micoud » 2. Nov 2011, 06:40

Bon, j'ai résolu le problème : J'ai installé dans une de mes partitions une debian, et je l'ai laissé installer GRUB. Maintenant, tout est OK.
Merci pour vos contributions.

Post Reply