Wieder Probleme mit GMX

German Forum
Post Reply
User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Wieder Probleme mit GMX

Post by jpg153 » 30. Oct 2014, 09:51

Hallo,


seit etwa 2 Tagen habe ich wieder Probleme mit dem Mailabruf auf GMX. Über POP3 kommt keine SSL-Verbindung zustande.
Online Web-Login ist ok und via Smartphone kommen die Mails rein. Nur auf dem PC nicht...

Ich habe seit der letzten Fehlerbeseitigung (siehe anderes Thema) keine Änderungen am Mailer vorgenommen.
WEB.de funktioniert weiter problemlos.

Irgendeine Idee?

Danke.
Regards Gruß
jpg

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Re: Wieder Probleme mit GMX

Post by westms » 30. Oct 2014, 20:50

jpg153 wrote:Hallo,

seit etwa 2 Tagen habe ich wieder Probleme mit dem Mailabruf auf GMX. Über POP3 kommt keine SSL-Verbindung zustande.
Online Web-Login ist ok und via Smartphone kommen die Mails rein. Nur auf dem PC nicht...

Ich habe seit der letzten Fehlerbeseitigung (siehe anderes Thema) keine Änderungen am Mailer vorgenommen.
WEB.de funktioniert weiter problemlos.

Irgendeine Idee?

Danke.
Hallo,
das Verhalten kann ich bestätigen. Empfang über POP3 des GMX-Servers pop.gmx.net Port 995 ist seit Mittwoch morgen nicht mehr möglich. Senden über SMTP funktioniert aber und einloggen am Web-Interface geht auch. Empfang über die Server pop3.alice-dsl.net und pop.mail.yahoo.com funktioniert weiterhin.

Auf den Hilfeseiten des GMX-Auftritts https://kontakt.gmx.net/index.html kann man folgenden Text lesen:
Fehler beim Login durch Abschaltung von SSL 3.0

Sie können sich nicht einloggen, sondern erhalten eine Fehlermeldung?

Zum Schutz vor der kürzlich entdeckten Sicherheitslücke "POODLE" stellt GMX schrittweise die Unterstützung des veralteten Verschlüsselungsprotokoll SSL 3.0 ein. Einige ältere Browserversionen setzen dieses Protokoll ein und funktionieren daher nicht mehr. Bitte nutzen Sie einen aktuellen Browser.

Mehr zu diesem Thema erfahren Sie auf der Seite GMX informiert zu POODLE in SSL-Version 3.0.
Könnte das ein Problem sein? Der Text bezieht sich zwar auf Web-Browser, aber vielleicht sind irgendwelche Ahnungslose zu weit gegangen und haben gleich richtigen Schaden angerichtet.

In der Newsgroup de.comm.provider.mail ist ein Beitrag erschienen (21. Oktober), in dem angegeben wird, dass auch pop3.arcor.de Port 995 nicht mehr mit TLS/SSL funktioniert. Die Diskussion ist bis jetzt ohne Ergebniss geblieben.

Claws liegt beim Hersteller nun in der Version 3.11.1 vor. Für die Version 3.11.0 wurden Änderungen zur SSLv3-Problematik vorgenommen. Könnte vielleicht ein Claws-Update für Salix helfen?

Nachtrag:

In der Zwischenzeit habe ich auf einem meiner beiden Rechner mit gleicher Salix64-14.1-Installation, Claws-Mail Version 3.11.1 erstellt (build) und dann installiert. Das geschilderte Problem existiert auf dieser Installation nicht mehr. Auf dem anderen Rechner mit altem Claws existiert es weiterhin. Wahrscheinlich ist Claws 3.9.2 veraltet.

User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Re: Wieder Probleme mit GMX

Post by jpg153 » 30. Oct 2014, 23:14

N'Abend.

Schön zu sehen dass ich nicht alleine bin.

wir können ja mal bei Gapan nachfragen, ob er ein Update für Clawsmail vorzieht...

Soll ich?
Regards Gruß
jpg

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Re: Wieder Probleme mit GMX

Post by westms » 31. Oct 2014, 00:50

jpg153 wrote:N'Abend.

Schön zu sehen dass ich nicht alleine bin.

wir können ja mal bei Gapan nachfragen, ob er ein Update für Clawsmail vorzieht...
Hi!
Soll ich?
Warum nicht. Selber bin gerade zu faul, dass auf Englisch zu formulieren. ;)

Interessant auch, welche Version Claws-Mail in der kommenden SalixLive Xfce enthalten sein wird. Wenn es sich um 3.11.1 handeln sollte, dann gehört die auch in die Salix Xfce, meiner Ansicht nach, denn sonst laufen die ja auseinander.

Es handelt sich aber nicht um ein reines Claws-Mail-Problem. Einige andere Mail-Programme scheinen auch betroffen zu sein. Wahrscheinlich ist eine verbreitete unterliegende Lib im Widerspruch zu dem, was sich GMX-Mail- und Arcor-Mail-Administratoren denken. Bei Yahoo und O2/Alice hatte ich das Problem nicht. Mit dem Build der Version 3.11.1 wurden auch Libs (oder wenigstens eine) neu erstellt. Die restliche Salix-Distribution funktioniert bis jetzt auch nach dem Update ohne Schwierigkeiten, so dass das Update vielleicht keine negativen Folgen hat.

User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Re: Wieder Probleme mit GMX

Post by jpg153 » 1. Nov 2014, 19:51

Bis jetzt gab es ja nicht gerade viel Reaktionen auf meine Meldung....

Vielleicht muss ich mir auch eine aktuelle Version bauen...
Regards Gruß
jpg

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Claws-Mail und GMX über POP3 (was: Wieder Probleme mit GMX)

Post by westms » 2. Nov 2014, 00:53

jpg153 wrote:Bis jetzt gab es ja nicht gerade viel Reaktionen auf meine Meldung....

Vielleicht muss ich mir auch eine aktuelle Version bauen...
Hallo,

kann mir gar nicht vorstellen, dass wir beide die Einzigen sein sollen, die Claws Mail und GMX in Kombination nutzen. Vielleicht sind alle Anderen Opfer der Halloween-Streiche geworden.

Eine Anleitung zum Build und zur Installation von Claws-Mail Version 3.11.1 will ich hier nicht geben. Erstens, weil ich wahrscheinlich nicht alle Belange für ein richtig ausgeführtes Build beachtet habe. Zweitens möchte ich nicht, dass mir hier für eine fehlerhafte Anleitung oder deren Folgen mein Kopf 'runter gemacht wird.


Alles Gute
Last edited by westms on 18. Jan 2016, 15:32, edited 1 time in total.

User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Re: Wieder Probleme mit GMX

Post by jpg153 » 2. Nov 2014, 20:32

Hallo,

Danke für die Anleitung.

Ich habe aber eine einfachere Lösung - zumindest für GMX: Port 110 und STARTTLS !

fluppt!

Mein Smartphone lief nämlich mit diesen Einstellungen und WEB.de läuft auch mit STARTTLS...
Regards Gruß
jpg

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Re: Wieder Probleme mit GMX

Post by westms » 3. Nov 2014, 16:02

jpg153 wrote:quote]Ich habe aber eine einfachere Lösung - zumindest für GMX: Port 110 und STARTTLS !

Mein Smartphone lief nämlich mit diesen Einstellungen und WEB.de läuft auch mit STARTTLS...
Hallo,

interessante Möglichkeit.

STARTTLS mit POP3 hatte ich auch probiert, aber den Port nicht geändert. Welcher Port hierbei verwendet werden kann, wusste ich nicht. An den Standardport hatte ich gedacht.

Man kann STARTTLS mit POP3 über Port 110 verwenden, habe ich später nachgelesen. Dabei kann aber während der Aushandlung, für den Nutzer unbemerkt, die Verschlüsselung verloren gehen.

Läßt sich heraus finden, ob in dieser Kombination die Verschlüsselung mit GMX ausgehandelt und verwendet wird? Vielleicht auch auf dem Smartphone? Ich kann mir vorstellen, dass ohne Verschlüsselung gearbeitet wird, um Übertragungsvolumen und Rechenleistung auf Mobiltelefonen zu sparen.

Wird SSL/TLS mit POP3 über Port 995 verwendet, dann kommt tatsächlich POP3S zum Einsatz.

Letztendlich hatten mich die Release-Notes zur Version 3.11.0/.1 http://www.claws-mail.org/news.php bewogen, es mit der neusten Claws-Version zu versuchen. Die relevaten Auszüge sind:

* Use 'gnutls_priority' hidden account preference for POP3 and
STARTTLS connections, in addition to SMTP.
[...]

* SSLv3 server connections are now disabled by default, in response
to the POODLE vulnerability, see
https://cve.mitre.org/cgi-bin/cvename.c ... -2014-3566.
[...]

* Bug fixes:
[...]
o bug 3300, 'Cannot send/receive mail when SSL 3.0 is not
supported on the server'
[...]
o Disable SSL3.0 entirely as a Poodle fix.
[...]
o fix building without gnuTLS support
o Don't differentiate the protocols used when using direct
SSL/TLS versus STARTTLS

Vielleicht läßt sich erreichen, dass Claws-Mail 3.11.1 für die aktuelle Slackware-Version nachgezogen wird. Dann würde das neue Claws auch in Salix auftauchen, nehme ich an. Wie erreicht man und wie reagiert Patrick Volkerding auf eine solche Bitte?

User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Re: Wieder Probleme mit GMX

Post by jpg153 » 4. Nov 2014, 21:11

Ob bei STARTTLS und der erforderlichen Aushandlung die Verschlüsselung verloren geht, kann ich nicht beurteilen.

Das man wegen der Smartphones und den schlankeren Daten die Verschlüsselung fallen läßt, klingt nicht logisch.
Das Mehr-an-Daten bei TLS/SSL dürfte kaum ins Gewicht fallen, zumal die meisten Smartphones mit Flatrate unterwegs sind.

Es macht in meinen Augen auch keinen Sinn erst die Verschlüsselung zu fordern (so wie bei GMX) und dann bei der
Aushandlung via STARTTLS die Verschlüsselung einfach fallen zu lassen.

Bei WEB.de war das von Anfang an (also als die auf Verschlüsselung umgestellt haben) mit STARTTLS auf Port110.

Die Daten meines Smartphones habe ich auch nicht selber eingestellt, sondern das lief über die GMX-app wenn ich mich recht entsinne.

Bedenken wir, dass wir vor etwa einem Jahr bei GMX und WEB die Daten ohne jede Verschlüsselung abgerufen haben!
Da sind wir heute eher besser als schlechter...

Ich gehe davon aus, da? Clawsmail demnächst nachgezogen wird.

Sicher kann man Patrick Volkerding anmailen. Ich fürchte aber, dass er da nicht mitzieht und auf die nächste Version verweisen wird.
Es ist ja auch fraglich, ob Clawsmail zum Slackware-Standard gehört. Volkerding pflegt doch nur das nackte System und den Kernel...oder?

Slackware kommt ja klassisch ohne grafische Oberfläche und Salix ist Slackware mit grafischen Oberflächen (mittlerweile nicht nur XFCE).
Gapan (und andere - also das Salix-Team) entscheiden im wesentlichen darüber.
Regards Gruß
jpg

User avatar
jpg153
Posts: 394
Joined: 23. Oct 2009, 15:43
Location: Essen/NRW/BRD/EU

Re: Wieder Probleme mit GMX

Post by jpg153 » 5. Nov 2014, 14:11

Nachtrag:

Die Nichtverschlüsselung beim Aushandlen kann nur auftreten, wenn eine Seite die Protokolle nicht fährt.
Das trifft aber nicht zu.

Die Server von GMX und WEB unterstützen alle TLS-Versionen. Arcor und andere haben da andere Probleme....

https://starttls.info/
Regards Gruß
jpg

Post Reply