Existing Unicode (UTF-8) letters are displayed as ? ????

Post Reply
User avatar
zAchAry
Posts: 804
Joined: 11. May 2010, 09:02
Location: Israel

Existing Unicode (UTF-8) letters are displayed as ? ????

Post by zAchAry » 3. Sep 2010, 10:13

Keywords: French, France, Germany, German, Hebrew, Hebraic, Unicode, utf8 (anymore languages?)


Table Of Contents
1) Problem
2) Solution



1) Problem
I can write Hebraic letters when naming files and folders, but other files and folders
in Hebrew, that were created before I've installed SalixOS, are displayed with ? ????

P/S: All the files and folders in question were merely created, named
and renamed on Ubuntu 8.10, and are stored inside a USB Drive.


2) Solution
Strangely enough I've just solved this problem after seeing
that Gigolo issue post and I've figured "why not checking out the problem..."
and "why not trying to mount the USB Drive in question with Gigolo?",
so I did:

...and Voila! WORKS!!!
  • a. Salix > System > Gigolo.
    b. Select the USB Drive.
    c. Connect.
    d. Browse the (mounted) USB Drive with Thunar File-Manager.
    e. Hebrew letters are displayed correctly.


Need to submit a bug concerning Thunar :roll:
http://thunar.xfce.org/index.html



Debugging...
damNageHack wrote:(06:54:36 PM) damNageHack: insert your stick and try to access it with thunar (broken signs then). open a terminal, type "mount" and pastebin the output
(06:54:47 PM) damNageHack: remove your stick (unmount before)
(06:55:16 PM) damNageHack: insert the stick again and try to access with gigolo (right signs then). open a terminal, type "mount" and pastebin the output
(06:55:28 PM) damNageHack: then you will see the difference, i hope so
(06:57:19 PM) damNageHack: and it is no bug of thunar
(06:57:32 PM) damNageHack: because thunar works if the mount is right
Thunar http://salix.pastebin.com/P3R1LS8d

Code: Select all

etf[~]$ mount
/dev/root on / type ext4 (rw,noatime,barrier=1,data=ordered)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,devgid=10,devmode=0664)
/dev/sda3 on /home type ext4 (rw,noatime)
tmpfs on /dev/shm type tmpfs (rw)
gvfs-fuse-daemon on /home/etf/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=etf)
/dev/sdb1 on /media/USB DISK2.0 type vfat (rw,nosuid,nodev,uhelper=hal,uid=1000,shortname=winnt)
Gigolo http://salix.pastebin.com/ufahAWbR

Code: Select all

etf[~]$ mount
/dev/root on / type ext4 (rw,noatime,barrier=1,data=ordered)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,devgid=10,devmode=0664)
/dev/sda3 on /home type ext4 (rw,noatime)
tmpfs on /dev/shm type tmpfs (rw)
gvfs-fuse-daemon on /home/etf/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=etf)
/dev/sdb1 on /media/USB DISK2.0 type vfat (rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=1000,utf8)
damNageHack wrote:(07:28:57 PM) damNageHack: ah, do you see the difference of the last lines?
(07:29:04 PM) damNageHack: about /dev/sdb1
Last edited by zAchAry on 28. Sep 2010, 08:20, edited 1 time in total.
Image
Help to make Slackware easier Donate to Salix

User avatar
damNageHack
Posts: 663
Joined: 24. Sep 2009, 17:07

Re: Existing Unicode (UTF-8) letters are displayed as ? ????

Post by damNageHack » 3. Sep 2010, 17:13

Hmm, it seems to be somehow a bug ...
edit /etc/xdg/xfce4/mount.rc
find the "[vfat]" section
append "utf8=true"
https://bbs.archlinux.org/viewtopic.php?id=97224

There is no such file /etc/xdg/xfce4/mount.rc in my Salix VBox. :roll:

Gapan should be able to fix that issue in the xfce package. I am using xfce-4.6.1-i486-3gv.

Maybe try that content for the file (from Fedora 13).

Code: Select all

#
# ABOUT
# =====
# This file contains the mount option configuration when exo-mount is used with the HAL
# back end (which is highly recommended). If mounting using exo is somehow not working
# for you, you can copy this file to your $XDG_CONFIG_HOME/xfce4 directory and modify it.
#
# The options for each filesystem are not used when they are not in the list of
# valid mount options provided by HAL. You can find those values using lshal and
# search for the volume.mount.valid_options property.
#
#
# EXAMPLE
# =======
# For example your usb device contains the vfat file system and lshal shows the
# following valid mount options for the device:
#
#   volume.mount.valid_options = {'ro', 'sync', 'dirsync', 'noatime', 'nodiratime',
#                                 'noexec', 'quiet', 'remount', 'exec', 'uid=',
#                                 'gid=', 'umask=', 'utf8'} (string list)
#
# All the values that end with a = character are options that contain a value,
# the other options are booleans that can be enabled by for example putting
# utf8=true in the group.
#
#
# SUBSTITUTIONS
# =============
# Some options can be substituted by exo-mount when you set the value to <auto>:
#   uid      : The real user ID
#   gid      : The real group ID
#   iocharset: To the EXO_MOUNT_IOCHARSET or LC_CTYPE environment variable.
#

[vfat]
uid=<auto>
utf8=true
shortname=winnt
# FreeBSD specific option
longnames=true

[iso9660]
uid=<auto>
utf8=true

[udf]
uid=<auto>
iocharset=<auto>

[ntfs]
uid=<auto>
utf8=true

[ntfs-3g]
uid=<auto>
# Make sure the device does not get 0777 permissions
umask=0077
Image
This is the oppinion of the author, it does not force you to share and is signed automatically.
You are free to keep them all errors for your own. Linux is the best game I ever played.

User avatar
zAchAry
Posts: 804
Joined: 11. May 2010, 09:02
Location: Israel

Re: Existing Unicode (UTF-8) letters are displayed as ? ????

Post by zAchAry » 3. Sep 2010, 17:47

Code: Select all

# install -m 0644 /home/etf/mount.rc /etc/xdg/xfce4/
http://www.salixos.org/forum/viewtopic.php?p=7798#p7798

...Mounting with Thunar...
WORKS!!!!
Image
Help to make Slackware easier Donate to Salix

User avatar
damNageHack
Posts: 663
Joined: 24. Sep 2009, 17:07

Re: Existing Unicode (UTF-8) letters are displayed as ? ????

Post by damNageHack » 3. Sep 2010, 18:16

I did another test:
If you create the file with Salix itself, it works also without the utf8 option.
It does not work if you created a file with utf8 option and try to see it without utf8
Image
This is the oppinion of the author, it does not force you to share and is signed automatically.
You are free to keep them all errors for your own. Linux is the best game I ever played.

User avatar
JRD
Salix Warrior
Posts: 949
Joined: 7. Jun 2009, 22:52
Location: Lyon, France

Re: Existing Unicode (UTF-8) letters are displayed as ? ????

Post by JRD » 30. Nov 2011, 22:05

On my gf computer, installed recently using Salix Live beta2 13.37, the file /etc/xdg/xfce4/mount.rc contains "utf8" for vfat instead of "utf8=true" which leads to the utf8 option being not applied when mounting the fat usb key.
How is this possible ? On my computer, the contains of this file is ok. Maybe I edited it at some point, but I'm sure I didn't edit that file, neither my girlfriend on her PC. Still a bug in the last xfce package ?
Image

Shador
Posts: 1295
Joined: 11. Jun 2009, 14:04
Location: Bavaria

Re: Existing Unicode (UTF-8) letters are displayed as ? ????

Post by Shador » 30. Nov 2011, 23:18

The original mount.rc from the xfce package in 13.37 x86_64 (xfce 4.6.2-x86_64-5) doesn't contain any references to utf8. To make matters worse mount.rc is not even .new. So if you edit that file for correct utf8 support, you loose all changes on upgrade and reinstall.
Image

Post Reply