Networking

Post Reply
jagdpup
Posts: 1
Joined: 11. Oct 2012, 21:47

Networking

Post by jagdpup » 11. Oct 2012, 21:56

So I created a live USB stick (with persistence) and it worked great! I ran it on my lenovo idea pad. Perfect.
But, then I used the same stick on my Toshiba netbook. It worked perfectly there too.

I then returned to use the stick on my idea pad. It will not network! In wicd, no wireless networks are recognized. And, I cannot even connect with a wired connection! Hardware is confirmed functional (as I type).

The stick still works great on the netbook.

Where do I start to debug this?

User avatar
JRD
Salix Warrior
Posts: 949
Joined: 7. Jun 2009, 22:52
Location: Lyon, France

Re: Networking

Post by JRD » 8. Nov 2012, 09:31

Hummm, could be that you have a device number shift for your connection. It happens also on regular installation, depending on the network driver and the order the bios list devices (which can change from one boot time to another).
Check with a root terminal, using ifconfig -a, that you have for example a eth1 or wlan1 interface instead of eth0 or wlan0. If it is, you just have to open wicd preferences and fill the correct device name for the connection.

I know that there is a udev rule trick to fix the connection name to wlan0 or eth0 despite the order the kernel/driver detects and name it.
Hope my guess is right…
Image

User avatar
gapan
Salix Wizard
Posts: 5396
Joined: 6. Jun 2009, 17:40

Re: Networking

Post by gapan » 8. Nov 2012, 12:47

jagdpup wrote:Where do I start to debug this?
Start by finding out what network card you have.
Image
Image

Post Reply