i'm back here

If you have any suggestions or ideas about improving Salix, here's the place to post them.
djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: i'm back here

Post by djemos » 12. Nov 2022, 13:03

dependencies for slackware current.
first type
sudo slapt-get -u
I installed the packages (sudo slapt-get -i fcitx5 fcitx5-gtk etc) which pull dependencies. Or fcitx5-anthy. But i could not type Japanese. I do not know what else is needed.
Also is possible to use ibus, ibus-anthy or ibus-kkc to type Japanese instead of fcitx5 ?

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: i'm back here

Post by djemos » 12. Nov 2022, 13:48

I managed to type Japanese on slackel.
sudo slapt-get -u
sudo slapt-get -i ibus ibus-anthy
edit the ~/.bashrc
and add there the lines

Code: Select all

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon -d -x
run ibus-setup
default keyboard shortcut to change keyboard is <Super>space (super is the windows key)
On "Input method" click on "Add" and "Japanese" and select "Japanese (Kana)"
Click on "Add"
click on "Advanced" and select "Share the same input method among all applications"
then click on "close"
log out and log in
press <super>space to change to Japanese (kana) Or can do the same with the mouse on panel.
and here are the Japanese characters
タタテスタテスイスイススイイススイノリシセラニナンサソヒツミモネルメムタテスイカ
I can type Greek (ασαξκασηιοόάΑΆκ), English (sahgahgasfaff) and Japanese characters ( タタイスカン )

Edit: I removed ibus-anthy. Only ibus is installed. Still can type Japanese characters.

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: i'm back here

Post by djemos » 12. Nov 2022, 19:46

Install fcitx5 on slackware current (slackel)

Code: Select all

sudo slapt-get -u
sudo slapt-get -i fcitx5 fcitx5-anthy fcitx5-qt fcitx5-configtool fcitx5-gtk kitemviews kwidgetsaddons 
edit the ~/.bashrc
and add there the lines

Code: Select all

export GTK_IM_MODULE=fcitx5
export QT_IM_MODULE=fcitx5
export XMODIFIERS=@im=fcitx5
fcitx5 -rd
run fcitx5-config-qt or fcitx5-configtool
log out and login
Some Japanese characters using anthy and Multi segment
他手他期茎間津さ素未桃砒素曽木勘

User avatar
balloon
Posts: 34
Joined: 31. Oct 2016, 09:44
Location: Japan
Contact:

Re: i'm back here

Post by balloon » 14. Nov 2022, 02:02

oh thanks for the info. It is useful for Japanese users. :D I'll try it again with Slackel too.
The fcitx5 dependency is not set yet. It messed up the required packages.
IBus 1.5 is useful if you use multiple languages, but it is inconvenient for Japanese. That's why Fcitx was favored.
🎈 BALLOON | FU-SEN 🗾 from Japan
🌐 English: https://balloon-en.vercel.app/ 🗾 日本語: https://balloon-jp.vercel.app/
🐙 GitHub: https://github.com/fu-sen

User avatar
balloon
Posts: 34
Joined: 31. Oct 2016, 09:44
Location: Japan
Contact:

Re: i'm back here

Post by balloon » 14. Nov 2022, 04:23

djemos wrote:
12. Nov 2022, 19:46
Install fcitx5 on slackware current (slackel)

Code: Select all

sudo slapt-get -u
sudo slapt-get -i fcitx5 fcitx5-anthy fcitx5-qt fcitx5-configtool fcitx5-gtk kitemviews kwidgetsaddons 
edit the ~/.bashrc
and add there the lines

Code: Select all

export GTK_IM_MODULE=fcitx5
export QT_IM_MODULE=fcitx5
export XMODIFIERS=@im=fcitx5
fcitx5 -rd
run fcitx5-config-qt or fcitx5-configtool
log out and login
Some Japanese characters using anthy and Multi segment
他手他期茎間津さ素未桃砒素曽木勘
I did the above after installing Slackel 7.5 Openbox. But fcitx5 is not started. I tried manual start of fcitx5.

Code: Select all

bash-5.1$ fcitx5
fcitx5: /lib64/libs.so.6: version `GLIB_2.34` not found (required by fcitx5)
fcitx5: /lib64/libc.so.6: version `GLIB_2.34` not found (required by /usr/lib64/libFcitx5Utils.so.2)
What package would this be missing?
sudo slapt-get -u
sudo slapt-get -i ibus ibus-anthy
Same with this. Dependent packages are important and will not work with this command.
🎈 BALLOON | FU-SEN 🗾 from Japan
🌐 English: https://balloon-en.vercel.app/ 🗾 日本語: https://balloon-jp.vercel.app/
🐙 GitHub: https://github.com/fu-sen

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: i'm back here

Post by djemos » 14. Nov 2022, 05:57

@ballon.
Slackel is a "semi rolling" release. You cannot do this without installing the iso and upgrade to latest slackware current. Slackel iso is old and since when it is released a lot of changes including glibc (is now glibc 2.36) happened. I use slackel as my main os for everyday use and i upgrade the system.

User avatar
balloon
Posts: 34
Joined: 31. Oct 2016, 09:44
Location: Japan
Contact:

Re: i'm back here

Post by balloon » 19. Nov 2022, 04:41

Yeah, I know that, but rebooting after running "slapt-get --upgrade" loses the desktop boot. :|

I probably need the steps described here, but I don't have the time to do it right now.

http://www.slackel.gr/forum/viewtopic.php?f=7&t=507
🎈 BALLOON | FU-SEN 🗾 from Japan
🌐 English: https://balloon-en.vercel.app/ 🗾 日本語: https://balloon-jp.vercel.app/
🐙 GitHub: https://github.com/fu-sen

djemos
Salix Warrior
Posts: 1311
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: i'm back here

Post by djemos » 19. Nov 2022, 07:45

install libxcvt package to boot on X. It is a new package.
sudo slapt-get -i libxcvt

User avatar
balloon
Posts: 34
Joined: 31. Oct 2016, 09:44
Location: Japan
Contact:

Re: i'm back here

Post by balloon » 20. Nov 2022, 09:45

Alas, I had bad timing. Because "slapt-get" download is failing. I will try slackel again later.
🎈 BALLOON | FU-SEN 🗾 from Japan
🌐 English: https://balloon-en.vercel.app/ 🗾 日本語: https://balloon-jp.vercel.app/
🐙 GitHub: https://github.com/fu-sen

Post Reply