Page 1 of 1


Posted: 26. Sep 2016, 11:09
by coyotl
Could this be included in the iso?

Networkmanager/nm-applet/modemmanager do not solve everything, in fact it has gotten some new bugs..
My experience is with Debian/ubuntu but I get the same when trying Manjaro etc.

My Huawei 4G modem, which has worked without problems for years does not work at all after
Debian 7 and (X)ubuntu 14.04 in nm-applet.

Downgrading modemmanager helped until I rebooted in Debian..

Official bug in debian/ubuntu now but seems not easy to fix.

Including wvdial only takes a few megabytes, I believe necessary packages are wvstreams and wvdial.

As it is now users who encounter this bug must download these and install before they can access the internet from their new Salix 14.2..

Re: wvdial

Posted: 26. Sep 2016, 13:28
by gapan
I'm sorry, I don't understand. You have a problem in debian, so you want to include another package by default in Salix?

Re: wvdial

Posted: 26. Sep 2016, 17:11
by mimosa
Not sure if it's relevant, but I couldn't get 4G internet to work with NetworkManager when I was on holiday recently and that was what was provided. I tried sakis3g too, no dice.

I can't test it now, but might wvdial have helped? It appears to be in the repositories (from SBo).

Re: wvdial

Posted: 26. Sep 2016, 21:54
by coyotl
The problem is the same in all distros now it seems: a number of Huawei 4g modems (possibly others too)
do not get online with networkmanager. Not sure what the error is. Network/modemmanager
automatically sets up a connection but it's greyed out, unusable. If the user sets up a connection manually it keeps
just disconnecting on trying to connect.

Solution: PPP. Easiest way here is wvdial.

Wasn't a big deal for me to fix this, found slackware packages online using another pc and installed using installpkg. (Did not have an alternative
to the usb modem here so could not use gslapt).
Of course most users can fix this.

Re: wvdial

Posted: 27. Sep 2016, 06:16
by mimosa
coyotl, it would be very useful for other Salix users (including newbies) who may face the same situation if you could give more detail of how you got it working.

Re: wvdial

Posted: 27. Sep 2016, 19:03
by coyotl
I downloaded the packages wvdial and wvstreams (64 bit versions) ... k.txz.html ... k.txz.html

then copied my custom wvdial.conf to /etc:

Code: Select all

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = *99#
Username = netcom
Password = netcom
Modem = /dev/ttyUSB0
Dial Command = ATDT
Baud = 9600

[Dialer net]
Init2 = ATZ
Init3 = ATQ0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,"IP","netcom"
ISDN = 0
Modem = /dev/ttyUSB0
Modem Type = Analog Modem
Baud = 460800
I'm not an expert so it has 2 sections that do the same, in case I needed to add more simcards I ended up with this.
(The commands wvdial and wvdial net do the same with this config file).
Section 2 here is very simple but works on a standard provider setup.
My device name /dev/ttyUSB0 may not work, /dev/ttyUSB1 is the most common.
APN must of course be changed. And username/password set correctly (mine are random and are not needed).

Autosetup with wvdialconf seems not to work very well with usb modems, my modem cannot be setup that way.

Re: wvdial

Posted: 28. Sep 2016, 20:13
by mimosa
Thanks. By the way, those are both available as SlackBuilds (and so, soon if not yet, from Salix's SlackBuilds repository, for 14.2). The version may not be as recent.