Page 1 of 1

MEGAsync as precompiled package in slapt-get.

Posted: 31. Mar 2018, 21:07
by globetrotterdk
I have discovered that any pre-compiled (SlackBuild) dependencies for MEGAsync get updated by slapt-get versions during an upgrade and a pre-compiled (SlackBuild) MEGAsync package will not run with the slapt-get versions. As there can be a number of potential problems with installing MEGAsync as is, why not include MEGAsync as a pre-compiled slapt-get package?

Re: MEGAsync as precompiled package in slapt-get.

Posted: 31. Mar 2018, 22:53
by DidierSpaier
Hello

Just type

Code: Select all

sudo spi -i MEGAsync
This works, I just tried.

To know how it works, type

Code: Select all

man spi
Didier

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 09:32
by globetrotterdk
As I understand it, many Slackware users make Slackbuilds on one computer and use them on all of their computers. I am just pointing out that this doesn't work with Salix, as slapt-get "upgrades" any dependency packages to the Salix slapt-get versions, which aren't compatible with the main (pre-built and already installed) Slackbuild package, in this case, MEGAsync. However, as MEGAsync isn't in the Salix slapt-get repo, MEGAsync doesn't get "upgraded" along with the other packages and just refuses to run, thus requiring an uninstall and a reinstall using "sudo spi -i". If you try this with xfe, which has one dependency, fox-toolkit, both prebuilt packages get "upgraded" to the Salix version, as both are in the Salix slapt-get repo.

I am just suggesting to avoid the loose end with MEGAsync, and include it in the Salix slapt-get repo as well.

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 10:01
by mimosa
When using SBo, you may have to do some manual housekeeping, however:
http://salixos.blogspot.de/2016/08/our- ... itory.html

In any case, in this case, if you use Salix tools, it looks as though there aren't any loose ends, though I haven't tried it myself. So you have to balance the labour saved by importing your prebuilt packages against any extra housekeeping that may entail.

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 10:14
by DidierSpaier
First, this thread appears somehow as a duplicate of this one: viewtopic.php?f=16&t=7560.

Why bother again as you have MEGAsync already working? And why also a thread in LQ's Slackware forum on the same topic? You are making people spending time on already solved issues, somehow.
globetrotterdk wrote:
1. Apr 2018, 09:32
As I understand it, many Slackware users make Slackbuilds on one computer and use them on all of their computers.
Mixing packages from several repositories, built with different versions or not the same background (already installed packages when building) or not the same building options is a very well known receipt for failure. That two packages bear the same name does not make them interchangeable at all. Only do that if you are able to solve yourself the issues that can arise.
I am just suggesting to avoid the loose end with MEGAsync, and include it in the Salix slapt-get repo as well.
That would need to also provide all dependencies, like Qt, and also maintain them. I can't speak for gapan, but in my opinion that's not worth the extra work for him, especially considering that spi -i MEGAsync works.

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 13:59
by globetrotterdk
DidierSpaier wrote:
1. Apr 2018, 10:14
First, this thread appears somehow as a duplicate of this one: viewtopic.php?f=16&t=7560.

Why bother again as you have MEGAsync already working? And why also a thread in LQ's Slackware forum on the same topic? You are making people spending time on already solved issues, somehow.
To my knowledge, I do not have a topic on LQ proposing the inclusion of MEGAsync in the Salix slapt-get repo. The Salix thread was dealing with a concrete problem. Again, this is a proposal, that is why it is under "suggestions". Therefore, I am not duplicating efforts, or wasting people's time.
---
In fact, my suggestion was thought of to avoid duplicating answering related MEGAsync questions. In the repo, it just gets installed along with dependencies and managed by slapt-get, as with other programs.

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 15:26
by mimosa
Perhaps the important lesson to draw is:
Mixing packages from several repositories, built with different versions or not the same background (already installed packages when building) or not the same building options is a very well known receipt for failure. That two packages bear the same name does not make them interchangeable at all. Only do that if you are able to solve yourself the issues that can arise.
You were given the solution to the problem your suggestion seeks to address on the other thread, and you reported that it worked.

EDIT Indeed, the way spi handles software from these different sources represents as good a general solution as is probably possible, given that Salix has no control or responsibility for SBo, which is, furthermore, not a repository. Not only does it work in this case, it works in most cases.

Re: MEGAsync as precompiled package in slapt-get.

Posted: 1. Apr 2018, 16:30
by DidierSpaier
globetrotterdk wrote:
1. Apr 2018, 13:59
To my knowledge, I do not have a topic on LQ proposing the inclusion of MEGAsync in the Salix slapt-get repo.
You are right here, I saw MEGAsync mentionned in this post hence my confusion probably.
In the repo, it just gets installed along with dependencies and managed by slapt-get, as with other programs.
Believe me or not, "just get installed" actually means a lot of work for the maintainer of the repo, especially considering that its huge dependencies should then also be installed in the same repo and also updated if need be, e.g. to provide security fixes.